20USD homeassistant host (cheap dq08 tvbox / rk3528 4g ram)

Hello,

As i need a new homeassistant host, i found a powerfull tvbox that can be used as HA host.

What you need:

  • A DQ08 (got mine from aliexpress)
  • An sdcard (4g if you want to use external usb3 ssd or 32g if not)

If you’re lazy and trust my image (you shouln’t, as I can bundle malwares inside):

  • flash this using [this] (HDDGURU: HDD Raw Copy Tool) - usb2serial included
  • put in DQ08 and plug it in ethernet
  • scan for the ip using this
  • in windows terminal, using password=1234: ssh root@BOXIP
  • follow this

To build the sd card, i’ve used this tutorial:

  • install wsl on your windows
  • apply this patch
  • open wsl shell
  • install docker on wsl: curl -fsSL get.docker.com | sh
  • run docker: sudo /etc/init.d/docker start
  • permit to use docker: sudo usermod -aG docker $USER
  • open a new shell (important)
  • follow this
  • flash the img file found in Linux/Ubuntu/home/XXX/armbian-build/output/image using this
  • put in DQ08 and plug it in ethernet
  • scan for the ip using this
  • in windows terminal, using password=1234: ssh root@BOXIP
  • follow this

If, like me, you want to use an USB3 SSD:

  • flash the usb3 drive with the same image
  • plug to the box
  • e2label /dev/sda2 ssd
  • change /boot/armbianEnv.txt : rootdev=LABEL=ssd
  • reboot
  • check free size with: df -h /
  • optional: remove unused boot partition: fdisk /dev/sda + d + 1 + w + q
  • optional: remove unused data partition: fdisk /dev/mmcblk0 + d + 2 + w + q

If, like me, you have usb2serial adapters:

  • follow this but remove all parameters at the end of ./compile.sh build and during kernel configuration, enable this: Device Drivers → USB Support → USB Serial Converter Support → FTDI and PL230x
6 Likes

Hi @fensoft, thanks for the tutorial and te recommandation on the DQ08. I will keep it in my notes for my next host.

How is the stability after some days ?

much more stable than the orange pi 3b i bought 3 month ago (random reboot, at least 2 per day). i think my orange pi is broken (tried other sd, other ssd, other powersupply => no change)

i’ve just migrated yesterday, i’ll keep you informed !

These DQ08 are so much cheaper than raspberry pi’s! Like 25EUR shipped to the EU!

Am looking a this now, will the usb ports work for a ZigBee adapter?

10 days later, still working perfectly on my side. i’m using usb3 port for SSD/OS and an unpowered usb2 hub on the other port to plug zigbee+rfxcom+usb stick for backup storage.

2 Likes

Hello fensoft,

I am looking for a home asistant box diy.
Thank you for your tuto.

Have you put HACS in your image “Armbian-unofficial_24.2.0-trunk_Rk3528-tvbox_bookworm_legacy_5.10.160.img.gz” ?

If my understand is good, home assistant is only on external support, not on eMMC of this box ?

Does your box work with a Tuya Smart Gateway Hub Zigbee Multi-mode Bridge WiFi Bluetooth ?

Only for using Home Assitant , if you add usb3 ssd price to he price of this box, what is better vs x96max+ (near 50€ 4go ram 64 eMMC) ?

Thank you.
Sorry for my poor english.
Have a good day.

HACS is not installed. It’s just raw armbian just after image generation.

I can try to install armbian on internal emmc if you want but i’ ve never trusted emmc neither sd card. SSD is always the better solution for me.

About your tuya gateway, I don’ t see the link with this topic.

Hello,
Sorry for the delay in responding, I was hospitalized.
Thank you for your explanations. They will be useful to me.

Finally got my DQ08

Wrote image (unzipped .img) to 16Gb micro SD card (worked fine with my old rpi). Ejected from Win 11 laptop and put into DQ08. Plugged into ethernet and power.

But device does not get IP address.

Plugged it into HDMI and nothing on screen, nothing on digital display. Removed card and boots into original TV fine, with time on digital display.

So I am unsure if it is even doing anything or booting off the micro SD card.

Do I need to wait a while or should it all magically work straight away? Should I see anything on HDMI output?

Any ideas to troubleshoot? Anyone?

1st boot time is about 3min, i don’t know about hdmi as i’m not using it.
You can plug an usb2serial to GND / TX / RX pins inside the box to see the problem.

1 Like