433Mhz Remote Code Keeps Changing

Tags: #<Tag:0x00007f73ad008fe8>

My goal is to be able to use a 433Mhz Etekcity remote to control various things in Home Assistant so I can turn off a lamp at night without having to yell at a voice assistant. I don’t actually want to use the 433Mhz power outlets (I’ll use WiFi plugs instead since they can report their current state) just the remote.

I first tried setting up the Sonoff RF Bridge with Tasmota following Dr Zzs’ guide. Once I set that up and pressed the “1 On” button repeatededly, I get non-unique values in data and some of the other fields if they matter.

01:28:41 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:28:41","RfReceived":{"Sync":6060,"Low":220,"High":590,"Data":"505500","RfKey":"None"}}
01:28:45 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:28:45","RfReceived":{"Sync":6060,"Low":220,"High":590,"Data":"505532","RfKey":"None"}}
01:28:48 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:28:48","RfReceived":{"Sync":6060,"Low":220,"High":600,"Data":"505500","RfKey":"None"}}
01:28:54 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:28:54","RfReceived":{"Sync":6060,"Low":220,"High":590,"Data":"505500","RfKey":"None"}}
01:28:58 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:28:58","RfReceived":{"Sync":6050,"Low":220,"High":590,"Data":"505500","RfKey":"None"}}
01:29:02 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:29:02","RfReceived":{"Sync":6020,"Low":220,"High":600,"Data":"505533","RfKey":"None"}}
01:29:04 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:29:04","RfReceived":{"Sync":6050,"Low":220,"High":590,"Data":"505500","RfKey":"None"}}
01:29:06 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:29:06","RfReceived":{"Sync":6060,"Low":220,"High":590,"Data":"505500","RfKey":"None"}}
01:29:08 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:29:08","RfReceived":{"Sync":6050,"Low":220,"High":590,"Data":"505500","RfKey":"None"}}
01:29:11 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:29:11","RfReceived":{"Sync":6060,"Low":220,"High":590,"Data":"505500","RfKey":"None"}}
01:29:13 MQT: tele/Sonoff_rfbridge/RESULT = {"Time":"2020-03-28T01:29:13","RfReceived":{"Sync":6070,"Low":210,"High":600,"Data":"505530","RfKey":"None"}}

This forum post suggested trying ESPurna instead of Tasmota, but when I tried to upload the firmware via Tasmota’s web interface (even with SetOption78 1) I would get an error, Upload buffer miscompare. When I tried flashing via the pins, it felt like pressing the reset button wasn’t putting it into flashing mode, tried several times and kept getting Failed to connect errors.

So then I tried a different tack and hooked up a MX-05V to an ESP8266 running ESPhome. But when I press “1 On”, I get different codes each time.

[05:26:54][D][remote.rc_switch:243]: Received RCSwitch Raw: protocol=5 data='1000110000'
[05:31:58][D][remote.rc_switch:243]: Received RCSwitch Raw: protocol=6 data='101001001'
[05:56:17][D][remote.rc_switch:243]: Received RCSwitch Raw: protocol=5 data='11111101'

So am I doing something wrong somewhere? Or does this mean I probably can’t use this particular Etekcity remote? Is there a better way to simply get a few buttons that I can push to trigger things in Home Assistant (so far I’ve only got WiFi devices)?

your remote is probably not supported by the Arduino RCSwitch library. Since you have already a ESP8266 with an MX-05V, you could try to flash it with OpenMQTTGateway using the PiLight library.

https://docs.openmqttgateway.com/

If that does not work, you can still see if it is supported by rflink.

Thanks for the ideas. I don’t see Etekcity listed as supported by OpenMqttGateway specifically, but rflink does. If I’m looking at it right, it seems like you can’t install rflink on an ESP8266 directly though, is that right?

Yes, rflink needs a Arduino Mega

I ended up buying a couple of Sonoff 433mhz remotes from Itead instead. They are working really well so far.
https://www.itead.cc/sonoff-rm433-remote-controller-base.html