About HA Client - native Android client for Home Assistant

Tags: #<Tag:0x00007f77fe1e69a0>

IMPORTANT! #1 Please read this before you try it: https://www.google.com/search?q=what+is+beta+version
IMPORTANT! #2 It is very nice to see all of your issue reported here and in bad reviews on Google Play (actually it is not), but it is very hard to follow every issue in one forum thread.
Please report issues on GitHub and we will be able to sort it out together one by one. Thanks!

Lovelace UI is supported and is enabled by default.
Location tracking is available in version 0.7.0 or higher.

Get it on Google Play

HA Client community: Discord or current forum section

Please read documentation on connection settings and requirements.

See release notes for… release notes.

27 Likes

what are the advantages of this over just using the frontend?

If we are talking about native client at all: speed, widgets, native notifications, location tracking and so on.
But if you asking about this version: it is only alpha pre-release and you will get only speed =)

1 Like

thx.

did you know that there are others (at least 2) that already have widgets?

Yes, I know

1 Like

Where do I get an access token? I haven’t been paying much attention to the new auth system, but I am using it.

So this is a flutter app? Does it build on iOS?

It’s in the documentation: http://ha-client.homemade.systems/docs

1 Like

Awesome thanks, I should have looked harder.

1 Like

Yes, this is flutter up and theoretically it should build on iOS. But this was not tested yet.

Awasome!!!downloading

2 Likes

I get stuck with connection time out(core 1)

Something wrong with configuration I think. Which Home Assistant version do you have?

1 Like

I have the same issue, with token or api password. HA version 0.78.0
I noticed one thing. I am using duckdns domain, where you don’t have to put port number, just httpS in front. When I leave Port number empty in connection settings, HA Client dash shows “my-domain.duckdns.org:” with colon at the end? Maybe there is an issue?

Sorry guys, you don’t need to add protocol to domain. Just “mydomain.duckdns.org” without http or https.

@estevez
I (we?) don’t add “https” in front. With “https” switch to “on” or “off”, every time I get Connection Timeout, code:1. Without 8123 port, I get Error in connection, code:5.

Did you try using 443 for the port?

Which url do you use to access web version?

Make sure you have http: component enabled. See documentation for requirements: http://ha-client.homemade.systems/docs

None.

Aaaaa, of course. Got it sorted. You need to put port 443, that’s the external port, which router forward to internal port 8123. So answer is, port 443, if you are using duckdns.

Niiiiice! Thanks for help. Will update documentation

1 Like