Acces /share folder through URL

I have Motioneye setup to record video when motion is detected. It saves the files to /share/motioneye/Camera1/file.mp4.

I’m now trying to send a link to my phone when I’m not home, so I can see the recorded file. I noticed that when I open an mp4 like this: www.example.duckdns.org:8123/local/file.mp4 I can play the file. But when I try to access the file in the location /share/… like this: www.example.duckdns.org:8123/share/Camera1/file.mp4 I can’t open it.

With some help I tried making a symbolic link in the www folder with ln -s /share/Motioneye/Camera1 but still not able to access the files.

Does anyone have an idea on how I can access these files using the URL?

1 Like

Hello @baaswietse, did you ever solve this? Im trying to do the same and have no clue where to start. Thinking about some kind of folder watcher that looks for a file in /share and moves it to /www but feels like an unnecessary step.

1 Like

I’m having the same issue, cannot share images from the share folder and changing the default MotionEye folder does not work…

Hello, I was not able to solve this.

1 Like

I want to do the same thing as in OP.

I’m heading down the path of periodically copying it over from share to www. I’d never used shell_comand before. Like others, I’d rather not have to have this additonal step outside of Motioneye.