Accessing hassio after months of inactivity

If ssh is not responding, that sounds very bad.
You may have to try a hard reboot

Sorry, you didn’t actually answer francis

Yes, I can ping it. Could my SSH and Samba add-ins have switched off for some reason?

Not unless you turned them off or the pi has crashed (v. unlikely)
What response times are you getting on the ping ?
Is it wired or via wifi ?

1 ms ping time, and it’s wired

How much config did you have ?
Is it backed up ?
How big is your sd card ?
Did you have history turned off ?

A good amount of config, several third party integrations, etc.
I’m not sure how up-to-date my last backup is, but it should have most everything.
SD card is 32gb
History was on

You can attach a keyboard and use the magic sysrq key

1 Like

Stupid question but you did save the backup off the sd card didn’t you ?

If so (and even if it isn;t) hard reboot.
If it comes back you will have been lucky
else, do a new install and restore the back up

Yep, have my backups saved to dropbox. I’ll try rebooting.

try francis’s tip first

Awesome, I’ll look into this. Which command should I try - just rebooting?

I tried Alt + Sysrq + B to soft reboot, but nothing happened.

Try Alt + Sysrq + o to shutdown clean

Still nothing

My guess is corrupted SD card that went into read only mode. That then probably caused all processes but kernel to crash (so no SSH but yes pings).

Try power cycle.

If that doesn’t work, pull uSD card, mount on computer, grab snapshot tarball if available or just config files, then rebuild on new uSD.

Power cycling didn’t help. I’ll just go ahead and rebuild. Thanks for all of your help everyone!

You can use Diskinternals linux reader to try and save your config directory, so you don’t have to rebuild your configuration.

This sounds similar to what happened to me. As one of the comments said above it turned out that the logging consumed the sd cards iop making it unusable.

Unfortunately I had to start from scratch.

I think for small instances of HA a pi is fine… But anything med size (spesh with devices that log alot) you need a real ssd drive that can handle constant writing.

… or just turn off logging