Add Helpers Button Not Working

For a while now my Create Helpers button is not working. It has been a while since I used this button so I can’t be certain when it stopped working.
I do have some helpers defined in my yaml but I definitely added some here at one point.
If someone can point me in the direction to locate this problem they would be greatly appreciated. I can’t edit existing helpers either.
I am currently running the latest build on docker.


Have you tired clearing your web browser cache?

@tom_l, I have not specifically done that as I have this problem with all of my clients and did not think that may help, but I will definitely try this and report back.
Thanks for the idea.

I had the same problem with helpers. Just updated to the new Operating System 10.3 and it resolved the problem.

I am having same issue helper button in UI not working, If I clear the browser cache then the helper button sometimes works but if I close the HA page and open later the helper button doesn’t work.
Any help appreciated

Home Assistant 2023.6.2
Supervisor 2023.06.2
Operating System 10.3
Frontend 20230608.0 - latest

I attempted to clear browser cache on my phone, also cleared cache and app data for the HA app and have the same problem.
Will try to remove the helpers I still have in yaml and see if that changes things.
I am currently running
Home Assistant 2023.6.2
Frontend 20230608.0
Docker on a debian system.

An update on this. Running incognito mode on my laptop or phone browser definitely works so it looks like this is a cache issue. I am not certain what more to do on my phone to get this working. Since clearing cache, rebooting, and also clearing cache as well as app data on phone did not solve the problem. Strange that incognito does work on the devices I have tried so far.

Tried a incognito window and got the same result as you pcwii, as you say must be a cache issue but I have no idea how to cure it. This started when I updated to 2023.6

Sorry you have it, but glad I am not the only one.

Try rebooting the whole host system. Blacky reported an OS update helped, so this might do as well.

This doesn’t seem to help me. It is a docker install on an i7 PC running debian. I have restarted the pc and docker container multiple times.

Tried reboots and updated to latest OS to no avail.

There’s an issue on Github:

Have had same issue for 4 days, worked fine than next time to use creat button nothing happens

Hopefully someone will figure it out and fix, does it work if you open a incognito window this works for myself and pcwii

I used incognito mode to create the helper I needed. It is nice there is this option. I trust it will get fixed as I am not the only one with this issue.

Discovered just now when I am on the page config/helpers with the create helper button bottom right that doesn’t work, if I refresh the page helper button then works. So when you first go to helper page create helper doesn’t work refresh page then it will.

It doesn’t work in the app, not sure how to “refresh” that.
Incognito is definitely a work around for now. I will continue to monitor github for progress.

When on the helper screen slide down with your finger to refresh

That does not seem to refresh my app. I have android, not sure if that matters. Regardless if I need to make a change I will access with a browser incognito.