πŸ†•[add-on] HassOS Serial Configurator

HassOS Serial Configurator

image
Enables the Raspberry Pi Serial Port in Host Mode. You can connect an SDCard and up to two hard disks or USB drives, which are detected as sda or sdb, and they will all have Host-Mode Serial enabled when you click start.

About

This project is a part of my HassOS Configurator project. The goal of this add-on, similar to root apps on Android, is to make a mole-hill out of a mountain.

Installation

Open your Home Assistant instance and show the add add-on repository dialog with a specific repository URL pre-filled.
Within Home Assistant, click Supervisor-> Add-on Store β†’ … button (in top left)-> Repositories. Add this repository.

Click β€œHassOS Serial Configurator”, then install.

Configuration

Be sure to disable Protection Mode. There is no other configuration. This will enable Host-Mode serial on mmcblk0p1, sda1, and sdb1

Operation

Hit the start button and observe the logs. You may uninstall the Add-On when complete.

Pre-enablement state, as observed via SSH plugin with Protection Mode disabled

Post-enablement state, after hard power-off reboot

Please note, if you use previously used ttyUSB0 or ttyUSB1 for your Zigbee or Z-Wave device, they will now be ttyUSB1 and ttyUSB2, respectively. You will need to update the OZW add-on configuration.

Update: you no longer need to set the protection mode off. I made some change to app armor settings

1 Like

Thanks for this, just got my DeskPi Pro and was wondering how to get the script setup, but the output message is a little confusing, do I do the steps outlined in order, or do I do either 1 of the 2?

  1. Perform a hard-power-off now.
  2. You can uninstall and reboot now.

Hi Coolie,
I had a few issues getting this going too, but managed to figure it out in the end.

  1. Install the HassOS Serial Configurator
  2. Disable Protection Mode. This was the fix for me, as I couldn’t get it to work without doing this.
  3. Start HassOS Serial Configurator
  4. Monitor the HassOS Serial Configurator logs. You should hope to see something like this.
  5. Pull the power cable out of your DeskPi, or hold the power button for >3 seconds ie. hard power off
  6. Power on DeskPi
  7. Once HassIO has restarted, install DeskPi Pro Active Cooling
  8. Within DeskPi Pro Active Cooling, click on Configuration and configure your options. The Serial Device should be as shown.
  9. Save your config and start the service.
  10. Check the logs for DeskPi Pro Active Cooling. It should now show you your temp readings.
  11. Once everything is working correctly, go back into Supervisor and uninstall HassOS Serial Configurator

I hope this helps!

1 Like

Thanks for this, I have been struggling to get this working and protection mode was the issue.

1 Like

Hi, when I start the add-in I get this in the logs:

s6-overlay-suexec: fatal: can only run as pid 1

Can you help please? thanks

Looks like this might be related to a recent HA update …
S6-Overlay 3.x update on our docker base images | Home Assistant Developer Docs (home-assistant.io)

Is this forum still active?

1 Like

Yes. Still active and still works.

I just added this to my home assistant Pi 4 setup, it works amazingly well!

1 Like