Add-on request: nextcloud

I was wondering if anybody is working on a nextcloud add-on for HomeAssistant. I know that there are ready to use official docker images out there, but I have no idea how to best make use of them and integrate those into the HomeAssistant add-on structure. Like, it might be preferrable to use the Alpine based fpm docker images since those are better suited for IoT devices like the RPI, but I have no idea how to link it to one of the available proxy add-ons that are available for HomeAssistant. Or how to bind it to the MariaDB add-on or configure it so that it uses the SSL certs from the default HomeAssistant location. Neither have I any idea how to make it possible to f.e. point it to an attached USB drive as main storage device.

So I was wondering if any of the HomeAssistant add-on and docker cracks could give it a try? I would also welcome a small file server thingy that provides stuff via UPNP/DLNA so that it can be browsed from a random media device at home (not sure if Nextcloud does support this).

Thanks.

7 Likes

Hey @da-anda,

I stumbled on https://github.com/mtthp/hassio-addons

I’ll try it when I have the time.

oh nice, thanks, will also give it a try. I started to work on my own version of it in the meantime, but it didn’t progress much yet (like config is not yet properly forwarded from HA to the container).

Another alternative, has a few other addons as well in the same repository. https://github.com/haberda/hassio_addons

1 Like

This seems to be the more reliable version as far as I see. Unfortunately both do not seem to generate a QR-Code for 2fa.
Is it just me or does someone have the same issue?

No not just you, i dont get the 2FA QRs either.

1 Like

Got the QRs running after some fiddling around. You need to enable it in the Addons of Nextcloud:
See also: https://apps.nextcloud.com/apps/twofactor_totp

I can confirm it working with Authy now.
Nevertheless, altering the trusted domains does not work for me because I cannot find them
No matther when you restart the Home Assistant Addon or even the whole physical Machine.

I followed following instruction bit it does not help me when I cannot find it in the path…

2 Likes

I have the exact same issue. Would love to use it in combination with the Nginx add-on. But keep getting the message that the domain is not trusted.

I tried the same procedure, but also tried the instructions here:

But that did not work either. Suggestions would be more then welcome!

trusted domains worked fine for me. I am using the version from https://github.com/haberda/hassio_addons

But yeah, a more streamlined version that is better integrated into the HA add-on ecosystem would be nice on the long run

2 Likes

I tried to install NC from both these repos, and I got this error -

## Failed to install addon

<html> <head><title>504 Gateway Time-out</title></head> <body> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx</center> </body> </html> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page -->

Where did you edit it?

I retried a whole new installation (deleted the remaining files from previous installations) with SQLITE

it looks like there is no config.php

probably via SSH in the addon data folder - don’t remember exactly.

The Addons-folder is empty. So still no config.php…
It would be awesome to figure it out so everyone who stumbled upon this thread could benefit from it.

since you managed to get to the installation screen, why don’t you install it first and then mess with the trusted domains? Using your local IP should always work for installing it.

Like I stated before:
The Installation worked fine, I have installed it with SQLITE and I can enter it locally through the Class C IP Adress.
And thats the problem: I can use it locally but now (with 2fa etc etc) I want to use it with duckdns BUT the config.php is unfindable!

EDIT:

After fiddling around for something different, I enabled Developer SSH to lookup where it is.
The path is:
/mnt/data/supervisor/addons/data/1315902c_nextcloud/config/www/nextcloud/
(which is unrechable without dev ssh)

then i copied the config to a path i can easily access through SMB, edited it and copied it to the original path back and overwrote the older config.

cp /mnt/data/supervisor/addons/data/1315902c_nextcloud/config/www/nextcloud/config/config.php /mnt/data/supervisor/backup/

cp /mnt/data/supervisor/backup/config.php /mnt/data/supervisor/addons/data/1315902c_nextcloud/config/www/nextcloud/config/

1 Like

well, I had mentioned that I probably edited it via SSH in the addon data folder, which is exactly what you did now :wink:

There are now instruction for adding a trusted domain through the web gui in the readme.
hassio_addons/nextcloud/readme.md

Another alternative, has a few other addons as well in the same repository. https://github.com/haberda/hassio_addons

I’ve successfully installed this Nextcloud add-on in HassIO.

What is the procedure to add this to the menu Supervisor | “Home Assistant Community Add-ons”?
Who will maintain this add-on?

Hi Erriez
I’m not sure i understand what you asking, but hopefully this helps;

To install go to the Supervisor > Add-on Store, then use the three dot menu (top right) select Repositories and paste the link in and click add.

Nextcloud will then appear Supervisor > Add-on Store, click it and follow the instructions to install, the original developer will create updates which will be flagged in the Supervisor, where you can choose to update or not, alternately there will be a switch for auto-update.

Hi willowone,

My question is if Nextcloud can be added to the list Home Assistant Community Add-ons without adding the repository manually.