Add-Ons not starting, unable to create socket: permission denied

So I have recently installed Homeassistant with Docker and Supervisor. Install went smooth and all is working as expected - except my add-ons. I have installed a few, like Letsencrypt or UPS Tools, but all of them throw this error at me:

s6-rc: info: service s6rc-oneshot-runner: starting
s6-ipcserver-socketbinder: fatal: unable to create socket: Permission denied

I have found another thread here, that mentions the very same error. But all the steps to solve it hover around the Supervisor being buggy in a specific version and that updating solves the issue. Well, for me it does not.
I updated my docker to version 20.x, the Supervisor is on latest version now too. The network is bridged and accessible (devices are found and controllable). It really is only stopping my add-ons from running.
I‘m out of ideas what to check next.
My setup is running Debian 11 on amd64. I have installed docker through openmediavault, which seems to be standard docker though. As Kernel I use omv‘s Proxmox 5.15, because I need zfs for my data drives. (The default 5.10 acts weird on that regard)
I have very recently installed Homeassistant (after getting rid of my old OS setup), so I have nothing ‚valuable‘ on it yet. But I have tried a reinstall of docker 3 times now, so that does not seem to fix it either. (I do have a few automations and scrips to re-install once it works)

Has anyone an idea what causes this permission violation? Or how I can fix them?

You realize installing supervised on anything else than a pristine Debian 11 (not sure what you mean by “As Kernel I use omv‘s Proxmox 5.15”), with anything else running alongside (omv) is not supported, right?

I mean Supervised has gotten so many requirements/dependencies over the years that you need to be a Linux guru if it doesn’t work out-of-the-box…
And if you are a Linux guru, you don’t need addons, so you don’t need Supervised and just the HA container should do.

Home Assistant OS is supported running under Proxmox on Debian 11:

It shouldn’t be installed Supervised, as that’s unsupported.
I’d suggest installing it per the tutorial this other member wrote, that should solve the issues you’re experiencing, but may not meet your needs

@ koying
Appart from the missing permission for add-ons, it does run perfectly fine.
I am using OMV to manage my drives on a web gui. Makes things simple and easy to see. There should be no conflict, especially since it doesn‘t share software resources (at least in my case).
As for the Kernel, I understand it as a Debian default Kernel with a few packages added to work better out of the box with less mainstream, but still popular use cases - for me with ZFS, since the Kernel that Debian 11 came with is not too friendly with it. I am not running virtual software or such.
Grub lists Debian‘s Kernel as 5.10.6, whereas Proxmox‘ Kernel is 5.15

@ pickerin
Since I am running HA in docker, that video doesn‘t seem to fit my setup.
I have tried to run HA through KVM, but it seems the updated Kernel is not too happy about that. At least I have run into so many errors to fix, that a straight forward Docker install was much much easier to get running. I am left with just this one error, on which I can‘t seem to find any helpful information as to what causes it or how to fix it.

What I want is to get Letsencrypt-add-on running, so that I can automate certificate creation for secure access. Also I want Samba-add-on for quick access to the few .yaml files I need to manage (at least I don‘t know how to edit them through the HA web interface).