Add ons not working properly after snapshot restore

EDIT: The problem also occurs with a 32 bits based OS. It is related to the restore.

I see folowing error un the log
Login attempt failed Login attempt or request with invalid authentication from supervisor ( See the log for details.

And in the logs

Login attempt or request with invalid authentication from supervisor ( Requested URL: '/api/config'. (HomeAssistantSupervisor/2022.08.3 aiohttp/3.8.1 Python/3.9)

I have a raspberry PI 4, and a 32 bit home assistant installation. The SD card started showing weaknesses, so U used the recommended image from
Everything went smoothly, restored the previous backup, everything seems to be working…

But, I can’t install/access the addons any more. Even if they are started (according to their logs) HA sees them as stopped. Even if I start them, it does not do anything. I can’t access the web frontend, they all look greyed out.

I tried to uuninstall/reinstall an existing add on (Home Assistant Google Drive Backup 0.108.2), no changes. I also tried to install one fresh, it does not appear.

I cant launch the add on detail
HA sees it as stopped

But it has a log and works, the entities are here, but i just can’t acces them

`6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/

Add-on: TasmoAdmin
Centrally manage all your Sonoff-Tasmota devices

Add-on version: 0.20.0
You are running the latest version of this add-on.
System: Home Assistant OS 8.4 (aarch64 / raspberrypi4-64)
Home Assistant Core: 2022.8.3
Home Assistant Supervisor: 2022.08.3

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

cont-init: info: /etc/cont-init.d/ exited 0
cont-init: info: running /etc/cont-init.d/
cont-init: info: /etc/cont-init.d/ exited 0
cont-init: info: running /etc/cont-init.d/
cont-init: info: /etc/cont-init.d/ exited 0
cont-init: info: running /etc/cont-init.d/
cont-init: info: /etc/cont-init.d/ exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun nginx (no readiness notification)
services-up: info: copying legacy longrun php-fpm (no readiness notification)
s6-rc: info: service legacy-services successfully started
[18:18:38] INFO: Starting PHP-FPM server…
[18:18:38] INFO: Starting NGINX server…`

Did i do something wrong?
Is it a bug?


I ran into a similar issue today…

  • Was running out of space and figured a reinstall of HAOS would be the quickest path to solution
  • Did a full backup, flashed the eMMC with HAOS, restored the backup on setup
  • Add-ons are functional, show in logs, able to toggle device state, etc.
  • Unable to access any official add-on (deConZ, file editor, samba share, etc.)
  • Uninstall/reinstall does not solution

I am running an ODROID N2+ on haos_odroid-n2-8.4.

Going to look into it further today - just wanted to say something as misery loves company?

Can you add again github repo for addons ?

I removed each add-in and installed it again vial the CLI and it unfortunately it did nothing.

I am back up and running with everything functional.

Through process of elimination, I found the following worked for me:

  • I flashed my eMMC to haos_odroid-n2-8.4 again to start fresh
  • Skipped the restore on the initial setup
  • Installed all my add-ons again
  • Did a partial restore (just HA)
  • Once complete I confirmed that I could still access deCONZ and the other ad-ons that I could not before
  • Did another partial restore this time just for the add-ons

There is likely a more eloquent solution - I favoured getting things up and running vs. finding the root cause :man_shrugging:

Hope this helps!

1 Like

With 2022.8.4 the homeassistant.tar.gz is not integrated into the partial backup for me.
It used to be selectable on top of the partial backup list, now it is not there anymore, do not know if this is a bug.
I do not know when this happened, as the last known good backup I did, was with 2022.7.x
Maybe this could be your problem?

I haver the same issue and it also happened after I restored a backup

I have a similar problem with restoring a backup (I wanted to switch from RPI3 to an RPI4 + SSD).

I reinstalled the addons and restored the backup for the addons afterwards and that worked for me.

1 Like

I also encountered this problem, both with a partial restore and then a full restore. The addons that were included in the backup did not suffer problems but if I tried to install a new one, in the frontend area it always showed as stopped but from the log it had started correctly. There was no way to get a working solution except after completely resetting the SD card. In this case I preferred not to restore the backup but to import only the yaml files manually losing of course the history.

I had looked at the Addons folder and it was empty. In fact, I didn’t understand where it was writing the information after performing the restore.

Got exactly the same problem. Any solutions other than a clean install?

With the last Home Assistant OS 8.5 it seems to be solved.

I’ve not yet tried 8.5, but here is how I got going on 8.2…

  • Install HASS image on SD card. Boot and let it do initial install.
  • Partial restore on only core, no addons.
  • Install one addon at a time from the Add-On Store. Verify it is able to start. Stop it.
  • Partial restore of just that add-on. Verify it is able to start.
  • Go on to the next addon, one by one.

Today I was just cloning my RasPi4 SD card to an SSD adapter I bought from Geekworm, and in the process was met with a lot of pain due to this (what I’m going to call) bug in Home Assistant 2022.08.6 and OS 8.4. Currently 8.5 is not available to my Pi for download, without joining the beta channel perhaps.

I found through my own process of deduction essentially the same things as the above posts. I found that, compared to the process above posted by overkill32, you do need to install each addon manually, however you do not need to load each one before you restore a partial backup. Simply install them back to back, then restore those addons altogether.

The bug only happens when you restore an addon that is not currently installed. That addon will fail to Start, even though its Log will appear to be progressing normally, going back to the Info tab the Start button will be present again. Those addons will be greyed out on the Addons page as well.

Anyway, it saves a lot of time not needing to Start each one by one before restoring, at the very least. Hopefully they fix this bug soon for everyone.


i had the same issue with all my add on when I am migrating from raspberry 3 to raspberry 4 with SSD,

what I did to solve the issue is by turning off all add on then did backup on my old raspberry then on the new raspberry 4 on SSD install a fresh copy of HA and then restoring backup and once it is completed i run over all add on and turn it on one by one


Seems a nice solution. I will try that!

FYI: I’m migrating from x86 to VM on Synology

Same issue here and I am running 8.5

I was in the same situation, but after reading your messages I just tried restoring only the add-ons again. I mean, they were not working but they were restored from the landing page. When restoring them for the second time everything is working.

I hope it helps. Regards.

Thank you guys for all the tips.

Ii actually managed to get a clean working install after many tries (and reproduced iit, thanks to the inputs of @factorial, @sme79 , @Protechtedd , @overkill32 )

So the process is quite easy 'even if i still think that it should be working directly and this is a workaround). Actually for some reasons, the restore does not manage to install the addons properly. They are then fully functional (once started) but supervisor does not see them as up. So if they have an UI you cant access it (ex. Deconz, tasmota etc…)

Prerequisite: a full backup your instance

  • Get yur new syste ready (eg. Burn the new sd or whatever) and let it start
  • Do a partial restore, with everything (configuration) but the add ons. Note the addons you have
  • Install all the add ons from the addons stores (you may have to reimport custom repositories if you use community addons). No need to configure them at all.
  • Then restore the backup again, but jus the add ons this time,
    PS I am really used to HA working so well that i think this should be fixed. the issue is restoring an addon without installing it. As a developer myself (not contributing to HA because i am not a python fan, i a pretty confident this is easy to fix)

Thanks everyone for the great job


I had the same issues and was about to follow your steps.

However I did a complete shutdown and reboot of the hardware - restarting via the UI doesn’t solve the problem. And when it booted up, all the addons were back and running. Not sure if this is the solution, but in my case it seems it a hard reboot fixed it.


Upgraded from Rpi 2 → Rpi 4 can confirm hard reboot fixed the problem.