Adding matter device not working

aloha,
Installed my new nuki pro 4 smartlock today and wanted to try out its matter integration:

  • running a skyconnect with latest openthread firmware
  • on HA I installed open thread border router add-on and the HA matter integration
  • on starting the matter integration it asks to install the HA matter add-on
  • once everything is (to my understanding) setup in HA …
  • in nuki app starting the matter integration - which is already a bit weird to me as it just states to scan the QR code and reference only google home but not home assistant
  • so I tried (as I am used to from z-wave) to just manually add a new device within matter integration
  • and there it is just asking me to select the select the connection method (see screenshot)
  • and then just tells me that it has successfully reconfigured the matter integration…

how is a new matter device included ?

thanx in advance




You need to go to the Home assistant settings page, devices list and add a device there. You can pick matter and follow instructions. Curious how you fare. I added it through a nest hub 2 as border router, but it periodically becomes unavailable.

2 Likes

ok thanx for this hint:

  • found it on the mobile app
  • tried to scan the QR code on the nuki box but it tells me that this is invalid
  • and it says to find the 11 or 22 digit pairing code of the matter device

no clue where to get this from but will contact nuki and ask them

i keep you posted

The qr code is in the box with the manual on a separate card, not on the box.

I’m wondering if this is a Thread issue… in your HA Thread Integration (not AddOn), does it have a “Preferred Network”… Take a look at UI->Integrations->Thread->CONFIGURE Does it have “home-assistant” under “Preferred network”?

I used the Companion app app to join the network of the Nest Hub 2 border routers as I do not own a SkyConnect and my Sonoff Dongle E is configured for Zigbee only. So the nest border routers are my preferred network.

Edit: I used the three dot menu to import the credentials from it if I remember correctly. Maybe you need to do something similar with your SkyConnect?

And did you find the right QR in the manual box?

If you’re only using SkyConnect w OTBR AddOn (No other TBR), then the OTBR will already generate its own credentials, I just can’t remember if you have tell HA to set it to Preferred or not.
The Commissioning Apps get the Thread creds from HA Thread Integration set to Preferred.

The other thing to check is that since the Nuki App didn’t see Home Assistant after scanning QR code, I’m wondering if IPv6 is setup on HA. HA should be advertising its “meshcop” using mDNS via IPv6 over the layer 2 network for the App to see. Also, the mobile device running the Nuki App has to be on the same layer 2 network as HA.

I know I tried several things and if I remember correctly the Nuki app did not show HA either, at least not initially. I had to reset my Nest hubs (for different reasons) in order to get it to work. But I added though HA afterwards, so I’m not sure if HA was there in the Nuki later on, so I didn’t check. The Nuki website it only supports the ones you see. But that is clearly wrong, I got it working. The initial problems could have been for two reasons:

I had factory reset the router for some other problems and restored a backup on it. The hubs may not have reregistered with dns properly afterward, requiring them to reboot.

I also have problems with mdns only working a certain time after a device reboot. I have several esp32 devices suffering from the same thing, ESPHome no longer seeing them after a while. Others work just fine. I see more reports from people suffering the same fate. Maybe my Fritz!Box is not so good with mdns, it could also be my switches with IGMP snooping on (required for iptv) messing things up.

Mdns trouble may be why my connection is not very stable.

Ipv6 settings for HA can be checked on the network tab in settings. It must be set to automatic or static.

If I remember correctly, I opened the Nuki app to add matter (I assumed it was needed to activate matter an/or enter pairing mode). But HA wasn’t there, so I left the page open, manually opened HA, went to devices and continued the process there. After that the Nuki app showed Matter was configured.

(After looking back at some notes), a non-HA mobile App for Matter/Thread will not find HA Matter Server, but it is possible (but may be App dependent) for it to find HA’s Thread Network, get the Thread Creds from HA’s Thread Integration, and commission the Device onto the HA Thread network, and if successful, it may ask you to choose another App to do the Matter Commissioning, and from the list should be HA Companion App, and from there do the HA Matter Add Device as you mentioned.

did the same and it nearly worked … but instead of your successfull integration I ended up with an error in the nuki app … will try again and post some more details once i am back home
thanx

1 Like

Did you ever get this working? Could you post steps?

yap …
attached screenshot pointed me to the right track