Adding Moes Rad Valve TSO601


I’ve bought a few Moes TS0601 Rad Valves with the ID _TZE200_zion52ef. This ID is talked about in a few places but no-one has described successfully getting it to work.

I’ve tried adding them in both ZHA and Zigbee2MQTT and they don’t work in either. Z2M complains that the model doesn’t exist and constantly errors. ZHA correctly identifies the devices but doesn’t bring up any entities.

I’m a bit stuck as to where to go next. Can anyone guide me through getting them working?



TRV support has been extended in latest zigpy library (used by ZHA) and will be available in next HA release. If, after you update and reconfigure or re-add the device to ZHA it is still not correctly recognized you can open an issue here: Issues · zigpy/zha-device-handlers · GitHub after reading the documentation

1 Like

Thanks for the info. I’ll await the next release, which I assume is happening on Dec 11.

Hello, I think our issues are related. I just made a similar post, here: Switch Zigbee TZE200 TS0601 paired but without entities - #28 by Sergeantpup

You referenced a release in dec. Was not that the one to resolve this?

It didn’t solve my problem, no. It’s still not supported in either ZHA or Zigbee2MQTT. At least it wasn’t last time I tried a few weeks ago.

I had to buy another rad valve in the end. I still have two more of the other type on radiators but they’re useless until I can find out how to get them working. I should try to open an issue in GitHub but the whole process is very opaque to me.

Hello and thanks for your response.

Well lucky for us, I work in software and opening issues is my specialty lol. Unfortunately, I don’t have the option to abandon the devices. I am several thousands of dollars committed and the other devices work, I just need to get the problem worked on or keep the 3 remaining devices on HE until a fix is in place.

With the information you’ve provided in mind with my own troubles, I can write a story for all 3 devices that are having the issue. I can probably gather all the details and submit it by this weekend.

Here’s a brief summary:

  1. I have 4 curtain rails model TS0601. 3 of them work fine in HA. The 4th pairs without entities. Verified the device runs on hubitat hub. All devices are branded zemismart but the manufacturer id for the device in question is different than the others. I believe this is related to the device not being read correctly in the library.

  2. I have 2 zemismart curtain shades (brand new) that pair to HA without entities. The device model on these is also TS0601. I will do further research on the manufacturer ID and also try to pair it to hubitat and provide those findings with the story.

  3. You have a device (that appears to be a water valve?) With model TS0601 that’s missing entities when paired with HA.

Signal strength has been ruled out by pairing it within the same room. Both users have zigbee networks that are running fine with no other pairing issues besides these specific devices.

If you want me to include anything else, just reply here. I’ll let you see it all before I submit it and I’ll send you a link afterwards.

1 Like

I found another identical issue already open and I added our info to it: [Device Support Request] TS0601 Cover. Zemismart (Tuya) TZE200_5zbp6j0u curtain motor · Issue #1245 · zigpy/zha-device-handlers · GitHub

1 Like

Fantastic work, thanks!

if you want to create the quirk yourself, we did a lot of leg work last night that can probably be applied to your situation (just change the guts):

The local quirk IS being read and it wasn’t too difficult.

Thanks for the update. I’ve checked the thread but I’m not sure what you’re doing. I can see where I might edit the details but I have no idea what to do with the resulting file!

It’s actually the easiest implementation for hosting custom local quirks that I could find:

Just create a new folder for custom quirks

Point ZHA to custom quirks in config.yaml


1 Like

So I finally got around to trying this out and no joy.
I created the quirks folder with the tuya folder inside it. I added the line to config.yaml. All easy so far.
I then found what I thought was the right file from the github repo ( and copied it to my local machine. I edited the file and added the line:
("_TZE200_zion52ef", "TS0601"),
in the list of devices.
I then rebooted and added the device by repairing it. It added but the state is no different than it was before :confused:
Is there anything else I should be changing in the file?

No, this is where we’re at too [Device Support Request] Zemismart Curtain Motor with Rail (Mains powered) (_TZE200_rmymn92d) · Issue #1294 · zigpy/zha-device-handlers · GitHub. We had some hiccups with 2022.4 and the new quirk structure borked my ZHA. Julian fixed the quirk and now it’s acting as it was prior to 2022.4. It’s accurately tracking state and does have an entity but it’s throwing weird errors and not controlling the device. This has been confirmed by multiple users. A user using the MQTT version of this device says it’s working and I’m thinking we just need a change/update to the code.

So I’d call it still a work in progress. Is your device using the new quirk sending weird ‘sending tuya’ commands that don’t make sense in the logs when you press non-reactive buttons?

1 Like

Ah, OK. That might explain it then. Let me know if you get any further and thanks for the assist so far!

I have two moes TS0601 radiator valves and I was able to add it to my zigbee network without any issue. The problem might be your zigbee cordinator.

What is their ID, @ddaniel ? Are they _TZE200_zion52ef ?

in zigbe2mqtt they are listed as “_TZE200_b6wax7g0.” I believe its the same type, but the only difference is a cordinator.
Maybe you have poorly cordinator.
@LeeJS this is the one i bought ✅ Zigbee CC2652P Coordinator v4 USB Dongle Stick Home Assistant! DARMOWA WYSYŁKA! | eBay

Well that’s why yours works and mine doesn’t, then. They are different models with different IDs. There are dozens of TSO601 TRVs that run ZigBee. Just because one works doesn’t mean they all do. The ID must be specifically referenced or a quirk created for it. You got lucky in that someone has already added your device’s ID to the code. Mine has not.

I think you are on the wrong track. I have two of those and they have the same id. Those are the same devices. I have 40 zigbee devices from various manufactures, some flashed sonoff devices and everything is working fine.
I believe you problem is zigbee cordinator. When I was buying zigbee cordinator in the doc was stated that you should buy cordinator based on 26 chip. That one I bought. I use some aquara and sonoff smart plugs as routers and everything is working fine,

I don’t know why the coordinator would make any difference? The protocol is the protocol and it runs in software, not hardware. I run one of these: