Adding Remote Access to Network UPS Tools - RESOLVED

I’ve installed and configured Network UPS Tools so that HA is Master. I’d like have my QNAP NAS monitor the UPS as a slave unit to HA. How do I go about adding a remote access account to Network UPS Tools?

Note: The QNAP NAS has been configured as a slave. I tried setting the Network UPS Tools user as ‘admin’ with a password of ‘123456’, which is what the QNAP credentials are, but PWNED protection in HA prevents use of the QNAP password.

RESOLVED - there is a setting in the Network UPS Tools config file that I missed in the documentation. It is i_like_to_be_pwned. When set to ‘true’ the short password used by the QNAP NAS is accepted, the server starts and the QNAP connects as a slave to HA Network UPS Tools. Adding the following to the config file worked wonders;

i_like_to_be_pwned: ‘true’


Thanks for sharing @rcblackwell

Can you please share your configuration under “Network UPS Tools” (which driver etc.)
as well as what ever config is required and what it offers you eventually?

(I have a QNAP NAS and hoping to use it to expose UPS status to HA so I can automate power outage actions - is that possible??)

Looking forward to learn more on what I can do with this!

This should be possible. My configuration is the opposite way around. The UPS is connected to the Home Assistant device using the NUT integration. It’s configured as Master on that device (HA Blue). On the QNAP I’ve set the “Network UPS as Slave”. In the “IP address of the UPS” field, I entered the IP address of the HA device. On HA I see;

On the QNAP I’m able to see;

Hope this helps.


Thanks for getting back to me on this @rcblackwell !

I am wondering, are you able to learn based on the diagnostic information if the UPS kicks off during power outage, or just monitor the various numeric data and settings?

Also, can you share the Addon config? – (mainly - driver, mode & port)

have you set the network host port or did the Qnap get access to the HA host without it?

I tried 2 setups:

  • If the NUT is connected to the HA device, I guess you are using the Addon?
    in that case I am able to see the UPS integration on HA but QNAP can’t seem to pull any data (nothing displayed under “UPS information”

    • What’s the Addon configuration if so?
      What drivers / users do you have setup under the addon? any port specifications changed?
    • any idea how I can diagnose what’s keeping HA from getting data from the HA master NUT?
  • If U connected the UPS to QNAP, I see the UPS information in qnap but can’t seem to pull the data on HA
    • in this case QNAP is the NUT master (connected via USB), the HA IP is whitelisted for UPS services
    • when I setup the integration in HA and add the QNAP IP - I get unexpected error :confused:

That would be correct. Here’s a screen shot of my QNAP configuration page;

In HA I’m using the Nut UPS Configuration;

HA UPS Config

Be sure to add the IP address of your HA server, not the IP shown in the picture.

This results in the following entities being added;

The user name for the integration is “admin”, without quotes.

The password is “123456”, without quotes.

When configuring the Nut UPS integration be sure to set i_like_to_be_pwned: ‘true’ otherwise you won’t be able to complete the configuration.

I finally made it work,
seems like on top of all above pointers, device name should be set to “qnapups” for QNAP to connect (along with the admin user & insane password)

  - config: []
    driver: usbhid-ups
    name: qnapups
    port: auto
mode: netserver
shutdown_host: 'false'
  - actions: []
      - all
    password: '123456'
    username: admin
i_like_to_be_pwned: 'true'
1 Like

Worked for me – thanks!

Thanks for spending the time on this… your config works!

Hello Everyone… Attempting to set this up on my HA Yellow, with the UPS connected to the Yellow USB port. Followed this thread and the Network UPS Tools config to the letter. But no matter what I do nothing works?

Here’s my config…

  - actions: []
      - all
    password: "123456"
    username: admin
  - config: []
    driver: usbhid-ups
    name: qnapups
    port: auto
mode: netserver
shutdown_host: "false"
i_like_to_be_pwned: "true"

Here’s my logs…

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/
[10:59:51] INFO: Setting mode to netserver...
[10:59:52] INFO: Generating /etc/nut/upsd.users...
[10:59:52] INFO: Configuring user: admin
[10:59:54] INFO: Configuring Device named qnapups...
[10:59:54] INFO: Starting the UPS drivers...
Using subdriver: CyberPower HID 0.4
Network UPS Tools - Generic HID driver 0.41 (2.7.4)
USB communication driver 0.33
Network UPS Tools - UPS driver controller 2.7.4
cont-init: info: /etc/cont-init.d/ exited 0
cont-init: info: running /etc/cont-init.d/
cont-init: info: /etc/cont-init.d/ exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun upsd (no readiness notification)
services-up: info: copying legacy longrun upsmon (no readiness notification)
s6-rc: info: service legacy-services successfully started
[10:59:55] INFO: Starting the UPS information server...
   0.000000	fopen /run/nut/ No such file or directory
   0.001530	listening on port 3493
   0.002606	Connected to UPS [qnapups]: usbhid-ups-qnapups
[10:59:55] INFO: Starting the UPS monitor and shutdown controller...
   0.000000	fopen /run/nut/ No such file or directory
   0.000896	Using power down flag file /etc/killpower
   0.001411	UPS: qnapups@localhost (master) (power value 1)
   0.001621	debug level is '1'
   0.001643	Warning: running as one big root process by request (upsmon -p)
   0.002613	Init SSL without certificate database
   0.008070	Trying to connect to UPS [qnapups@localhost]
   0.048540	User [email protected] logged into UPS [qnapups]
   0.011674	Logged into UPS qnapups@localhost

And here’s what I see on my QNAP…

I am unsure of what I am doing wrong? But no matter what, the UPS never appears in the QNAP “UPS Information” area?


Looks to me like the HA Yellow is not making port 3493 available to the QNAP?

nc: connect to port 3493 (tcp) failed: Connection refused

I have tried a few ways to verify port 3493 is available on the Yellow, but all fail.