Adding resources to lovelace

Hello, I have updated my hassio to version 0.107.4. Until this version it was possible to add resources like

resources:

  • type: js
    url: /local/gardena-mower-card.js?v=0.3

to the configuration of the overview. Now, if add the code above, I get the message that resources should be put to lovelace configuration window instead.

I do not know the lovelace configuration window. Where can I find it? Any help is appreciated!

2 Likes

config/lovelace/resources

Screenshot_20200323_145808

its here on ha core.

2 Likes

Or you can edit configuration.yaml and add your resources there. Example:

#
# Enable lovelace User Interface
#
lovelace:
  mode: yaml

#
# Add-On for lovelace
#
  resources:
    - url: /local/auto-entities.js
      type: module
    - url: /hacsfiles/weather-card/weather-card.js
      type: module

1 Like

I would like to configure my dashboards with the help of ui editor. If i switch to yaml, this is not possible anymore. So, I think I have to put resources using the url config/lovelace/resources. I am a little bit confused since I cannot see the tab resources but dashboards. If I enter the url in the browser I can switch to resources. Does anyone know why the resources tab is not shown in hassio 0.170.4?

Many thanks for your help!

On the underside of the page there are 2 icons. One to select dashboards, one to select resources.

1 Like

I do not see any underside for resources :frowning:

Right one on the underside.

You need to enable “Advenced mode” in your user profile to see the “Resources” tab.

5 Likes

I have the same problem on 0.108.9, but I can’t figure out how to enable “Advanced mode” for my user profile. I am the admin user, and I see the tabs like “Developer Tools”, “Configuration” etc in the menu. I can’t find an “advanced mode” setting in Configuration -> Users or anywhere else.

I also have a custom card that I need to add resources for (converting from the ui-lovelace.yml), but the “Resources” tab is missing for me, too.

1 Like

Ah, that’s where that setting is. Wow, that was difficult to figure out… :wink: Thanks so much!

Is there any way to reload without restarting editing configuration.yaml?

1 Like

anyone ever figure out the answer for this ?

Well there’s a post marked as the solution. So I’d say, yes.