Adguard listening on 127.0.0.1 instead of the hassio ip?

Hello Fam,

I have hassio running on a RPI4 (IP reserved on Nest Wifi to 192.168.86.27). The Adguard Home was installed running successfully for more than 2 months now. When I opened it today - I noticed it stopped working at 3 in the morning and auto reset everything. The setuo guide section now says it’s litening in 127.0.0.1. First of all - WHY and HOW?
I tried to uninstall and reconfigure. It still is listening on that IP. I tried to set my DNS on my Nest Wifi to that but it is not not filtering nor listening. How do I fix it? ANy help would be appreciated. Pretty please.

2 Likes

Just a me too here. Mine has been running fine for over a year and about a week ago just stopped. I noticed that it’s listening on 127.0.0.1 and see no way to change it. I run under Debian supervised and DO have a static IP set as well as external DNS servers set (9.9.9.9, 1.1.1.1)

Edit: I have also removed/re-installed the adguard add on with no change

I have the exact same issue - let me know if you ever figure out a way to fix this please!

Same here. It stopped working a few weeks a go and so only listening to 127.0.0.1, not to my hassio Pi IP address anymore. I did a reseach the whole day and did not find a solution.
I now installed Raspbian & AdGuardHome on a second Pi and it directly worked. But I’d like to get it back into Home Assistant agan :-/

hi any solution to the above?

Go to Adguard/Conf/AdGuardHome.yaml and edit the file adding your expected local IP address in the section dns: bind_hosts: restart Adguard image after that.

I cannot find this file, where can this be found?

I am using Debian so for me the exact location of this file is:

/usr/share/hassio/addons/data/a0d7b954_adguard/adguard/AdGuardHome.yaml

if you using a different installation it can be somewhere else.

go to addons and supervisor, click adguard, go to configuration, edit yaml and set bind_hosts to 0.0.0.0

certfile: fullchain.pem
keyfile: privkey.pem
ssl: true
dns:
  bind_hosts:
    - 0.0.0.0

Instead trying to force ad config value you. I chose to follow these steps https://www.reddit.com/r/homeassistant/comments/oeptmi/comment/h4bdhd8/?utm_source=share&utm_medium=web2x&context=3 which worked for me. All it required was saving the configuraiton page one time. Could probably save the configuration page before starting the first time and would solve the issue as well