ADT Pulse integration


#62

Interesting - I’m not getting that output at all for ADT, but for my Sonoffs I do.

#mosquitto_sub -h 10.1.30.194 -v -t "#"
tele/sonoffofficetv/LWT Online
cmnd/sonoffofficetv/power ON

#63

Are the topic names the default in the addon config?

{
  "ssl": false,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "pulse_login": {
    "username": "",
    "password": ""
  },
  "mqtt_host": "core-mosquitto",
  "mqtt_connect_options": {
    "username": "",
    "password": ""
  },
  "alarm_state_topic": "home/alarm/state",
  "alarm_command_topic": "home/alarm/cmd",
  "zone_state_topic": "adt/zone",
  "smartthings_topic": "smartthings",
  "smartthings": false
}

#64

Yes - I haven’t modified any of the above.


#65

As you can see in some of my previous posts above I was having some weird MQTT issues, and I was not able to get things going until I did a series of restarts and MQTT flushes. Not saying that you have the same issues. Just that there can be oddities that occur with MQTT apparently. Especially since you have experimented with your sensor calls in different parts of your configuration.

Maybe try stopping the addon (and set it NOT to start on reboot) and comment out references to it within your configuration.yaml. Then reboot your HA device, flush the related MQTT topics, and proceed to start the addon. Then see if you can get the sensor dump. After that start adding (uncommenting) the code in configuration.yaml.

I think my issues were also related to using my current ADT login credentials within the addon. I created a new logon user account for the ADT Pulse portal and use that one in the addon config.


#66

I also see no authentication issues to MQTT in the log of the addon either, where before when I had the wrong username/password - it showed auhentication errors.


#67

Interesting - but fair and I thought the same in regards to rebooting the system. I’ve noticed with a few things sometimes, until there is a full reboot, things don’t work smoothly.

In this case, it seems like something isn’t complete. The config for sensors in the yaml is normal. I’m always strugglng making sensors and their configs work.

As for the username/password for ADT Pulse, that’s working - I can issue MQTT commands with no issues from within Hass.io and enable/disable the system.

Rebooting now - I’ll report back results! Thanks for your help!


#68

It’s possible that not having the right credentials caused it to fail to retrieve the sensor dump on initial start up of the addon.


#69

I had it working initially, too. But I think logging into my ADT Pulse from my phone/pc, while troubleshooting may have been causing conflicts. A separate login account seems like an easy way to avoid any conflicts.


#70

I’ll consider that if issuing commands start failing. Right now MQTT or something else seem to not be working.

Reboot didn’t work. So so strange. I’ll keep at it.

Thanks for the help!


#71

Hey! Your idea worked! Creating a new username finally pulled the sensor information!

018-7-25 12:42:53 Pulse.getAlarmStatus: Getting Alarm Statuses
2018-7-25 12:42:54: Pushing alarm state: disarmed to home/alarm/state
2018-7-25 12:42:54 Pulse.getDeviceStatus: Getting Device Statuses
2018-7-25 12:42:54 Pulse.getZoneStatus: Getting Zone Statuses
2018-7-25 12:42:54 Pulse.getDeviceStatus: Getting Device Statuses
2018-7-25 12:42:54 Pulse.getZoneStatus: Getting Zone Statuses
2018-7-25 12:42:54: Pushing  adt/zone/Downstairs Interior Door/state to {"id":"sensor-9","devIndex":"14VER1","name":"Downstairs Interior Door","tags":"sensor,doorWindow","status":"devStatOpen","statusTxt":"Downstairs Interior Door - Open\nLast Activity: Today 10:01 AM","activityTs":1532527309187}
2018-7-25 12:42:54: Pushing  adt/zone/Back Door/state to {"id":"sensor-26","devIndex":"16VER1","name":"Back Door","tags":"sensor,doorWindow","status":"devStatOK","statusTxt":"Back Door - Closed\nLast Activity: Today 11:23 AM","activityTs":1532532229209}
2018-7-25 12:42:54: Pushing  adt/zone/Basement Motion Detector/state to {"id":"sensor-25","devIndex":"11VER1","name":"Basement Motion Detector","tags":"sensor,motion","status":"devStatOK","statusTxt":"Basement Motion Detector - No Motion\nLast Activity: Today 12:36 PM","activityTs":1532536592122}
2018-7-25 12:42:54: Pushing  adt/zone/Front Door/state to {"id":"sensor-7","devIndex":"12VER1","name":"Front Door","tags":"sensor,doorWindow","status":"devStatOK","statusTxt":"Front Door - Closed\nLast Activity: Yesterday 3:39 PM","activityTs":1532461160003}
2018-7-25 12:42:54: Pushing  adt/zone/Garage Door/state to {"id":"sensor-8","devIndex":"13VER1","name":"Garage Door","tags":"sensor,doorWindow","status":"devStatOK","statusTxt":"Garage Door - Closed\nLast Activity: Today 6:33 AM","activityTs":1532514814960}
2018-7-25 12:42:54: Pushing  adt/zone/Garage Exterior Door/state to {"id":"sensor-10","devIndex":"15VER1","name":"Garage Exterior Door","tags":"sensor,doorWindow","status":"devStatOK","statusTxt":"Garage Exterior Door - Closed\nLast Activity: 6/15 4:41 PM","activityTs":1529095304656}
2018-7-25 12:42:54: Pushing  adt/zone/Hall Smoke Detector/state to {"id":"sensor-4","devIndex":"E9VER1","name":"Hall Smoke Detector","tags":"sensor,fire","status":"devStatOK","statusTxt":"Hall Smoke Detector - Okay\nLast Activity: 8/18 2:17 PM","activityTs":1503080266282}
2018-7-25 12:42:54: Pushing  adt/zone/Living Room Motion/state to {"id":"sensor-24","devIndex":"10VER1","name":"Living Room Motion","tags":"sensor,motion","status":"devStatOK","statusTxt":"Living Room Motion - No Motion\nLast Activity: Today 12:03 PM","activityTs":1532534618303}
2018-7-25 12:42:54: Pushing  adt/zone/Indoor Camera/state to {"id":"camera-21","devIndex":"099B31","name":"Indoor Camera","tags":"camera,ip","status":"devStatOKcamera","statusTxt":"Indoor Camera\nLast Activity: Today 6:33 AM","activityTs":1532514813759}

Also see it in the console!

This is great! Now to get the sensor configs working!

Thanks again!


#72

Awesome! Have fun with it.


#73

Ok - Got it!

Here is the final config in binary_sensory.yaml.

  - platform: mqtt
    sensors:
    name: "Interior Garage Door"
    device_class: door
    state_topic: "adt/zone/Garage Door/state"
    payload_on: "devStatOpen"
    payload_off: "devStatOK"
    value_template: '{{ value_json.status }}'

Here are the options I can trigger it seems
image

I did notice, if I try to issue arm_night or another comand other than arm, away or disarm, the addon crashes - which was a bummer, but it’s OK. It good that I can automate more of the common alarm modes.

I can move it into Node-Red and create my “Good Night” automation and enable the alarm! It won’t be “night” mode, but “home” is good for now.


#74

I didn’t try any of the other modes that are part of the alarm_control_panel component. I figured they wouldn’t work since there were no corresponding MQTT topics for them.


#75

Makes sense… Well - hey - this is better than what I’ve had before, so I’m more than happy. Can setup some cool things now.

Thanks again for your help!


#76

I don’t have any other options than Arm Away and Arm Stay in ADT Portal
How do you enable Arm Night option?


#77

I enable it via keypad CODE+33

That enables “Night Stay”. Difference is that as soon as specific doors are opened, the alarm goes off, no delay - it’s instant.


#78

Firstly: Thanks for the awesome work on this!

I am attempting to implement this and I seem to be running into an issue with parsing the response for the “sat” value.

sat = body.match(/sat.+value=\"(.+)\"/)[1];

The regex returns no value.
If I pull the code down, hard-set my “sat” value from the response and execute in a local node environment it works fine.
What am I missing?
Thanks for your review of this.


UPDATE:

For the data queried from ADT, the following line returns the proper data for me.

sat = body.match(/sat.(.+?(?='))/)[1];

The snippet from the Response body is the following (I have sanitized the “sat” number):

"setShiftState('changeModeRRA.jsp?sat=d123c456-abc7-89ca-a0ef-d4aa9b2f1d34','','');"

Is this a normal format for this number?
Thanks again.


#79

@geekweaver
Hey there. I was working on this. I just fixed it. Please look for the next update. v0.2.0.1


#80

Hi everyone,

thank you for everyone chiming in helping/bug reporting/fixing.
I created issues page in github. You’re more than welcome to file bugs and feature requests.

PS: Just pushed 0.2.0.1… bugfix for sat values.


#81

@haruny
Thanks for the update. I have just pulled down, but still see the same issue.
I will submit an bug / issue on github with info.
Thanks again!