Aeotec smart switch 6 - ZW096-B09 - don't work properly

Tags: #<Tag:0x00007f739803f3a0>

Ok, I have about 8 of these things and I have constant issues with them. They are super annoying and I am hoping someone else has had experiences and being able to resolve them. They detect as zwave.aeon_labs_zw096_smart_switch_6 in HASS.

I only seem to be able to use them if they are within 10 meters of the ZWave controller. I add them to the network at the controller/at my desk and then when I try to move them out as soon as you try to use them they turn up as a dead node, the ZWave controller can not find it, you get an error as below:

2020-03-15 16:54:52.489 Info, Node033, WARNING: ZW_DELETE_RETURN_ROUTE failed. No ACK received - device may be asleep.
2020-03-15 16:54:52.489 Warning, Node033, WARNING: Device is not a sleeping node.
2020-03-15 16:54:52.490 Detail, Node033, Removing current message
2020-03-15 16:54:52.494 Detail, Node033, Queuing (Command) ControllerCommand_AssignReturnRoute (Node=33): 0x01, 0x06, 0x00, 0x46, 0x21, 0x01, 0x38, 0xa7
2020-03-15 16:54:52.498 Info, Node033, Sending (Command) message (Callback ID=0x38, Expected Reply=0x46) - ControllerCommand_AssignReturnRoute (Node=33): 0x01, 0x06, 0x00, 0x46, 0x21, 0x01, 0x38, 0xa7
2020-03-15 16:54:52.513 Detail, Node033,   Received: 0x01, 0x04, 0x01, 0x46, 0x01, 0xbd
2020-03-15 16:54:52.513 Info, Node033, Received reply to FUNC_ID_ZW_ASSIGN_RETURN_ROUTE - command in progress
2020-03-15 16:54:52.630 Detail, Node033,   Received: 0x01, 0x05, 0x00, 0x46, 0x38, 0x01, 0x85
2020-03-15 16:54:52.630 Info, Node033, WARNING: ZW_ASSIGN_RETURN_ROUTE failed. No ACK received - device may be asleep.
2020-03-15 16:54:52.630 Warning, Node033, WARNING: Device is not a sleeping node.
2020-03-15 16:54:52.631 Detail, Node033, Removing current message
2020-03-15 16:55:18.904 Info, Node033, NoOperation::Set - Routing=true
2020-03-15 16:55:18.904 Detail, Node033, Queuing (NoOp) NoOperation_Set (Node=33): 0x01, 0x09, 0x00, 0x13, 0x21, 0x02, 0x00, 0x00, 0x25, 0x39, 0xda
2020-03-15 16:55:18.905 Info, Node033, Sending (NoOp) message (Callback ID=0x39, Expected Reply=0x13) - NoOperation_Set (Node=33): 0x01, 0x09, 0x00, 0x13, 0x21, 0x02, 0x00, 0x00, 0x25, 0x39, 0xda
2020-03-15 16:55:18.916 Detail, Node033,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-03-15 16:55:18.916 Detail, Node033,   ZW_SEND_DATA delivered to Z-Wave stack
2020-03-15 16:55:22.997 Detail, Node033,   Received: 0x01, 0x07, 0x00, 0x13, 0x39, 0x01, 0x01, 0x99, 0x4b
2020-03-15 16:55:22.998 Detail, Node033,   ZW_SEND_DATA Request with callback ID 0x39 received (expected 0x39)
2020-03-15 16:55:22.998 Info, Node033, WARNING: ZW_SEND_DATA failed. No ACK received - device may be asleep.
2020-03-15 16:55:22.998 Warning, Node033, WARNING: Device is not a sleeping node.
2020-03-15 16:55:22.998 Error, Node033, ERROR: node presumed dead

There are plenty of other zwave devices around the network is working really well these days due to some upgrades but these GPO’s are the last remaining thorn in my side. Any ideas? Thanks

I have 2 of these and are really shitty. Try updating the firmware in case it might fix some problem. I still use them but I don’t buy new ones, just add Xiaomi sensors which are extremely reliable and battery last forever

When I first got mine, I found that in some locations, 10 feet was about as far as it would work properly, but I found in my washing room, around 10 meters away it surprisingly worked well, so I use it to monitor the washing machine and report when its cycles have completed. No real issues with it at this point.

Having said that, I have other ZWave devices that also have communications issues beyond around 15-20 feet, so I’ve concluded its not just the Smart Switch 6. I have added a Range Extender to help out, and I’ll probably add more in the future.

where do I find firmware updates? I have tried looking for some before… Can you link the Xiaomi device you are using? THanks

ok, after converting all your ‘feet’ to ‘meters’… 3 to 6 meters! WoW! I have some a few more than that. 10-15 meters (so up to 50 feet).

Do you mind linking the Range Extender? I am in Australia so I sometimes find that some things are just not available due to our regulation, etc.

I added the Range Extender-7 from Aeotec about a month ago:
https://aeotec.com/z-wave-repeater/
The Webpage says “coming soon” but it is already available on Amazon.

1 Like

It looks like we are correct in saying, these things just have horrible range. I tried a different location with another routing slave within 2 meters of it and it works fine but my original location has nothing for 5 or so meters and just disappears off the network all the time.

Ok, duely noted. Thanks

I find this comment interesting, how are you doing that? Do you have an automation example? :slight_smile:

I will at least describe it for now (I can provide the automation yaml later)…

  • I use the Smart Switch 6 to provide power measurements (seldom use the on/off capability) and I have it periodically (I believe once per minute) send power status (in W). I have setup a sensor in HA to represent this power status.
  • Automation1: When Power goes above 0 W for 1 minute, I set an input_boolean to true. This is just to prevent false triggers because the sensor will occasionally read >>1W on my power line when the washing machine is not running.
  • Automation2: When Power goes below 1W for 6 minutes and the input_boolean is true, I declare the washing cycle complete (set the input_boolean to false) and perform any other action. In my case, I have Alexa make an announcement.

The trick for me at least, was determining the 1 minute/6 minute values. I did this by checking the sensor’s history over a few weekends of washing to see how the washer’s power consumption behaved. My washing machine’s power goes up and down (to 0W) a number of times before the washing is complete. I just determined that the longest period of up time (power >>1W) was safely greater than 1 minute and that the longest period of down (0W) time was around 4 to 5 minutes. So I just decided that 6 minutes of down (0W) time was enough to declare the washing to be complete.

You may also be interested in this thread:

Cheers!

1 Like

cool, thanks.

I think I have another problem first, the values for power are not changing… it just fixed at 0.0 even though right now the machine is on. :\

ok, looking at this my units are not even reporting… so the values don’t change… Need to solve that problem first.

found htis thread; http://forum.micasaverde.com/index.php/topic,41192.0.html?PHPSESSID=dlhcf1fh32hg3p8smm9gk1eth4

Changing this, has it reporting regularly now:

Parameter 101 [4 byte dec] = 12 //report kwh and watt
Parameter 111 [4 byte dec] = 60 //report every 60 seconds

phase 1 complete! Now to get some numbers when the devices are on!

1 Like

Just a final solution post to anyone who finds this thread. The lowdown is:

If you have an Aeotec smart switch 6 - ZW096-B09, their ZWave range is rubbish and it seems dependant on the unit. I have some that will work 20 or so meters… I have some that struggle within 3 meters. The only way to include them is at the location were you want to use them. Do not add close to your controller and then move. This is a PITA.

My final solution for these devices was just to trial and error each one on locations where they would work. I seem to have 2 that have < 3 meter range but the rest I found a use for.

I also then found the Aeotec smart switch 6 - ZW110-B09. These work flawlessly… anywhere in the house.

Yes my ZW096 didn’t have much range (would not work across the next room), at least in one part of my house, but plenty of range in another part of the house. Good to know about the ZW110…thanks :slight_smile:

1 Like

They seem harder to find to buy them but worth it.

I bought a Smart Switch 6 (ZW110-A) from Amazon
It does work fine. The only issue is with changing parameter 90.
I can’t seem to enable the Wattage threshold and percent. Either by the Z-Wave Network Management UI or using Developer Tools > Service > zwave.set_config_parameter

Screenshot_2020-09-24 Configuration - Home Assistant

The zwave log seems to think that I am trying to disable it…

Refreshed Value: old value=false, new value=false, type=bool
Received Configuration report: Parameter=90, Value=0

With the GUI, it should be setting the new value to “true”. I tried the same value manually with zwave.set_config_parameter. I have also tried “True” and “1”.
It always seems to send a “false” or “0”.

The config xml being used is still ZW096, as I have not found a newer config xml for the ZW110

which did you try, value: True or value: "True" ?

“True” != True

So with double quotes I do get it set…

Configuration::Set - Parameter=90, Value=1 Size=1
Refreshed Value: old value=false, new value=true, type=bool
Received Configuration report: Parameter=90, Value=1

So the UI isn’t set right, as the only options are preselected True or False, no quotes. Both of which result in disabling the parameter. Enabling can only be done with zwave.set_config_parameter I guess.

Issue opened for a year…