Aeotec Smart Switch: Can't set config parameter and sensors still show old values after re-include

Tags: #<Tag:0x00007f739377f8b8>

I am having some troubles with an Aeotec Smart Switch 6. I wanted to reduce network traffic and adjust the Z-Wave parameters from sending a group report every 5 minutes to only send on power change based on thresholds.

The first problem is, that when I try to reconfigure parameter 90 from 0 to 1, I can see in the Z-Wave log, that whatever I do, it always sends value 0. I tried through node management and manually with zwave.set_config_parameter.

Next thing I tried was to remove the node, stop z-wave, factory reset the node, restart HA, and re-add the node, which worked, except that the Node still has the same Z-Wave configuration as before. Even the sensors, e.g. the energy sensor, has the old values from before excluding and displays 400kWh and I have not renamed the entity ids yet. Shouldn’t at least that been reset to zero?

Any ideas how I can reset and/or reconfigure the node?

Thanks,
Julian

Did you do a secure include on the node? Also what is parameter 80 set to? If that is set to “Hail” your network will have a hard time talking to it because it’s flooding the network with updates. There is a command/way to reset the energy meters, it’s not through a parameter, rather a Zwave service command. I’ll have to dig through my notes from a few years ago on these.

You can always do the factory reset procedure after excluding the switch from the network. Hold the switch button for 20+ seconds and it’ll go through a color/light show and reset to defaults.

EDIT: reset energy meters: Reset energy meter

Dang. Notification Status. That’s probably it. Didn’t even think of that. Thanks so much for pointing me in the right direction. Needs to be basic, right?

I did do a factory reset before adding it back. Twice. It did do the red blinking, that become faster and then turned to green, just like described in the manual, but once I included it again, it had a new node_id, but the energy sensor (with the new, default entity name) did say 400-ish kWh, just like before I removed AND factory reset it. Really strange.

Correct. Set notification to Basic.

I had trouble with these not always updating their status from physical interaction with the switch. It’s been a while since I reset mine, but yes you get a new node id on inclusion. I thought it would reset the energy meters, but guess not. Anyways, using the Zwave service call in HA should reset the meters.

Thanks.

Just baffling, that the factory reset would not reset the energy meter. I don’t really need to reset them, but I thought it would be a way to see if the factory reset succeeded. Guess it’s not :slight_smile:

The main problem is, that I can’t set parameter 90 to 1, so that the thresholds actually trigger a report. Unfortunately, that still doesn’t work, even like this:

zwave.set_config_parameter
node_id: 89
parameter: 90
value: 1

I get value=0 in the log:

2020-10-11 20:05:44.985 Info, Node089, Value::Set - COMMAND_CLASS_CONFIGURATION - Enables/disables parameter 91/92 - 90 - 1 - False
2020-10-11 20:05:44.985 Info, Node089, Configuration::Set - Parameter=90, Value=0 Size=1
2020-10-11 20:05:44.985 Detail, Node089, Queuing (Send) ConfigurationCmd_Set (Node=89): 0x01, 0x0c, 0x00, 0x13, 0x59, 0x05, 0x70, 0x04, 0x5a, 0x01, 0x00, 0x25, 0x4a, 0xfc
2020-10-11 20:05:44.985 Detail, Node089, Queuing (Send) ConfigurationCmd_Get (Node=89): 0x01, 0x0a, 0x00, 0x13, 0x59, 0x03, 0x70, 0x05, 0x5a, 0x25, 0x4b, 0xfd
2020-10-11 20:05:44.985 Detail,
2020-10-11 20:05:44.985 Info, Node089, Sending (Send) message (Callback ID=0x4a, Expected Reply=0x13) - ConfigurationCmd_Set (Node=89): 0x01, 0x0c, 0x00, 0x13, 0x59, 0x05, 0x70, 0x04, 0x5a, 0x01, 0x00, 0x25, 0x4a, 0xfc
2020-10-11 20:05:44.993 Detail, Node089,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-10-11 20:05:44.993 Detail, Node089,   ZW_SEND_DATA delivered to Z-Wave stack
2020-10-11 20:05:45.010 Detail, Node089,   Received: 0x01, 0x07, 0x00, 0x13, 0x4a, 0x00, 0x00, 0x02, 0xa3
2020-10-11 20:05:45.010 Detail, Node089,   ZW_SEND_DATA Request with callback ID 0x4a received (expected 0x4a)
2020-10-11 20:05:45.010 Info, Node089, Request RTT 25 Average Request RTT 26
2020-10-11 20:05:45.010 Detail,   Expected callbackId was received
2020-10-11 20:05:45.010 Detail,   Expected reply was received
2020-10-11 20:05:45.010 Detail,   Message transaction complete
2020-10-11 20:05:45.010 Detail,
2020-10-11 20:05:45.010 Detail, Node089, Removing current message
2020-10-11 20:05:45.010 Detail,
2020-10-11 20:05:45.010 Info, Node089, Sending (Send) message (Callback ID=0x4b, Expected Reply=0x04) - ConfigurationCmd_Get (Node=89): 0x01, 0x0a, 0x00, 0x13, 0x59, 0x03, 0x70, 0x05, 0x5a, 0x25, 0x4b, 0xfd
2020-10-11 20:05:45.018 Detail, Node089,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-10-11 20:0

Yeah not sure why it’s not setting parameter 90 to a 1. If you try to send the set parameter command a few times in a row, does it finally go through? I’ve had times where a command didn’t go through because at that time a node was communicating or other commands were traversing the Zwave network.

It needs to be set as a boolean in string form.

zwave.set_config_parameter
node_id: 89
parameter: 90
value: "True"
2 Likes

Good catch. Going through the integration configuration (the old Zwave config panel in HA) and it shows it as either “True” or “False”.

Hi guys, I have a similar issue with Qubino 3-phase meter and enabling the IR port to control the Bicom Relay switch. The process is to set parameters 100 to 1, remove the node then add node and you should see the additional switch. I asked Qubino support who had me install the developer kit from Sigma and try again. In there I see the additional parameter stick but when I try with HA is always comes back with the parameter reset. Is there something HA does to reset all parameters on add? Any help would be appreciated.

Thank you. I’ll try that.

Is it a bug that the it also doesn’t work if I send it using the frontend?

Yes. https://github.com/home-assistant/frontend/issues/4134

1 Like

Yeah :slight_smile:

2020-10-16 12:01:27.029 Info, Node090, Value::Set - COMMAND_CLASS_CONFIGURATION - Enables/disables parameter 91/92 - 90 - 1 - True
2020-10-16 12:01:27.029 Info, Node090, Configuration::Set - Parameter=90, Value=1 Size=1
2020-10-16 12:01:27.029 Detail, Node090, Queuing (Send) ConfigurationCmd_Set (Node=90): 0x01, 0x0c, 0x00, 0x13, 0x5a, 0x05, 0x70, 0x04, 0x5a, 0x01, 0x01, 0x25, 0xb2, 0x06

Thank you, sir!