Aeotec Z-Stick Gen5 or HA not seing any z wave devices after power outtage

I had a short power outtage and later noticed all z wave light devices came up grey in HA interface and also z wave sirens and danalock. But, I do have a fibaro water sensor that shows up (temperature is updating) and a aetoc z wave water sensor that shows up (temperature is updating). But the aetoec sensor placed 1meter from the HA is not showing up nore are any fibaro wallplugs or wallswitches/dimmers our outdoor plugs/dimmers using z wave.

Tried restarting both stick and HA but no luck. I got the discolights flasing atleast.

Z wave JS version 0.1.53 also tried with latest 0.1.54. Earlier today I updated to 0.1.54 and core from 2022.2.5 to 2022.2.9 I first thought it might have something to do with these updates so used backup to restore back to core 2022.2.5 and z wave 0.1.53.

Under diagnostics it sais Driver: 8.11.5 , Serverversion: 1.14.1

I tried repair network.

Running on Pi 4 Model B 8RAM.

Anything else I can do or should or do I need to buy a new stick or did something on Pi itself broke perhaps?

PS. All zigbee devices work fine.

What do the logs show?

Im a newbie and altough Im a techy guy Im not on this level. Logs are green, do not really know what to look for.

So am I, so you are in good company. :grinning_face_with_smiling_eyes:

  1. I use Z-WaveJS2MQTT, so debugging IMO is much easier, but I believe you can use the log in zwavejs (see screenshot) ? Make sure it’s on at least 'info" level.

  2. Do you have an NVM back up of the Aeotec Stick?

Thanks. Found the correct place for logs with your help. In the logs I see alot of this
The controller response indicated failure after 1/3 attempts. Scheduling next try in 100 ms.
[Node 006] refreshing neighbor list failed…
[Node 006] refreshing neighbor list (attempt 2)…

The only backups I have is for 0.1.53 before I updated to 0.1.54 and I have restored to 0.1.53 currently.

Also noticed my driver sais 8.11.5 were your sais 8.11.14

How many nodes involved in the logs? Do you see one node more then others?

The reason why I ask, sometimes if a node(s) gets stupid, (non stop broadcasts, etc…) it can bring much of the network down. In the last 8 years (with HomeSeer) I’ve experienced this 3 times. It can be a pain to find the offending node.

Currently healing network so perhaps logs are being filled with more than normal but I only see Node 4 5 and 6 in the logs.

[Node 006] requesting node neighbors…
[Node 006] node neighbors received: 4
[Node 004] treating BasicCC::Set as a report
[Node 006] Sending node back to sleep…
[Node 005] failed to update the neighbor list after 5 attempts, healing failed

If those node are easy to power off - wait a minute - power back up, I would give that a try.

I just notice Node 006 is not mains powered. I’ve never had a battery powered node cause a network problem. YMMV

The fibaro wallswitches (plugs inside the walls) are hard to power off but it did not work with wallplugs.

Im doing 2 day old restore now, see if that helps. Edit: It did not.

Dont know what to do. :frowning:

Have you tried pulling the stick out for a minute and putting it back in?

I have yes.

Ok. I managed to get it fixed. ”Have you tried turning it off and on again” did the trick. A hard reset unplugging power to the Pi. So in order to fix the problems I got from the power outtage I had to simulate a power outtage. Go figure.

1 Like


Many thanks to all the help and tips and time spent.