Aeotec Z-Stick Gen5 ZW090 New Firmware Update

You are right, I looked a the manual for the 102. Thanks.

@freshcoast explained this at the top of this thread: Aeotec Z-Stick Gen5 ZW090 New Firmware Update - #5 by freshcoast

hi i upgraded zstick gen5 and there is no light at all… once connected to RPi4 ; any idea?

Try plugging it back into your PC and flashing it again.

1 Like

@sota is that an issue? as i can control devices… so i am confused and also it show fw version 1.2

No

The lights can be turned on and off
If it’s working then there is no concern

If it’s working OK and showing the correct f/w version then all is good. On the old f/w you could disable the rainbow LEDs on the stick. With 1.2 they are used to indicate the charge state of the internal battery. I wasn’t awatr that this could be turn off.

I did this upgrade on my Z-Stick Gen5 and it was successful. I alswo updated the firmware on all of my devices and built my Zwave netowrk from scratch.

I added my Aeotoc SmartSwitch 6 to the network and it worked fine. But when the Smartswitch was moved to another location (about 5 metres away), it shows as dead and does not come back to life and will not allow heal command due to being dead.

Any idea whether this is due to the firmware upgrade? or something else?

I’m using HASS with ZwaveJS as the controller.

Bad location. Can’t heal cause it not connected

FWIW, I had an original ZW090 stick on FW 1.0. I was unable to pair any S2 devices, even though my controller software should have supported it. I upgraded to FW 1.2 and now I’ve successfully added both S2 Authenticated and Unauthenticated devices. It’s really the only thing I changed, so it had to be the FW upgrade that allowed it.

The only issue I had with following their flashing instructions is that I had to run the flashing software as an administrator (right click exe and “run as admin”) before it would actually flash it.

1 Like

Other than the issue you mentioned, when you plugged it back in and restarted HA was everything still there or was there anything that was missing or got renamed? I just finished a ZWJS migration and got everything named the way I like it and really don’t want to go through that again.

Nope, you should be fine. I was in the same situation, I had just done the zwjs migration and just named everything. Everything stayed the same after the FW upgrade

2 Likes

Thanks; I’d hate to go through that again although it was worth it in the end as I think the naming scheme makes more sense now than it did prior to the upgrade.

I have been desperately trying to update my Aeotec Gen5 stick to the latest 1.02 firmware and the updater keeps failing. I have tried running as administrator with no luck. I even contacted Aeotec and they haven’t been able to figure it out.

I get messages saying the port is closed and it could not switch the chip to programming mode.

Anyone else run into these issues and have a solution? Windows 10 with the correct Sigma Designs programming driver.

Try another pc or usb port

Yeah I tried that and a different PC, no luck…

Where were you able to find the actual Firmware. The only link i have found doesn’t work.

Looks like Aeotec pulled the firmware article. You’ll probably have to submit a support ticket.

I had opened a ticket with them and haven’t heard back. Curious if someone still has the zip.

I just heard from them that they pulled the 1.02 release due to some sticks getting bricked. It sounds like 1.01 is now the latest for the Gen5 stick.