Aeotech ZW162 Doorbell

this is what I have for control panel sections:

I’ve tried to re-interview, heal, refresh, restart the container many times and it hasn’t changed anything.

the only thing I haven’t tried is to exclude/include.

Sections seem complete. You have in notification some stuff and all ‘idle’ and pressing button should then make one of those change value. ( Like my screen few posts back)

OK, thanks again I’ll check it when I have a chance.

Last week i took a gamble and switched from the openzwave Beta to ZwaveJS.
Transition was a bit less userfriendly than the manuals describe it was still manageable.

My only problem at this stage is that my doorbell does not trigger any notifications anymore.
The entity that i used previously is present, however with ZwaveJS it is unavailable.

Anyone having the same challenge and knows how to address?? :slight_smile:

I’m able to trigger the siren6.

I’m running these versions:
homeassistant 2021.4.2
zwavejs2mqtt: 3.2.0
zwave-js: 7.1.1

I’m new with home assistant, but somehow I don’t have the “endpoint” field.
would you share the yaml code by any-chance?

The homeassistant call service is “zwave_js.set_value” not a “zwave_js.set_config_parameter”

Said service has only been added since:

1 Like

thanks you. not working for me but at least I have zwave_js.set_value now !

From the zwavejs2mqtt control panel expand the siren6 node and expand the “Sound Switch” section. You will looking for any of the “Play Tone” items. The first “Play Tone” for me is called “[2-121-1-toneId] Play Tone”.

Inside homeassistant, go to dev tools > services > choose the zwave_js.set_value service.

set the target to: siren6 device (not the entity)
set the command class to: 121 (from the above Play Tone: [2-121-1-toneId] )
set the endpoint to: 1 (from the above Play Tone: [2-121-1-toneId] )
set the property to: toneId (from the above Play Tone: [2-121-1-toneId] )
set the value to: 1 (the value is the sound you want to trigger, Aeotec Siren 6 user guide : Aeotec Help Desk )
Press Call Service and your doorbell sound should be triggered.


How do you find the “device” id?


Never mind. I found it the hard way by looking in the core.device_config file.

Here is the properly formatted service call based on the above post:

service: zwave_js.set_value
  device_id: ebef77a48527a7a49239006fc7114566
  command_class: 121
  endpoint: 1
  property: 'toneId'
  value: 6

change you device_id and other values as needed.

I just used the GUI to select my siren from the dropdown list.

Mine doesn’t have that available:

But I’m not sure why.


I was in YAML mode. As seen in the picture… :roll_eyes:

did anyone with this doorbel and Zwave JS get the doorbell notification running?
With today’s update the logs of zwave JS do give more information.

This happens when the doorbell is pressed

2021-04-16T08:20:40.610Z DRIVER « [Node 014] [REQ] [ApplicationCommand]
                                    │ source:      3
                                    │ destination: 0
                                        tone id: 1
2021-04-16T08:20:40.699Z DRIVER « [Node 014] [REQ] [ApplicationCommand]
                                    │ source:      3
                                    │ destination: 0
                                        notification type:   Siren
                                        notification status: 255
                                        notification state:  Siren active
2021-04-16T08:20:46.101Z DRIVER « [Node 014] [REQ] [ApplicationCommand]
                                    │ source:      3
                                    │ destination: 0
                                        tone id: 0
2021-04-16T08:20:46.201Z DRIVER « [Node 014] [REQ] [ApplicationCommand]
                                    │ source:      3
                                    │ destination: 0
                                        notification type:   Siren
                                        notification status: 255
                                        notification event:  Unknown (0x00)

Which is good, however for some reason my native binary_sensor of the doorbel device is not triggered. (binary_sensor.indoor_siren_6_and_doorbell_6_siren_siren_active)

Any ideas? happy to try out a few things, just not sure what. :slight_smile:

i have several of these ‘siren_active’ , depending on which endpoint got triggered for sound, you get one of those ‘Detected’ and goes to ‘Clear’ after…
button is endpoint 3 right? so it would be binary_sensor.indoor_siren_6_and_doorbell_6_siren_siren_active_3 that goes off (and not the one without a number at the end)

Really? I only have 1 siren active, which sadly only gives a status unavailable.

Maybe I should remove and add the node to the zwave network or something.

check device related entities, maybe some got ‘disabled’

Nice! I’ve been banging my head on this one all week - any idea how to set the default volume for each endpoint?

Do you use zwavejs2mqtt or the non-mqtt version?

if you use the mqtt version that has the control panel you can find the data you need under the “soundswitch” section.

but here should be the syntax for (example) setting the endpoint 3 default volume to 75%.

service: zwave_js.set_value
  device_id: ebef77a48527a7a49239006fc7114566
  command_class: 121
  endpoint: 3
  property: 'defaultVolume'
  value: 75

However, I haven’t gotten all of the doorbell 6 functionality to work yet.

Most of my entities are “undefined” or 0%. and I never get any notifications/sensors to work when I push either doorbell button. So I can’t say that I’m anywhere near knowledgeable enough on this stuff.

But I was able to play a tone on the doorbell from HA so I know that it’s at least partially working.

1 Like

I did already check that, for my doorbell only 1 siren_active entity, which always has the status unknown.
I have about 30 entities disabled belonging to the doorbell, none seem to work.

Am thinking of removing the device and adding it again.

I’m running into the same issue.

Please let me know if excluding and including fixes it for you.