After the last Home Assistant version 0.108.4, scripts aren't working from Google Assistant

Hi! Home Assistant is fantastic, I’m very happy to use it!

I encountered an issue with the last version.
I configured the Google Assistant integration manually (without Nabu Casa) and everything was working until yesterday when I upgraded my Home Assistant instance to version 0.108.4.
The Home Assistant scripts and scenes I imported in Google Assistant aren’t working anymore. I can see them in the Google Home devices list, but if I try to run them (with “turn on [name of the script]”) I receive something like “I’m sorry, The device [name of my hassio device] is not available at the moment”.

I configured also other entities in the Google Assistant, like covers and temperature sensors, and they are working as usual.

My configuration is:

  project_id: home-assistant-13fc6
  service_account: !include service_account.json
  expose_by_default: false
      expose: true
      name: Lavandino
      expose: true
      name: relax
      expose: true
      name: pulisci camera
      expose: true
      name: tapparella

With this configuration, I can use covers and lights but I can’t use scenes and scripts.

Thanks for the help!

1 Like

+1 - I have not changed a thing and about 2 days ago this started happening to me as well. All I get when I make a call to Google Assistant is “I’m sorry, It looks like [name of my hassio device] is not available right now”.

I have checked all settings, my cert is good to go, I can access HASS via HTTPS over the internet no problem, but Google is not having it.

You have this issue just for scripts and scenes or also with other entities?

I have the same problem, i didn’t update anything.
suddenly the integration google home -> home assistant stop working.
It happen only with script in routine.
I have also some lights and these turn on and off normally through the home assitant integration

1 Like

I have the same issue since 108.4 but I am using google_assistant through nabu casa. Scenes and scripts do not work via Google Assistant, but switches/lights/thermostat do.

1 Like

I can’t turn on/off anything from my Google assistant here. This was before I updated to 0.108 as an FYI - I was running 0.107 until I posted here last night in Docker. I have a feeling Google has changed something on the backend.

Using Home Assistant core as well through Docker on 108.5 and cannot get Google Assistant to work either. Have tried relinking a few times with no success.

Running 108.4 and just tested a script via Google Assistant and it worked fine. Running via NabuCasa. Maybe there was an outage?

Have the same issue, since a couple days i can’t activate script or scene from google assistant. I’m not using nabu casa. Lights and covers work fine.

Hi! Same problem here! :slightly_frowning_face:

I’m able to run the scripts fine but all of a sudden, my wife is unable to activate any scripts.

1 Like

I’m having exactly the same issue. Scripts are working fine for me, but not for others in the house. I haven’t updated anything. I’m guessing Google must have changed something.

I agree - I think this is a Google backend change. Mine was perfect, no changes, been running fine for months on end.

That is what nabu casa support told me as well, but I am not sure how to engage Google to fix it - not that they would care.

1 Like

This is very true - I’m thinking until on our side (HASS) - unless the dev of the plugin gets involved, this perk might be dead. I’m considering building my own voice assistant as relying on Google (who could care less that this does/doesn’t work…) is problematic. This is very unfortunate as this integration has been in place for some time and is one of my things I leverage in my household. WAF is low as a result - lol!

1 Like

Every thing works fine know. Must ne a Google issue.

For me, I had to go to each scene in google assistant and add it to a room. Once I did that, they started working again. Not sure why.


This fixed my issue. When I read this, I noted that the Google Home App on my phone showed 20 devices not in a home in the linked to you section of the app (towards the bottom when you open it.). I tested a light, no good. Then I added it to the home (which showed it was already in the home) but assigned it a room (which I had not before) and presto - up and running.

My guess is that they show these devices as not part of the house by default or something now and until added it won’t be controlled by voice. My guess - not confirmed. Thanks to coolguymatt for the tip!

It worked for me, I can close the issue.
Thanks a lot!

I tryed to look in google home app (version:
but i don’t find how assign script to a room.
It still not working for me