After upgrade to 0.117, Alexa Integration No longer works


Yesterday I upgrade to 0.117.1 from 0.116.4 and my Alexa integration stopped working. I set it up using the following link:

I disabled and tried to re-enable the skill, but it gives me the following error:

“We were unable to link Hass Voice Automation at this time.
For instructions and assistance with configuring your skill for account linking with OAuth, please see this guide.”

When I log into the lambda function to test the Discovery function from the instructions, I get the following error:

  "errorMessage": "HTTPSConnectionPool(host='<my hostname>', port=443): Max retries exceeded with url: /api/alexa/smart_home (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x7facf47ea810>: Failed to establish a new connection: [Errno -2] Name or service not known'))",
  "errorType": "MaxRetryError",
  "stackTrace": [
    "  File \"/var/task/\", line 68, in lambda_handler\n    body=json.dumps(event).encode('utf-8'),\n",
    "  File \"/var/runtime/urllib3/\", line 80, in request\n    method, url, fields=fields, headers=headers, **urlopen_kw\n",
    "  File \"/var/runtime/urllib3/\", line 171, in request_encode_body\n    return self.urlopen(method, url, **extra_kw)\n",
    "  File \"/var/runtime/urllib3/\", line 336, in urlopen\n    response = conn.urlopen(method, u.request_uri, **kw)\n",
    "  File \"/var/runtime/urllib3/\", line 767, in urlopen\n    **response_kw\n",
    "  File \"/var/runtime/urllib3/\", line 767, in urlopen\n    **response_kw\n",
    "  File \"/var/runtime/urllib3/\", line 767, in urlopen\n    **response_kw\n",
    "  File \"/var/runtime/urllib3/\", line 727, in urlopen\n    method, url, error=e, _pool=self, _stacktrace=sys.exc_info()[2]\n",
    "  File \"/var/runtime/urllib3/util/\", line 439, in increment\n    raise MaxRetryError(_pool, url, error or ResponseError(cause))\n"

This happens even if a LONG_LIVED_ACCESS_TOKEN defined. I did check that nothing changed on the AWS side based on the link above, but I cannot figure out why.

Also, in my configuration there is no content under “smart_home:” however I never added anything to it in the past; I assume the config gets added when it’s linked?

Can someone please help?


Can someone help me here? Any guidance is appreciated.


I had this issue, but I didn’t do anything HA side, lambda side, or skill side. It was all Alexa phone app side. Unfortunately, I don’t remember what I did exactly. Or it was NGINX and I reset it.

I get this same error when I try to activate the skill from the web so it doesn’t seem to be my iPhone…

Also, note that I cannot get the Lambda function to work either…it complains that “/api/alexa/smart_home” is a “Name or service not known.”

Can anyone else please help?

Are you running nginx? Yes or no. As an aside, the alexa phone app manages your alexa’s. I remember the issue being inside the management of the alexa’s or in nginx. This is what I meant by your phone, not the app itself.

Also, I’m trying to help. Continuing to beg isn’t helping anyone.

@petro apologies if I offended you or if am sounding “petty,” this was not my intention.

I am running the Home Assistant Core Docker Container with a nginx reverse proxy in front of it. I think I understand where you are going in relation to nginx. I took a look at the nginx logs when trying to add the skill and all I get is the following:

 [04/Nov/2020:13:47:05 +0000] "POST /auth/login_flow/<uuid> HTTP/2.0" 200 184 "https://<hostname>/" "Mozilla/5.0 (iPhone; CPU iPhone OS 12_4_8 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.1.2 Mobile/15E148 Safari/604.1" "-"

Not much there…it does seem that the authentication is working.

Revolved my issue. It was due to a DNS issue in which my external hostname was not resolving. I did not realize this was the case because it did not present itself anywhere else since I was accessing either internally or from a device that cached the IP.

Kicking myself as it is something I should have checked…posting in case anyone else every runs into this.