AirTouch 3 Local Integration

I have put together an api that wraps the functionality of the AirTouch 3.

The Api can be found here. The instructions can be found in the github repo.

I have also created a custom component that turns this api into a climate entity with switches for zones and sensors for the temperature devices. The custom component can be found here.

The end result

I have been using (testing) this for a couple of weeks without any issues. The limitations and warnings are listed in the readme file in each repo. Please take a look.

If you do find issues or have suggestions, please raise a github ticket and I will try and look into it. Any questions just drop them here.


Hi Guys,
I am trying to get this integrated into my Home Assistant.
The Author Mike, has created 2 GitHub links:


My query is, how do I import this into my Home assistant config?
I have tried installing using the terminal add on. Didn’t have much luck, I have also tried adding it as a repository and got some errors in the log.

If someone could point me in the right direction it would be appreciated.

Hi Mike,

Great project! I managed to get the API wrapper container running on my Win10 laptop and can get the UI working in HA, which is running in docker on a raspberry pi 4. But, I’d really love to get your API wrapper container running on the Pi too. Any plans to release an ARM64 compatible version? Or tips on how to get this running on the Pi?


Great that you have it working.

re: pi 4 - it should be possible. I think all you need to do is change and add the appropriate RuntimeIdentifier to RuntimeIdentifiers .


I have a pi3 so I will try on there on the weekend.

Thanks @ozczecho, really appreciate the quick response!

Yeah I tried changing the RuntimeIdentifiers to linux-arm64 and then it failed during the build process as the final stage image runtime specified in the Dockerfile 3.1-buster-slim didn’t support arm, so I updated that to 3.1-buster-slim-arm64v8 - but it still fails to run, just sits in a rebooting loop with the following error in the logs:

[FATAL tini (6)] exec /app/VzduchDotek.Net failed: Exec format error

Not sure where to go from here…

I made the following changes to the DockerFile to run it on my pi3:

  • use linux-arm
RUN dotnet publish -c release -o /app -r linux-arm --self-contained true --no-restore /p:PublishReadyToRun=true
  • use image 3.1.12-buster-slim-arm32v7

Good Luck.

Thanks Mike!

I updated the Dockerfile with the changes and it works like a charm.
Thanks again, appreciate your help getting it running!


I have created a Home Assistant Addon for the vzduch-dotek API used to interface with the AT3 controller. The addon can be found here: home-assistant-addons/vzduch at main · ozczecho/home-assistant-addons · GitHub

ATM I have only included an amd64 build config. Feel free to add additional configs.

1 Like

Any chance you could include a build config for Raspberry Pi 4?