Alarm control panel not working with Google Home

Tags: #<Tag:0x00007f739661ef48>

Hi,

I setup an alarm control panel, just as a test:

alarm_control_panel:
  - platform: manual
    name: Allarme
    code: !secret alarm_code
    code_arm_required: true
    arming_time: 30
    delay_time: 20
    trigger_time: 4
    disarmed:
      trigger_time: 0
    armed_home:
      arming_time: 0
      delay_time: 0

Works pretty well, but i wanted to integrate it in my Google Assistant:

google_assistant:
    project_id: home-assista
    service_account: !include ghkey.json
    secure_devices_pin: !secret alarm_code
    report_state: true
    expose_by_default: false 
    entity_config:
        alarm_control_panel.allarme:
            expose: true
            room: Ingresso

The problem is that the created alarm in Google Home looks like this, and it will not let me do anything a part from showing its informations when i click on it:


My attemps:

  • If i ask google “activate allarme”, it says that there is no such mode for “allarme”.
  • Tried to change “allarme” to something else, as the name may be referred to other Google stuffs. Nothing
  • Tried to manually write the secure_devices_pin (which, as per documentation, must be the same of the device) in different ways and instead of the !secret, like: “1234”, ‘1234’.

I think that i’m missing something in the configuration, as it appears that usually users are at least asked a pin when clicking on the icon or asking Google to activate/deactivate the alarm, as reported here: This action requires a security code, but it hasn't been set up in your device's app

Any help?

Valid modes are as listed in the documentation - armed_home/armed_away etc.
Have you tried “Hey Google, set alarm to armed_home” or a similar command specifying a similar recognised state?

My working manual alarm integration (that ties together a Konnected.io board, some motion sensors etc.) integrated via Nabu Casa has no clickable actions in the Google Home interface but can be used to set to armed_home and prompts for pin when requested.
NB: although currently Google seem to confuse my “Home Alarm” with alarm clock settings - either due to Android 11 update or recent Google changes.

Nope, still giving me “no such mode available” or, if I say “set allarme active”, is saying that “allarme is not available”.
As well as yours, mine is confusing the word “alarm” or “antitheft” (!) with the alarm clock (even if the italian world still has nothing to do with it). Had to name it “panel” in order to avoid questions about the alarm clock.

Why are you saying that there are no clickable actions on Google Home? Is it normal or is it just your (and mine) case?
I will give it a try with Apple Homekit as i go back home

I believe it’s normal although I’ve nothing to compare against.

I also have no clickable actions on my:

  • Garage door
  • Unifi Cameras (integrated in HA via Unifi Protect component)
    but they can be controlled via voice commands.

Of course I haven’t done a deep dive into Google’s documentation as to what one should expect from an alarm panel in Google Home.

This is getting strange… If i create a routine in Google Home, i’m allowed to choose the “arm the security system” and in actually find the Home Assistant alarm panel modes

But, if i trigger the routine, it says that “antifurto does not support this functionality yet”

Out of interest I’ve just tried the same and can confirm your experience except for the results - I get a Google search for the routine command :man_shrugging:
I’ve definitely been able to arm and disarm the alarm by voice in the past (it was one of the first things I tested after configuring my alarm setup in HA).

I’d chalk it up to Google weirdness given the time of year - Android version launches are notorious for rapid, random and messed up feature changes by Google.

Did some playing quick playing around.

Bear in mind that my alarm panel is listed in Google Home as “Home Alarm” (not terribly original I know):

Also spotted an issue that may be relevant on Github: https://github.com/home-assistant/core/issues/37345

EDIT: hopefully the alarm’s status will eventually be reflected in Google Home, similar to how light icons are (now) shown as lit / unlit depending on their actual state.

Interesting issue, thanks!

I tried the same on Homekit:

homekit:
    auto_start: true
    filter:
        include_entities:
        - alarm_control_panel.antifurto
    entity_config:
        alarm_control_panel.antifurto:
            code: !secret alarm_code

And it works perfectly, i can see the modes (correctly synched to Home Assistant):

I can deactivate or activate the modes through Siri, even if it does not ask me the pin:

(for the moment, just “armed - home”, the others do not have any effect neither by voice nor by pushing the buttons, even if i do have the “armed - away” mode in the alarm panel.)

So, given that these are the italian names for the alarm mode, i asked Google Assistant to activate the alarm with the same sentence, with no luck.
BUT.
The disarming sentence works, and in fact it asks me for the pin and then correctly deactivate the alarm:

I guess that for Google Assistant there still is just a translation problem.
So this makes me think that all the configurations are correct for the alarm to work with Google Assistant, but given the fact that there are no “pushable” buttons and that the phrasing still has some issues, it leds to think that it doesn’t work.

Guess i just have to wait :see_no_evil: