Alexa Announce Feature - Text to Speach via Alexa now a possability?

alexa
Tags: #<Tag:0x00007f1b950ff110>

#408

i dont know what chromebook is :wink:
is it an app or a device?

i believe that android with chrome is the best for lovelace.
i dont care about that because it works perfect with HADashboard. and i cant get a cheaper wallpanel then that (unless i buy used or get it from someone else)

@ptdalen TTS should work. “normal” apps are hard to do. just amazon apps, unless you add google play, which can be breaking the alexa experience.
but if the alexa experience isnt what you expect you can always get an echo for a few bucks extra :wink:


#409

Oh its a table that runs ChromeOs (which i think is a form of android) as the operating system. Pretty much can only access the chrome browser. They are pretty cheap, but not Amazon fire cheap.


#410

Oh. Yeah. I have too many echos already haha.

That is part of the reason I’ll be ok if it’s not quite as good as a true echo. Sounds like I’ll get an ok but not great echo capability and an ok but not great tablet. Worst case I’ll end up with a digital photo frame haha.


#411

Just an fyi, but chromebooks can do a lot more than run the chrome browser. Most can run android apps and can now also run linux apps.


#413

Chromebook is my primary device (Acer R13). Standard Chrome browser , Works fine with HA . Has the ability to run Android and Linux apps in Containers . Supports touch screen . Next year big push in tablet form devices . Google and Acer have devices (expensive !)


#414

@lonebaggie and @ReneTode - Quick question. How often do you find your cookie has expired? Yesterday my cookie expired. I think it had been working close to a month. I’ve got the process down to go get a new cookie, so it’s not the end of the world, just wondering if you or others have to refresh their cookies often?


#415

not much.
when i tried to get the last alexa on a regular base (5 min or so) it did expire quick.
now its once in a few weeks, but very unregular.


#416

Even every few weeks is still a bit of a hassle, but at least I can plan on it. :slight_smile:

Thanks!


#417

I copied the two files .alexa_cookie and .alexa_devicelist.json in anothe folder, so when it expires i just do a copy and i have alexa runnin again…


#418

Hmm, so I was doing that to avoid the deleted cookie from /tmp. But that only seemed to help if the cookie was deleted. For example, yesterday my cookie expired and was deleted. I copied my cookie.txt (last cookie I had), back into the correct location, renamed it to .alexa.cookie, and it was removed again. It seemed to me as if it had expired, Got a new cookie and it worked fine.

Just to clarify, are you saying that you are able to reuse those two files indefinetly?


#419

Yes, just tried…


#420

No I understand that if your cookie is good you can override it, but if your cookie expires, I dont think you can just copy a copy of the old expired cookie into the right place and be good, right? I will say I’m not a cookie expert (other than I do like a good chocolate chip cookie), haha.


#421

Since now all is working… i’ll let you know if what you think will happen or not…


#422

I’ve forked the latest alexa_wrapper.sh and alexa_remote_control.sh from Fabrizio Branca

Here is mine:

https://github.com/raidolo/ha-alexa-tts

Changes:

  • Added -lastalexa in the alexa_wrapper.sh, now you can use a configuration like this in HA and then use the notify.last_alexa service in your notifications (thanks @ptdalen for the idea)
    notify:
      - platform: command_line
        name: 'last alexa'
        command: "/config/ha-alexa-tts/alexa_wrapper.sh -lastalexa"
  • Modified the location of the alexa cookies in the alexa-remote-control.sh script, now the cookies go in the HA config dir (configurable as needed if you use docker or not)

  • Alexa secrets go in HA_CONFIG_DIR/secrets.yaml as “alexa_email” and “alexa_password”.

  • Added the Alexa endpoints for Italian


Using Amazon Echo as a speaker?
#423

What worked for me.

I’m on a Mac running .homeassistant

Downloaded the scripts (alexa_remote_control.sh and alexa_wrapper.sh), made them executable.
Edited the PATH in alexa_remote_control.sh
Edited the TMP directories to be explicitly the correct paths:

TMP="/tmp"
COOKIE="/tmp/.alexa.cookie"
DEVLIST="/tmp/.alexa.devicelist.json"

Checked and updated/installed the locations for SED, AWK, CURL and JQ as needed with ‘which SED’, etc
Checked and updated the location for the secrets.yaml file.
Updated the contents of the secrets.yaml file.
Edited the alexa_remote_control.sh file to fix a SED -r error with -E where needed to get round a Mac problem with SED.
Grabbed the cookie using firefox, chrome didn’t work for me.
renamed to /tmp/.alexa.cookie
removed the old login rm /tmp/.alexa.login
changed permissions on the cookie file chmod 777 /tmp/.alexa.cookie
ran the cli command with success! ./alexa_remote_control.sh -a

Good luck!


#424

Today my cookie expired again Re-using the other cookie file did not work. I had to use Firefox to repeat the process and get a new file. I’ve got it down so I didn’t take too long. I was wondering how you were faring. Seems interesting that it was exactly 2 weeks ago that I have the same problem.


#425

I just restarted Raspberry yesterday and after this reset i still have the cookies up and running…
Don’t know what to advice you about it.


#426

No worries, just checking to see if others were having to refresh thier cookie every 14 days.

When I generated the cookie using firefox I selected the checkbox for “stay logged in” and I also have 2 factor authentication set up. When I entered the 6 digit code I also selected “dont ask again”


#427

I just started playing around with this. It seems like it would be easier than exporting cookies from browser with mixed results. Haven’t got it working yet since I have to coordinate with Docker.

https://www.codementor.io/slavko/controlling-amazon-echo-dot-with-shell-a-bit-of-fun-mz6xxz92n


#428

i would love to automate my cookie retrieving, but i dont see how that is done in that project.
i see a link to a js lib, but i wouldnt even know how to start with that.

and i believe the project you linked is nodered, which i am also not using.
i would love it if someone found a python or shell way to collect the cookie.