Alexa Announce Feature - Text to Speach via Alexa now a possability?

alexa
Tags: #<Tag:0x00007f47fecaf6a0>

#102

@Sunonline
ok,
so did you run the remote command? does it work?


#103

Yes. Work and never delete the alexa.cookie and also device list


#104

@Sunonline, good. glad you got it going.


#105

Also many more command for alexa via alexa_remote_control.sh

./alexa_remote_control.sh [-d |ALL] -e <pause|play|next|prev|fwd|rwd|shu ffle|vol:<0-100>> | -b [list|<“AA:BB:CC:DD:EE:FF”>] | -q | -r <“station name”|st ationid> | -s <trackID|‘Artist’ ‘Album’> |
-t | -u | -v | -w | -i | -p | - P | -S | -a | -m <multiroom_device> [device_1 … device_X] | -lastalexa | -l | - h
-e : run command, additional SEQUENCECMDs:
weather,traffic,flashbriefing,goodmorning,singasong,tellstory,speak:
( has to be entered with ‘_’ instead of ’ ’ (spaces))
-b : connect/disconnect/list bluetooth device
-q : query queue
-r : play tunein radio
-s : play library track/library album
-t : play Prime playlist
-u : play Prime station
-v : play Prime historical queue
-w : play library playlist
-i : list imported library tracks
-p : list purchased library tracks
-P : list Prime playlists
-S : list Prime stations
-a : list available devices
-m : delete multiroom and/or create new multiroom containing devices
-lastalexa : print device that received the last voice command
-l : logoff
-h : help


#106

I am not running either. I am running Hassbian on my raspberry pi.


#107

right so I done that and now I get this error when I run: ./alexa_remote_control.sh -a

device list does not exist. downloading ...
the following devices exist in your account:
./alexa_remote_control.sh: 459: ./alexa_remote_control.sh: jq: not found

any idea?

UPDATE:

So I installed jq and ran the script but none of my devices are identified?

It just gives:

[email protected]:/home/homeassistant/.homeassistant $ sudo ./alexa_remote_control.sh -a
the following devices exist in your account:

UPDATE 2:

It works now had to re do my cookies.

Thanks for your support everyone.


#109

Were you able to get one of your devices to speak a test message? I can get the list of devices and I get the what looks like a message that it was successful but nothing is spoken.


#110

Yes I heard the test message.

Check that you have selected/connected to the correct echo/alexa and the volume of your echo/alexa is loud enough.


#111

I was in the same boat. Here’s how I was able to get it to work:

I think the key was the cookies must come from the login html file that’s created in the temp directory and the login must occur on the same LAN as the device running the shell script.


#112

Ok, I ended up redoing everything and now I get the below message. It makes it look like it’s working but can’t verify. I tried logging into the Alexa app to see if it would show a message but it doesn’t look like it.

Edit: I checked the actual Alexa history and it shows simon says this is a test, so I guess it’s working! Thanks!


#113

Great! Glad it worked for you.


#114

Ok, next question. I have several Alexa’s throughout the house and have them grouped together to do whole house audio. I can see my “Everywhere” group in the list of devices but don’t see any history when I use that group. Are you able to use that “Everywhere” group or will you have to create a media_player group within HASS to get the message broadcast throughout the house?


#115

This is actually my situation, Echo is in Italy and actually testing here since it’s still not sold yet.

My config of the .sh is with

LANGUAGE="it-IT"
AMAZON='amazon.it'
ALEXA='alexa.amazon.it'

if I execute the
./alexa_remote_control.sh -a
command, in the /tmp folder I get only .alexa.cookie and .alexa.devicelist.json file,
NO .alexa.login

Strange, isn’t it?

I tried to execute a command to listen to a TuneIn radio and it’s working
alexa_remote_control.sh -d my_echo -r "radioeins vom rbb"

But when I execute the command
./alexa_remote_control.sh -d "Echo di Vittorio" -e speak:'Test'

Alexa answer me
Unfortunately I cannot find the answer to the question

Can the TTS not yet available in my country?

Thanks


#116

Yeah, I tried it too and it didn’t work for me either. This seems to work better:
./alexa_remote_control.sh -d "ALL" -e speak:This_is_a_test!


#117

I saw that option but was worried it would notify other devices that were given as gifts and still under my account or Firetv’s that probably don’t need to be used.


#118

Just tried, but same voice telling
Unfortunately I cannot find the answer to the question

I tried also
./alexa_remote_control.sh -e speak:This_is_a_test!

without -d "ALL"or -d "mydevice"

and I get as reply

setting default device to:
Echo di Vittorio

that is correct, but again no TTS


#119

That was my concern too. I can confirm it only sent to my echo’s. None of the fire tvs. If you have other echo’s under your account that you don’t wish to send to then you might consider creating another group with
-m : delete multiroom and/or create new multiroom containing devices
Or just creating a notify group within homeassistant.


#120

Awesome thanks! I’ll have different things tonight to see how how everything is working.

How are you liking this TTS via Alexa?


#121

So far so good. The cookie expiration has me a bit concerned. I hope someone will discover a way to auto renew them without doing the cookie extension copy/paste every x amount of days.


#122

I was having the same issue for days. I decided to load up Firefox instead of Chrome and export the cookie then the script started working correctly.


Alexa italy