Alexa device not responding on first try

I have the same problem, I have integration with nabucasa and it’s been more than 3 months that my commands for Alexa take a long time to be executed, and it was never like that, they were executed immediately. I’m going crazy with this. If I run it directly via homeassistant, it runs immediately.

Nabu Casa has recognized this issue and it has to do with their servers. Unfortunately, that doesn’t necessarily mean a fix is on its way. I suggest e-mail Nabu Casa and threatening to cancel.

I don’t threatening people is the best way forward. Come on man…

They’re aware of the issue, and at last check a fix should be implemented next month. If you can’t wait, do the manual integration for now.

1 Like

I’ve been testing the new relayer last night and this morning and it’s working out well. It’s still in progress but looking good. Still shooting for before the end of the month, but encouraging others to submit tickets isn’t going to make it go faster.


My problems with slow and intermittent connections to NC have continued and this morning, I’m locked out. I don’t use Alexa.

Frustrating as we use HA to open our garage door, and it’s 10 below today.

I know the drill - I have to get into my HA server locally by wifi, close and reestablish the server connection to NC manually; then I can get in over NC again via the net. This happens every few days.

I just submitted (another) ticket to NC on this problem (admittedly OT to this thread). I really need NC to work reliably.

The new relayer was deployed! This only took a few minutes, and happened in the last hour as I write this. Now it’s time to see if it helps!

You don’t have to restart HA for your server to re-connect, or sign in or out of cloud, but you can. If you wait long enough it will just connect on its own or it has already happened.

Try out your Google and/or Alexa voice assistants and apps and see how it goes.


This is great news!

Thank you for the work! For me, it fixed the problems completely. Alexa is responding fast & without a problem, even when I switch 20 different HA things immediately after each other.

Looks good for the moment.

Yep, works great

All good! Working much faster for me. Thanks everyone that worked on this!

Working here now too

Hi. Im new here and just started to use ALEXA here. I did everything by quide and logged in Nabu Casa, linked Alexa, etc… When asked ALexa APP to discover devices, it found nothing… I restarted APP and ALL devices was dicovered there… Funny.

BUT EVERY item is : “Device is unresponsive”. I tap on powerbutton, nothing happens ever on ANY devices… IT seems that WHOLE integration is broken somehow?

SIdenote: Why every item is added to Alexa as Light AND Switch? So its double…

Sounds like something that starts at the source. What are you exposing to Alexa from the “manage entities” page?

fixed, thanks for the followup @cogneato

Friends, it has 3 days that the commands requested from Alexa are answered immediately.
I don’t know if there has been any changes to the system, however it is perfect.

I’ve been having this issue a lot lately. I never get any verbal response from Alexa though. The command will either work immediately as expected, work as expected after a several second delay or work immediately after I repeat it. If I have to repeat a command, my Alexa history shows the command twice (so Alexa heard it correctly from me both times) but HA history/automation traces only show the command making it through the second time.

I just noticed this over the last few days. Similar behavior. First command appears to have been understood but nothing happens, follow up command a few seconds later works correctly.

I’m noticing this over the last few days as well. Alexa will react with “Device is not responding” then do the thing anyway.

For me, everything is working first try, but Alexa always responds with [entity name] isn’t responding. This is new this morning after the maintenance that occurred at I believe 5:00 UTC, per the notification I had.
Tried unlinking and relinking the skill from Amazon’s side, but no change.
Google isn’t having this issue today.

1 Like