Alexa doesn't find any devices - solved


yesterday I tried to pair my Hass with Amazon Echo. I registered in HA Cloud, activated Home Assistant sill in Alexa app. When I try to discover or add device I get “Discovery filed” info :confused:

Did you put these 2 platforms in configuration.yaml?

After put these 2 in your configuration.yaml. Restart your HA. go to configuration> on right hand side you will have to sign in to homeassistant account.
On Alexa App > go to smart home > choose devices> discover device> then you will see the devices from HA to your alexa app.

I have “cloud:” already.
About “config:”. I have it in my config already to activate configurator. I believe it’s ok. Or should I add another one beneath “cloud:”

then go configuration menu > look on the right hand side, you will see cloud sign in.


this will expose all devices from HA.

Can’t add another “config:” because it generate errors (dupilcated key).


Make sure you are logged into Home Assistant cloud inside Home Assistant (at the config panel) before discovering devices in the Alexa app.

you don’t need double cloud: and config: if you already have in configuration.yaml.

Once you have cloud: inside restart your HA. You will see cloud login under configuration menu inside HA. Login to Cloud. Then it will show connected. Then go to your alexa app > smart home> devices> discovery devices.

Yes I see that Hass is connected to Cloud, and in my Alexa app I can see that Home Assistant skill is Linked. But still “Discovery failed”

1.On alexa app > try logout home assistant skill.
2.Disable home assistant skill.
3. Then enable the homeassistant skill again and login. This will automatically ask you to discover device after you have login to homeassistant skill from alexa app.

I did that already. No change.

Try put device in your cloud: then restart your HA. Go to alexa app again and discover device.

        -  <=== put according to your entity_id
        - light.kitchen_left  <=== put according to your entity_id

Lastly, did you confirm email after registered home assistant account in alexa app?

Tried that, but still nothing.
I’ll try to reset Echo and setup it again. It acting wired, because when I change adres to polish Alexa “say” that she is still in Seattle. :confused:

Next thing is that I cannot pair my spotify premium account with Alexa app. So its probably sthg wrong with echo config.

You can change home address from your profile. Then try by asking alexa like temperature or location. Then she will answer with right answer. If you don’t change it follow from amazon account.

She didn’t link your address from HA. She links your address from your profile.

alexa app> setting> your name’s alexa app> device location> then change to where you are.

Problem solved!
Somehow Alexa setup process went wrong. I did the factory reset of echo device, and set it up all over again, after that Alexa discovered all my devices right away.

1 Like

i have tried all of these steps, Still she doesnt find any of my home assistant devices, what is wrong?


i have the same problem, tried a lot, but still: Alexa doesn´t find any devices

I am logged in the HA cloud, also shown in settings on my just updated hassbian.
i am logged in, and the HA skill (german version) is installed and linked to HA cloud, then looking for devices: found none.

I tried:
unlink, uninstall and reinstall and link HA skill in Alexa.
new amazon account (old one had already groups and stuff in 2 networks, was wondering if it go confused)
factory reset of my alexa dot 2gen
some filters and settings for Alexa in the configuration.yaml (including tons of reboots)

I even tried to get Google Assitant manually to work, had duckdns https, ssh and all port forwards working (turned now all off again, for cleaner testing), used Google API, Actions, Cloud Platform and a bunch of stuff, still could not connect to any device over both services.

is to use Alexa or Google Aassitant to abort my 3d printer over octopi (octopi is already running and showing all sensor), to stop a failing print by voice. Mid term goal is to ask for the current hotend temperature.

Any help appreciated, tried for several days now, still not getting past first steps to connect to Alexa.

Here is my config:

  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 0
  longitude: 0
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here:
  time_zone: UTC
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend

# Enables the frontend

# Enables configuration UI

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url:

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically

# Allows you to issue voice commands from the frontend in enabled browsers

# Enables support for tracking state changes over time

# View all events in a logbook

# Enables a map showing the location of tracked devices

# Track the sun

# Sensors
  # Weather prediction
  - platform: yr

# Text to speech
  - platform: google

# Example configuration.yaml entry for the HTTP component
# Example configuration.yaml entry for the HTTP component
#  base_url:
#  ssl_certificate: /ssl/fullchain.pem
#  ssl_key: /ssl/privkey.pem

#  alexa:
#    filter:
#      include_entities:
#        -
#      include_domains:
#        - switch

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

    name: Test Boolean
    initial: off

 - platform: template
       value_template: "{{ is_state('input_boolean.testswitch', 'on') }}"
         service: input_boolean.turn_on
         entity_id: input_boolean.testswitch
         service: input_boolean.turn_off
         entity_id: input_boolean.testswitch

  - platform: random

  - alias: Check sensor value and show notification
      platform: numeric_state
      entity_id: sensor.random_sensor
      above: 5
      service: persistent_notification.create
        message: "Sensor value greater than 10"

# editor
    title: Configurator
    icon: mdi:wrench
    url: http://hassio.local:3218

#3d printers
  - host: my_ip
    port: 5003
    api_key: my_key
    name: DEV_RIGHT
    number_of_tools: 1
    bed: true
  - host: second_ip
    api_key: second_ip
    name: DEV_LEFT
    number_of_tools: 1
    bed: true

after some serious debugging, i endet up creating a second account with the HA cloud. Did the same and all worked. Bummer, did not expect to have HA show me a “connected” with the old account and lie about it…

Hi all,

I had this problem and it took me quite a long time to solve, tried everything in the thread. The eventual solution (thanks to Paulus for this one), was to enable only a few (less than 50 devices) to sync at a time. I had been trying to sync upwards of 100-200 up to 400 at a time and it didn’t work at all. But by doing them in chunks of under 50 at a time, I got it done.

Hello all,

I’m still struggling with this. I had around 30 devices connected to Alexa through HA Cloud. Then I switched off Alexa integration to be able to do some tests using Alexa nodes in NodeRed. Removed my devices and now I’m unable to put them back. Behavior seems erratic, I edited my filters (yaml) to leave one device only and it got discovered, but luck ended there. All the others are missing. I did everything: reset echo dot, disabled/reenabled the skill, tried adding via UI instead of yaml, logged off/on HA Cloud, …

I’m just gonna sit on this for a few days to see if something new comes up.

Remove media_players from the device list going to Alexa. I had this issue recently. It was the media player causing the issue.

1 Like