Alexa + Google Home Assistant Skill "slow" / timing out

I only use 1 skill in Alexa, which is home assistant as everything in my “smart” home is connected to HA only, mainly via zigbee2mqtt.

Every now and then when I tell alexa to do something, she spins the circle for longer than usual (which is immediately do what I say), then what happens is: what I said starts happening while alexa will say Sorry the device XXXX is not responding.

I tested this numerous times and it fails in this way sooner or later, usually within 10 repetitions.

Just tell alexa: turn off ceiling lamp, turn on ceiling lamp, turn off ceiling lamp, turn on ceiling lamp and so on and on and sooner or later what I described will happen always without fail.

Is this something that happens to others? (Would anyone be willing to try to spam their alexa with on/off requests to test?) or is it something in my config ?

Thanks for any advice.


I get this occasionally. I’d prefer not to do any destruction testing though!

Is anything else happening on the network? My Internet connection is not the best, and Windows 10 updating sometimes slows things down.

I don’t think it’s network. Every wired device I got is plugged into 24port managed switch which is the only thing that connects to router. All wireless devices connect to deco m4 access point, which connects to said switch. I use librenms to monitor network interfaces amongst other stuff and although it only takes snapshot of machines state every 2min, in last few months there were zero errors or dropped packets on all interfaces. My internet is not the fastest, but pretty stable.

Seeing as all my devices are zigbee I can’t do much of testing different integrations. It’s no big bother just annoying when it happens.

This is happening to me, too. Did you find a solution?

1 Like

Seeing this also starting a few months ago. It used to be my HomeKit that had this problem while Alexa always was snappy, now it’s the other way around!!

I wonder if there’s some request logging we can enable to get timing information on requests from Alexa.

I’ve never found any solution to this so far. I tried to put the echo alone on wifi access point on router, and while it seemed it happens less often, it still did. I just keep telling myself it’s no big deal and when it happens (usually when I try to show off my “smart” home) I just fly into bout of seeing-red rage and on the whole find the entire process quite cathartic /s

I wonder does anyone that encounters this use some sort of ad-blocking? I’m using pi-hole and wonder whether alexa tries to send some spy info every now and then with the request, and times out since the address is unreachable. Not really willing to test this though, as even if it was the cause, I ain’t giving amazon any exceptions in pi-hole.


It’s not just you. I don’t run a spam blocker the way you do and also get this behavior or worse, it will say the device isn’t responding. A quick click in my phone’s HA app confirms the device is fine and it’s either an Alexa issue or a connection to Alexa from HA.
My internet is rock solid fiber and it still doesn’t matter.

At this point I’m considering looking into some voice control alternative, I literally only use alexa to tell her “device/group/scene/automation name” on/off or ask her what is the “room/outside thermometer” temperature, really very limited set of maybe 15 sentences I only ever ask her and then I get disproportionally irate when she mishears and googles some nonsense or even worse starts playing some music.

No idea if anything like that exists though, something like Voice Attack for games but for HA.
edit: maybe I should just get google home


Thought it was just me. Lately it has been really slow response from my Tasmota based devices. 5 -10 seconds after I ask Alexa to turn on/off something.

1 Like

Ok, same Problem here. Every now and then alexa complains that the device is not reachable, even though it did respond in the very last moment.
I have a rather fast internet connection.

I anyone has any advice ill be happy to try it.

1 Like

Same for me, too. Often I’ll tell Alexa to (for example) “turn living room lights off” and she’ll say it’s not responding but the lights turn off anyway.

Additionally, the Alexa phone app will tell me that pretty much every device she can see via Home Assistant is “unresponsive” even though Home Assistant itself is fine.

By the way I’m assuming everyone else is using Nabu Casa for the Alexa integration, as I didn’t think there was any other option - that’s the case, right?

And… finally… this is on a Pi 4 in case it’s a hardware challenge.


I’m on nabu casa yeah, afaik you can make custom skill and use alexa without nabu, but I haven’t tried that.

I recently ordered google home (which uses nabu casa too) and gonna try to set up exactly same as I set alexa to see if it exihibits the same behaviour before I point any fingers. I’ve also set up instance of Mycroft, but don’t have time to play with it.

I also get he all unresponsive in alexa app and then when I pull the page down they refresh and act as if nothing happened. As for hw, my HA + mqtt + zigbee2mqtt all run in 12 core 3.3GHz 48GB ram vm so I should hope it’s not hw related.

Last thought is I have several things set up as Script helper object in HA, which if exposed to alexa appear as scenes in the app, and those NEVER fail. They might take even 5 seconds to “happen” occasionally, but they never do what this whole thread is about. However I don’t think it’s feasible/possible to set up everything as script.

1 Like

Exactly the same behavior with alexa voice command for me since few week.

1 Like

I’ve set up same devices and routines on the google home and it’s the same, down to the dashboard devices going “offline”. GH will actually say outright it cannot contact Nabu Casa Cloud.

I opened an issue on github @ Frequent Nabu Cloud timeouts with both Alexa and Google Home HA Skills · Issue #298 · NabuCasa/hass-nabucasa · GitHub feel free to chime in with anything I forgot, please don’t spam the issue with Me too posts, upvote the issue instead, thanks!

edit: I also changed title to reflect it happens with google home too


Happens to me too, and now even more then a few months ago

1 Like

As found out by another ha user from nabu casa support apparently it’s a known issue as they’re upgrading network infrastructure, see the github comment.


I am having this same issue… I finally after a year of planning and playing to get to know HA, I am migrating off SmartThings due to the CONSTANT outages and un reliable setup, to HA with a USB GoControl Zwave/Zigbee dongle running on an ESXi host with the VM having 12GB RAM/8vCPU/60GB HDD. Got all 35 switches moved over and the numerous ZigBee devices and other Wi-Fi RGB controllers and such integrated. When I use the dashboard, everything is stupid quick. But when I use Alexa/Google, they either time out, or waits 10 seconds or so to perform the action… 10 seconds is LONG when you want the light on NOW… I am super disappointed by this and having regrets…

I even shut down the other 6 servers running on this ESXi host and even migrated to another ESXi host and same issues… I dedicated one of the 8 NIC’s to just this VM and put a path in my network to prioritize all traffic and even moved a vlan to make it go direct to internet and thats it… still same issues.

For the time being, now setup local google instead of nabucasa, now it’s instant

@pergola.fabio can you point me in the direction of exactly what you mean please?

1 Like

I mean , I setup this one now :