All in one on a Rapsberry PI 3 fails

have the latest Jessy on my Raspbery PI 3 and run the all in one installer which told me at the very end:

[localhost] sudo: ldconfig
[localhost] sudo: ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages
[localhost] out: ln: failed to create symbolic link ‘/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages’: No such file or directory
[localhost] out: 

Warning: sudo() received nonzero return code 1 while executing 'ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages'!

can anybody help?

1 Like

Is that for a fresh install, or an upgrade?

Hi, have the same problem here, same error message.

This is an upgrade on the latest Dist, on a Pi3 using All-in-one, not a fresh setup as running other systems on the Pi3 and need Home Assistant to run in a virtual machine.

As mentioned by Juergen above, any ideas please.

I tried the other week, before the latest Dist-upgrade, but it failed the same way.

This is happening to me and is driving me crazy. I had HA with AIO before, but I had to flash the SD card and reinstall everything. I have tried installing the AIO about 10 times, always with the same error result. I have also created a issue on the Github page, maybe head there and share your experience so the dev can address this issue.(

I had a lot of z-wave sensors and light switches connected to all kinds of automations on my config, and my “smart” house is even dumber than a normal house without HA. Nothing works.

Does anyone else have any idea of what can be causing the problem? I tried the HA Reddit page, the HA Gitter, no one know what can be causing this. I thought I was alone in this fight, but now I know it is happening to more people…

Just to be sure, are you guys using the latest Raspbian img (I believe it’s 02/03/2017)? I don’t know if the issue comes from the Raspbian img or AIO itself.

Here the same problem:
Warning: sudo() received nonzero return code 1 while executing ‘ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages’!

I use the latest Raspbian img

Hi, everyone.

Update on my part: I had a previous Raspbian image from November and I used that instead if the new one. I also used the old the command wget -Nnv && bash instead if the new curl. This - and I can’t really explain why - seems do do the trick for me.

I now have HASS back up and running. If you’re interested, I have the image on my OneDrive, here (!AlHN56ATj_RBtERikErn1nfCl_EQ).

it didn’t work for me…thanks

something is wrong with the All-In-One

Just got the same error…
[localhost] sudo: ldconfig
[localhost] sudo: ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages
[localhost] out: ln: failed to create symbolic link ‘/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages’: No such file or directory
[localhost] out:



curl -O && sudo chown pi:pi && bash

Don’t use Stretch, use Jessie. There have been many threads about people having problems trying to use Stretch.

I just checked my install log and I have exactly the same problem as this.

HDMI CEC is unusable as a result and in some cases brings down home assistant.

Are you on Stretch or Jessie?

Jessie, it’s a fresh pie with a fresh install, but I found out it’s not the AIO installer, Libcec is broken and there’s a ticket - (my progress: HomeAssistant AIO HDMI CEC error (clean install))

in particular, this issue should be tracked for those wanting to keep up to date with cec: