All third reality power monitoring zigbee plugs are offline

The zigbee part of my system has a Sonoff Zigbee 3 dongle (Texas Instruments). I have 20 zigbee devices attached that include products from sengled (mainly power plugs), Third Realty (power monitoring plugs) heiman (smoke detectors) and a couple of others. 10 of the 20 devices are Third Reality power monitoring plugs

Everything has been working fine for many months

Yesterday an HA upgrade from 2024.1.3 to 2024.1.5 and when it came back, the Third Reality plugs were all offline. All other zigbee devices are fine. I restored back to 2024.1.3 but they stayed offline - which is how they remain. I have tried numerous restarts (HA and OS) and reloaded the integration multiple times. I can see them in the topology diagram, and in the devices and entities lists - all 3rd Reality devices marked as offline or unavailable.

I am currently a 7 hour flight away from my home and am not returning for 3 months, so I am cautious about doing anything dramatic here.

Any suggestions on how to bring these back?

Have you tried a reboot?

I’m on 2024.1.5 and my thirdreality plugs are all working normally. I’m using a SONOFF Zigbee 3.0 USB Dongle Plus-E with Zigbee2MQTT.

Yes, I did reboot few times. Unfortunately I didn’t set things up to allow a remote full power cycle (of my rpi host). The fact that my other 10 ZigBee devices continue to work does suggest the dongle is functioning - just that there is something different about the third reality devices.

Interesting. I’m running the sonoff ZigBee 3 usb plus. (plus what I’m not sure) on zha.

I wonder if something changed in zha in the .4 or .5 release that conflicted with the firmware in my plugs? I see on the thirdreality website that you can do OTA firmware upgrades to these plugs (but I don’t yet now how (even if I could talk to these plugs which I can’t)) This hypothesis however wouldn’t explain why going back to .3 didn’t fix it.

Of course, because I can’t talk to my plugs anymore, I also can’t get the current firmware levels to compare.

Are yours power monitoring plugs? (mine are)

Yes. Here is the link on Amazon.
https://www.amazon.com/gp/product/B0BPY5D1KC/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

thanks - same plugs that I have. Gen 2

Have you ever done a firmware upgrade on them?

My last set of these I purchased in October so I’d think they’d be current (but then I don’t know how long they were in the local Amazon warehouse)

Perhaps I should have installed the thirdreality app so that I had an alternate means of accessing these plugs - but I assumed that involved making them available over the cloud. Did you install the thirdreality app?

I got mine in November and they did have a firmware update available. I’ve never downloaded the third realty app. I did the update through mqtt

To make matters even worse:

2 days ago the plugs all came back online - all at once. Now these plugs have their startup behaviour set to “turn on” - which it looks like they did. A few hours later the 3rd reality plugs all went off line again.

One of those plugs controlled my fridge/freezer combination. That fridge was turned off before I left (several months ago) and the doors were left open to keep it ventilated.

So the fridge came on, and is staying on. The fridge & freezer doors are open and the compressors are probably getting ready to burn out after running several days non-stop. From a camera I can also see a puddle of water forming on the floor in front of the fridge.