Almost there - Alexa skill unable to link account

Tags: #<Tag:0x00007f3267fb61c0> #<Tag:0x00007f3267fb6030>

I think I’m at the goal line, but my Alexa skill is unable to link to my account.
I followed the documentation guide. When I try to link my new skill (from the Alexa app) - I enter my HA credentials on the login page, and then get an error from Alexa “Unable to link Home Assistant with Alexa.”
I’m able successfully log into https://xyz.duckdns.org:8123 from a browser without any issues using the same credentials. It seems like I’m missing something obvious.

Other details:

  • I’m new, converting off of SmartThings to Home Assistant.
  • Installed HA without any issues - pi4b, HassOS 4.14, duckdns, zwave, zigbee
  • only have two devices - Ecobee 4 thermostat and a lamp (zigbee bulb) configured so far.
    • The 2 devices show up in the Lambda Discovery test execution results (with DEBUG = true)
    • Without the debug variable I get
      “event”: {
      “payload”: {
      “type”: “INVALID_AUTHORIZATION_CREDENTIAL”,
      “message”: “401: Unauthorized”
    • For now I’m using a LONG_LIVED_ACCESS_TOKEN

I need to get this resolved before I decommission my SmartThings hub or Management will send me to the garage. I appreciate any suggestions!!

I am using the LONG_LIVED_ACCESS_TOKEN variable and populated it with the generated value. Unfortunately it doesn’t seem to make a difference. When I get to the Alexa mobile app and attempt to link my account, it takes me to my Home Assistant login page. Entering username/pw is where it fails on me (alexa mobile app: “Unable to link Home Assistant with Alexa”). Though I can login through a browser using the same url (https://xyz.duckdns.org:8123) and login credentials.

In the HA logbook there is an entry:
Login attempt or request with invalid authentication from Wireless_Broadband_Router (50.54…

This is so strange, I can’t figure out why it still isn’t working. I’ve even cleared the entire setup and started over and still get the same problem linking the Alexa skill.

I’m going back to SmartThings if I can’t get Alexa enabled without a monthly fee. But I’m out of ideas and have wasted way too many days on this one seemingly small issue :confused: Everything else was fairly easy to get set up.

I have nothing to contribute except that I’m facing the same issue.

I’ve attempted to configure using haaska function and the default function in the main how to guide (https://www.home-assistant.io/integrations/alexa.smart_home/)

I had this working in the passed but had to re link after restructuring my home network. The last step I was going to try was to revert back to duckdns with let’s encrypt as I’m currently using my own registered domain with my own SSL cert that I purchased through namecheap (signed by DigiCert CA) but after seeing your post I’m not sure it’s worth the hassle.

I’ve seen post saying that you must forward port 443 from the outside to your HA instance. Maybe try that ? It didn’t solve my issue but who knows maybe will work for you.