Amcrest video doorbell AD110 initial impressions

Yes, just tested, the camera.snapshot service also works on AD110 through the HA Amcrest integration now.
No issue with new firmware upgrade here.

I am trying to follow your setup for integration tasker with the Amcrest doorbell. I believe I followed all of your steps however I am not successful in making this work. The one part that seemed a little confusing to me was this:
: Now tap the back < icon to exit this menu and you then select the HA call-service task that was previously imported. Now tap on this task name from the profile menu to configure this task.

In the Parameter 1 field, enter: input_boolean.turn_on
In the Parameter 2 field, enter: {“entity_id”: “input_boolean.amcrest_doorbell_button”}

When I selected and tapped the “HA call-service” task that was imported it brought up the task which contained a number of steps. Is this the correct task to update the parameters in? or should I be creating new tasks? It seems different from your screenshots. Thx

Yes.that’s the correct task to add those 2 parameters. If what you see now is different then I guess the template was tweaked a bit since I created those screenshots. Please refer to the thread created by the author of those templates - Using Tasker with HA
I recall there was a mention of a few changes being made.

Seems odd because when I go to edit the task it gives me a screen that has a couple of “If . .” statements and there isn’t a place to enter the parameters.

yes, it certainly is odd. There should be a parameter 1 and 2 fields.

I have 2 suggestions. One is create a screenshot of your HA call-service “Action Edit” screen and post it to the author’s HA Tasker thread asking why the parameter fields are apparently missing.

The other is that instead of using his templates you can install the free HA Tasker Plugin that you can configure quite easily.

Sorry that I can’t explain why this is now different. I didn’t develop these templates, I just tried to show how to use them to interface the AD110.

Unrelated, but in the most recent amcrest app, with an sd card is anyone else having choppy video playback that will skip 5-7 seconds at a time when trying to review the footage? Is there a solution to this?

Not really, viewing in the Events tab used to be hit-n-miss, failed a lot, now it’s been more reliable and pretty smooth playback.
Viewing from the microSD card tab is even smoother, just make sure your card is not having issues. If possible, reform the card just to be sure.
I don’t have cloud Recordings, btw, not set up at all.

I’ll try a reformat, do you think it’ll be better off reformatting on my computer, or using the app itself to reformat while in the doorbell? Have you noticed any issues doing it one way or the other?

Using the app would make sure the formatting is done the way the doorbell camera likes.
I have always used the app to format/re-format.
If you’re backing up the card content on a PC, do a scan on the card as well.

1 Like

Yup, it turns out I had to factory reset it too. I only noticed it stopped working after I realized I hadn’t gotten any motion detected alerts from the Amcrest app for a few days. Tried everything I could to get it to “connect” and show the feed in the app even though I could still see the feed in. I finally gave up and factory reset it and it worked. I haven’t tested the Http Api Snapshot though. I’ll have to check it out.

Anyone else seeing “offline” in the SmartHome app live view today?

RTSP streaming is still working fine.

Just checked, same here, app said offline, both rtsp and HA Amcrest is working fine.

Thanks. Global issue then with Amcrest back-end. Amcrest Support forum also confirms many others down. The only “fix” known is to factory reset the AD110 and somehow it resolves the connection to the AWS servers running SmartHome service.

This issue has been affecting many, but not all, SmartHome app users for 2 weeks. Now something Amcrest did yesterday evening has crapped out the service for everyone it seems.

Usability with Home Assistance is unaffected (live stream, snapshot, motion detect) and NVR recording is fine too, but no way to answer/view doorbell via SH app.

Last night I came up with a way to get my AD110 back online without having to resort to a factory reset. Looks like this is going to be an ongoing issue each time the AWS servers hosting the service change IP’s again, until they can get out a firmware fix.

The problem is due to an incredibly naive firmware developer decision that I won’t go into here. You can get around the problem if your router is capable of rerouting an outbound IP to another.

If interested , refer to this post on the Amcrest Support Forum for details.

That’s prefect!! I happened to have an Asus router, worked as promised.
I did have to restart the camera after it came back online to see the settings again.

Hey @jtpublic - that’s great this router redirect worked for you!

These iptables settings by default will not be saved upon a router reboot unless they are placed in a startup script. The iptables wiki wasn’t really clear how to do this, but my best guess for Asuswrt/Merlin was to put the commands in an executable script named: /jffs/scripts/firewall-start

Is that what you did too?

I did feel this needs to be permanent and did not do the script.
Hoping for firmware update soon.

New firmware is here:
Fixed issues with device incorrectly showing as offline.

Anyone had any issues updating the firmware? I just installed one, tells me firmware update available. Clicking “Cloud Upgrade” says downloading, but does nothing… if I go to the menu and select firmware update, it says “This device does not support cloud updating”

NVM, as suggested by someone in the Amcrest forum I quit the app and went directly to the firmware upgrade in the menu. It seems the pop-up that suggested updating firmware was causing something in the process to hang.

I waited until I got back home to update the firmware - in case it needed to be reset (which some have had to do after an update). I had no problem at all with the update. I never saw this “cloud update” message.

And FYI - the AWS SmartHome servers changed IP’s again a few days ago. With this firmware update, it now appears that the AD110 is finally able to stay connected. Whoa, what an accomplishment by their developers. :smirk: