An important update about upcoming changes to the Home Assistant Companion for iOS app


Done the update. Went like a breeze on iOS13.

On iOS 12 FAIL on my iPhone it crashes when starting. Even tried removing the app and rebooting the phone wo any luck.

Could you maybe have a look into this because now my home away automation will not work :sob:

Fails unfortunately on IOS 12.4.8

I have the same on ios 13.6 on iPhone. App crashes immediately after startup. Also tried hard reboot but doesn’t help. Can’t do anything now except that on my iPad (iPadOS 13.6) al went fine.
Let me know if there it’s anything I can do to help, like providing logging etc.

Reinstalling the app solves the issue!

The app is working when I use my local http-address for my Hassos Pi4. If I am using the external NGINX-address (handled by Hassos) it is not working!

At first start of the app this external address was shown but then a big red X appeared and told that this is not working!


1 Like

Notifications are broken on this new app, including 2 factor notifications so that’s fun…

Reinstalled and it doesn’t work. I really don’t want to have to reset and re-set it up in HA and recreate all my sensors.

I ended up resetting it, still doesn’t work. I have no working notifications now.

You need to restart home assistant in order to make the notifications work again.

Tried reinstalling, done switch off, done hard reset. Done even HA reboot but the app will crash immediately after the double click. So no way to enter any information.

Running 12.4.8 on iPhone that’s a Fail and on iPad 13.6 which works fine.
So it looks to be an iOS 12 install issue.

Tried also the ol trick of removing the app and then a reboot with another install afterwards. Still no luck.

Please release a working version. Please feel free to contact me if you guys need some more information or assistance.

Is there any way to downgrade the app. My iPhone 6 is bombing out when you start the app…it’s fine on my iPad with iOS 13
Why would you release a new package that says it’s compatible with iOS 11 then put an addendum that’s missed easily after all the core information on the app store not to install it on ios 12 or lower…
I would of thought the developers would have removed the app or degraded the minimum iOS level first…Is there no beta testing ?

Downgrade is probably not possible because of the change of owner.
See my post #11 for the stuff I tried.

There was an issue related to the newly added NFC that was causing this crash on certain older iPhones (pre-iPhone 7) and older version of iOS (12 and under) which did not have NFC support.

Due to the recent transition, the TestFlight had to be restarted from scratch and all previous beta testers need to re-enroll. So currently there’s much less beta testers than usual, and most are on newer hardware and operating systems. So this issue wasn’t caught ahead of time unfortunately.

But Zac has already submitted a new version with the fix included. It just has to go through App Store review and should hopefully be available soon.


Thanks Sean. I registered myself now as a tester.

Will test it when available in store again and reply back ;).

Same problem here:
After Updating the app, my notifications stopped working.
I tried several things. Restarting home assistant, Resetting the notification ID, Restarting again, Deleting and reinstallation of the app, restarting, Reseting the app, restarting, Revok the notification rights and granting them back after restarting the app and the server,…
Nothing worked.

When I signed in again it had created a duplicate mobile app integration. I deleted both of them, restarted HA, reset my phones app, signed in again, restarted HA again and then notifications worked. Much more than just “sign in again and everything should just work”

1 Like

that did it :slight_smile:

The new version 2020.5.2 now works as before. Thanks again for the quick turnaround. :grinning:

I can confirm the only way I could get this fixed was to:

  1. Delete all phones from the app integration
  2. Remove the app from phones
  3. Reboot HA and phones
  4. Install apps on phones
  5. I had to manually go to settings/notification and tap permissions to make it ask to allow notifications. (otherwise HA was missing from notifications settings)
  6. reboot HA
  7. reset push id in app
    Push works again