Android 2021.12: Wear OS Beta!

Same problem here. Tried disabling bluetooth as some people reported getting it to connect on WiFi but no luck for me. App on the watch just say “Could not connect”. Setting the watch app from the phone app always goes back to “Login Wear OS Device” and nothing works.

Any idea what might be wrong?

I managed to get it to work by using my nabu Casa cloud url instead of my own url. This is kind of weird because my url (using my own domain) does work for internal and external access but it doesn’t work with the watch app.

There is a long Github issue about this. It seems to be caused by the watch connection being proxied to Home Assistant via the Phone. If you disable Bluetooth on the watch forcing it to connect to WiFi, it will connect to Home Assistant internally without issue. There are plenty of open issues on Stack Overflow from people through the years complaining about the watch being unable to access internal network resources, but no real clarity as to why it affects some people but not all people.

How do you remove a watch when you want to replace it with a new one, it keeps connecting to the old but can’t see a remove option

1 Like

this doesnt sound related to the app

Same here. WIFI works and BT over mobile not.

Is there a way, after setting up the shortcut, to make them more recognizable in the widget watch? Without any label, if i choose 5 scripts, how to know which one is the first in the list and all the others?

set a custom MDI icon to easily distinguish between them

How to do this? For example how to change an icon for a script? From HA frontend or from the Companion app?

from HA frontend or YAML depends on how the script was configured Customizing entities - Home Assistant

1 Like

Hey guys,

I just bought a samsung galaxy watch 4 to use with home assistant, setup everything and installed the home assistant app in the watch but can seem to connect neither by wifi or bt.
Dont know if related or even nevessary but in spite of the working watch/phone connection, the wear os app can’t seem to see or connect to the watch, neither I am using beta apps.
Any thoughts?

Yesterday we had discovered this bug in the production version, its fixed in the latest beta that you can get off github. It will be pushed to the beta play store on Saturday but you are more than welcome to sideload it beforehand. It will install over the production version

1 Like

Installed the latest beta from github and it’s working now. tks for the quick response

1 Like

Is it possible to receive alerts via notify over LTE without having to have the phone around?

create an enhancement request on github :slight_smile: the watch can create its own notifications and it should have google play services for firebase

1 Like

It would be nice to see the tile icons highlighted in Wear OS when the entities are on. its obvious when I’m at home and I switch a light on using the tile option on my Samsung watch 4, but I have to use blind faith that it worked when I’m away from home.

follow this request

I am unable to connect to The companion app using galaxy watch 4. I’ve tried all The solutions I have found whole searching for it, such as disabling BT, disabling vpn, restarting The watch, trying to login using the Android in The settings but after loggning in there, it wont show The device and its not logged in. I’m using duckdns, for example my URL is https://xxxxx.duckdns.org
I have tried adding and removing The port at The end of The link but that doesn’t help.
It works fine on my Android Phone but not on my watch.

I am met with: ‘Unable to connect’

Any ideas?

Somehow it randomly started to work, I kept trying to restart eveerything and it got in. The problem is that it is really laggy when scrolling. Its impossible to do anything on The watch because it lags too much. Can you get this to work better?

Hi i had the same issues with the stable release. Just download the latest beta version under https://github.com/home-assistant/android/releases. it works witout any issues :slight_smile:

Seams a bug in the stable release.

1 Like