Android TV (Shield) no longer works

Hi I
have been using Android TV integration for a long time to control my Shield.
but this integration doesn’t work anymore. I don’t think I changed anything.
I have the following message

I tried to delete and reload the integration by “add integration” and also in yaml without success.

The android IP address is correct
My home assistant is recognized by ADB
The log is empty

I found the cause of the error: It’s the core update from 2023.4.3 to 2023.5.4
Am I the only one having this problem?

Generally speaking, I would always start with the release notes, and specifically Breaking Changes.

In release note, I see The “Android TV” integration has been renamed to “Android Debug Bridge”.
but in add integration, it’s still “android TV”


After reinstalling, I still have the same error. If I remove the core update, it works again.
Maybe it’s related to the Nvidia Shield?

I believe it’s related to your system. After the core update, you should see Android Debug Bridge (not sure why you’re not) and Android TV Remote.

The icon next to your “Android TV” indicates you are using a custom component for Android TV. Try to remove it and see if you get the core integration.
All my Android TV devices still work after the latest core update.

Im having the same issue. I cant find the integration in HACS. Did you figure this out?

Thank you @rodak ,
I just realized one thing:
If you use a custom integration once, even if:

  • you delete the corresponding lines in configuration.yaml
  • you delete it in the “config/custom components” folders

It will appear as not loaded but will still be present.

After restart, the official integration will take its place.

After core update, the name will change to “Android Debug Bridge”

1 Like

Thats what I was missing, thanks :slight_smile: