Any Support for Midea A/C?

Hi Joerie,
You need to check the connected devices on your home network in your router, also you have to reserved the IP.

Yes I tried that yesterday but I can only see connected MAC addresses… (no IP address, no description, nothing…)

Okay, I found the correct IP Address but still it shows ‘unavailable’ in HA. Any suggestions?

If all is setup well then its probably an unsupported device. Either wait if someone integrates this device or follow the alternative usb stick (check aceindy’s posts) with esp

Thanks again for bringing up the “ESP project” and for monitoring it! :+1: :+1: :+1:

As it seems, the project is in a working state now, would you mind starting a seperate thread for this? I’d be happy to assist with that, especially as I feel, this really valuable information is kind of lost or burried in this thread under a lot of other things.

I (and I’m sure a lot of others) would really appreciate it! :slight_smile:

Done --> Support for Midea A/C


Just installed an Ariston Split Air conditioner, and it connects to as the midea units and the “Ariston Clima” android app seems to be a clone of the midea app, so it should be possible to use the cloud integration by @andersonshatch With this unit. I’ll will do some testing and post some conclusions!

I confirm it is working with midea cloud (I had to configure it through midea app as “ariston clima” app is very buggy). It is working on my HA instalation via cloud (the unit is on a remote location, so lan control is not an option for now). It as the fan issue, so I had to use the ‘use_fan_workaround’. Model is Ariston Alys R32 35.

Hi - I have a new split AC - Midea with their supplied Wifi dongle - ran midea-discover : & found unsupported 0xac. Lan Intergration also unresponsive.

So what are my options - I tried the cloud intergration but it is very slow and stops working after few hours requiring a restart. Do I need to go the route of esphome as per - : Support for Midea A/C

Or are there some cleaver people adding more devices to the Midea Lan intergration ?

I’ve been backtracking the Telegram history, and as far as i understand the ESPhome usb dongle will support 0xac

Thanx, did try follow Telegram , but difficult from joning in last few days. Have ordered hardware. Now just the long shipping wait.

If you want to be 100% sure, why don’t you just ask ?
You’re on Telegram already anyway :thinking:

I appreciate all the work that has been done reverse engineering this and putting everything together. Y’all are amazing!

I’ve read through everything I can find and I’m just hoping to see if anyone can confirm that this applies to Pioneer units as well? It would seem so as they use the “NetHome Plus” app as well and the dongle is the same “Smart Kit” unit. I noticed this also goes by the same part number “OSK103” for Midea.

I also found that a dongle oddly similar to the mideahvac-dongle is listed for this series on Home Depot That one shows a different installation document than the one for the mini-split above. Again, it’s different because they use the “Cielo” app here.

Speaking of a Pioneer WYS units like WYS-19 9k BTU

As a side note; It looks like Mr. Cool uses the same “Smart Kit” dongle? which would make them compatible too?

I’d love if anyone could shed more light on this or confirm any of this.

I’m just hoping to clear this up for myself and possibly others in the future. I apologize for the wall of text and I hope it’s not any more confusing that this product line…

I have the exact same model. Could you please explain me what you did to integrate it in HA? I was able to add it into Midea’s App, but I can’t find any way to find it in HA…

@nuggets yes also mr cool is working.
And i think everything with osk103 :sunglasses:

@AlessandroTischer all relevant info was transferred to this topic (it uses esphome)


So the only way to integrate the ac is with new hardware? :cry:

No, you can always take the custom_component from @MacZhou. This works with the original OSK-102 (or something like that, the original hardware).

Go to HACS and search for " Midea Smart Aircon". This component works as well, with some small errors like taking longer than ten seconds to update, but it is stable that you can run and control you A/C. :slight_smile:

Here is the link to th repository:

1 Like

Unfortunately I’ve been trying to use that component for almost a month now, but without any success… The entity is created but remains unavailable. (if you give a look at the issues in ghat repository, you’ll see that I opened the latest one, just a couple of days ago)

This is why I was asking @n0t, since he also has my same hardware

Than debug the errors in this component or buy new hardware… :wink: Sorry, no other choice, as both components are relatively new, and so far working in most cases. :slight_smile: There is no need for a different, third component.

If you ask me, I’d invest in new hardware, it is not very expensive and so far the more reliable component (for me personally).

If you want to debug, you should provide some logs and data about your installation, maybe someone can help. I went the route with new hardware as all is open source and local, that fits my need perfectly and the cost was around 15€ to 20€. :slight_smile:

I am using the cloud integration by @andersonshatch (it is on a remote location from my HA server so didn’t test the local version). This is the version I’m using, installed via HACS and inserted the suggested code in configuration.yaml:

1 Like