Anyone willing to help create a FXLuminaire Luxor Lighting System Integration?

The landscape lighting at my home is controlled by a lighting system called “Luxor” by FXLuminaire. While it does have an app to control it, it is one of the only smart things in my home that I have not been able to integrate in the HA. I am hoping there is someone with much more talent than myself who might be able to help create an Integration for this system.

The system does support integrations with other commercial platforms like Crestron, Lutron and Control4, and they have posted their Crestron Luxor Integration files online.

Parsing through the SIMPL+ file (link) it appears that the system uses string-based commands over TCP and perhaps JSON responses. There is no authentication that I am aware of (the mobile app does not ask for credentials).

I’m no dev, and can’t pretend to estimate the difficulty here, but if anyone with HA component development experience is looking for a project, I would love to do what I can to get this created.

Thanks in advance for any help!

1 Like

I just installed the FXL ZDC controller. Starting to look into this myself.
Not a whole lot out there. There seems to be some threads on the SmartThings forum, perhaps can piece things together for a solution.


So I have been able to piece this together. Not the cleanest, but it works.

I run everything through HA.
I bought a Hubitat that controls the FXL controller. It is running this code.
I then installed Hubitat plugin for HA.
Just created my cards and nodered sequences to do the rest.


Thanks for this. Will look into doing the same!

I realize this is old, but in case anyone else stumbles upon this thread I took a stab at a Luxor integration this week:

I also built OpenAPI specifications for Luxor based on my device (and some other’s work):

It might not handle everything, but if you use it and see something wrong let me know and maybe I can help. You can install it using HACS → Custom Repositories as an Integration.

1 Like

Installed through HACS and I can activate the scenes but individual lights don’t update their proper status (on vs. off) and proper brightness level. Anyone else seeing this?

Hey! Does this still work? I’m getting 2 Luxor FX boxes next week and am crossing my fingers!

I’m the author of hubitat-luxor. A user just asked me for some changes and says it works great in HA natively now.

Awesome! Getting my 3 boxes hooked up any day now. Can’t wait to try this out.

@zeeg First, thank you for posting your Luxor integration! I’m so excited to get this working. I’m having difficulty getting it to work though. I’m new to HA so I tried to figure it out for the last few weeks but since it’s probably an easy human-error, I thought I better ask for help finally.

I was successful in adding the repository and downloading it. It didn’t seem to run config_flow because it never asked me for the hostname/IP of my Luxor system. I tried adding Luxor host in configuration.yml but didn’t seem to help. I added logging to your code so I can try tracing it and it shows that is only loads but doesn’t initiate with the host, no config_flow step.

Can you point me to what I should try next by chance?

Circling back here after a long absence. @zeeg thank you for your work on a custom HA component. Any chance you are still maintaining this? I added some requests as a github issue, but the most important would be that it doesn’t appear to be polling for updates if the state of the lights change outside of HA (ie via the Luxor app or a Luxor-controlled schedule)…


I have installed your Luxor integration on the latest HAOS through HACS. I am asked for an IP when I install the integration and HA accepts it and the integration is created and shows one device on the title card in the integrations screen. There are however no entries created. I have created 2 groups and a theme in the Luxor app but they do not show up as entries in HA.

I had to made a change to

    device_registry = dr.async_get(hass)

because I was getting an error about “await”

device_registry = await dr.async_get_registry(hass)

Now the logs show

Logger: custom_components.luxor.light
Source: helpers/
Integration: FXLuminaire Luxor (documentation, issues)
First occurred: 1:59:55 PM (5 occurrences)
Last logged: 7:55:41 PM

Error requesting luxor_light data: Cannot connect to host ssl:default [Connect call failed ('', 80)]


Logger: custom_components.luxor.light
Source: helpers/
Integration: FXLuminaire Luxor (documentation, issues)
First occurred: 4:53:55 PM (4 occurrences)
Last logged: 8:03:04 PM

Timeout fetching luxor_light data
Error requesting luxor_light data: Cannot connect to host ssl:default [Connect call failed ('', 80)]

I am on the latest HASOS and installed Luxor through HACS.

Home Assistant 2023.4.4
Supervisor 2023.04.0
Operating System 9.5
Frontend 20230411.1 - latest

Firmware on the Luxor is also the latest.
facepack 1.12
facepack_boot: 1.25
chassis: .31

I can reach the Luxor on port 80 and see the webpage with a browser.

Any idea what could be wrong? Things I can try?


I’m having this exact same issue. Have been trying to comb through the python with my limited knowledge but not having luck so far.

Ya, same here not knowing enough python :wink: I’m thinking I will try to test the api manually to see if there are any issues with that and the new firmware. Maybe get some more meaningful errors.

FYI I tried the latest update and no difference.

Cancel that!
I just went through adding a few more groups in the Luxor app, and now I see over a hundred in entities in home assistant. Most are not used in my case, but I was able to control one group.
It’s past midnight, but I also noticed only one of the groups that I renamed has retained the name. The rest went back to group(n).


FWIW, I ended up setting up a hubitat hub for the sole purpose of using @tagyoureit 's Luxor plugin for that ecosystem, then piping it home assistant using the Hubitat custom-component integration.

This works for status and control, and even allows changing colors for the lights, though it is clunky and a waste of hardware. If @tagyoureit ever decided to make an integration directly in Home Assistant, I would be most grateful.

I am fairly green to HA but I have been using Homeseer for many, many years. I have a fairly extensive FX LUMINAIRE system and have been waiting for someone to get this done.

Again, new to HA but I have one I purchased for trial and it is integrated into my HS system.

How do I find this in HACS?

Well duh… I needed to be in the right application. I figured this out and have this linked to my Homeseer system. All is working as expected… :wink:

Recently had a Luxor system installed…trying to use @zeeg 's HACS install but when I try to connect to host it spins for a while and eventually errors that it cannot connect. Running a Synology server with docker. HA container running in host mode.

Anyone using this recently?

Yes, I use it (I switched back to this integration after my hubitat died). It is occasionally flaky but generally works pretty well. I haven’t had a lot of luck changing light colors with it (though haven’t tried in a while), but reporting status and turning lights on/off is working for me.

1 Like