Apple TV - Device is already configured (SOLVED)

Trying to add my 2 Apple TV devices to HA (2020.12).

Previously had these working with old ATV integration. Changed to the HACS Beta version when issuedwith iOS 13 occurred (MRP Protocol?). Have removed the HACS version and added the new 2020.12 HA integration.

When I configure this in the UI I enter the IP address for either ATV and the pop-up window shows “Device is already configured”.

Have restarted HA multiple times and even rebooted my server. Always get the same error.

Is there some file that has stored the old device info I can locate and edit ? There are no Devices or Entities shown in HA related to Apple TV.


Solved this. Found old entries in homeassistant/.storage/core.config_entries.

Stopped HA, removed entries from file and re-started. Apple TV integration notified me of my devices and allowed me to add them.


I had this issue and this fixed it thanks

1 Like


thx! But where do i find these entries?


In the file I referenced. Search for apple_tv.

Thanks for the tip with adjusting the core.config_entries file. I tried several times with the beta as well the new integration, restarted, etc. and I couldn’t add my apple tv.
After deleting the entries all worked perfectly.

Where I can find this file in HASSIO installation?


Hi there,

Can I do this (reset Apple Tv configuration) from within Home Assistant? I am running HA on an Odroid, but have idea how to access files directly.


Hello all
Sorry to restart this thread with a stupid question

I can navigate to the


File but how do I enter the file and amend it?



In file editor I don’t have .storage

how to find it?

I can see the folder and file using samba but can’t do anything with it

I also cannot find it in file editor. If I try to create . Storage it say it’s already exists

Can anyone help please

So I added the file from samba share to file editor. Had a look at the contents and there is no reference to Apple TV there at all

Originally Apple TV was working fine and when I deleted the integration and tried to re install I cannot and get the aborted message

1 Like

got the same issue:

deleted the integration and when trying to reinstall it, it tells me that something wnet wrong and i should try again.

same here. No apple_tv Entries in the file. I’m adding the Apple Tv debug info in my config file and going to see what it tells me. I’ll report back with any findings today

When I deleted the integration and rested HA I can’t access HA. I can ping it but can’t ssh to it. I Reyes hard reboot but no luck.

Dose anyone have any ideas if I can fix this for do I need to reinstall?

Thanks, This solved my issue as well.