APsystems APS ECU R local inverters data pull

Nice! Maybe I’ll buy a newer ECU-R also. Energy prices went negative today and might also be tomorrow.

i got mine on “leboncoin” got it for 80e , never used …

Just got an ECU-R 1.3.10 set up by an installer at my relatives’ place, ID 216000(...).

Can confirm that on plugged ethernet, only 4540 and 502 are exposed. I also get Failed for query_result, but it’s night right now, so that might be why. I will most likely switch to WLAN so we get monitoring on 8899. If TCP modbus works though, that sounds simpler and more reliable than parsing reverse-engineered payloads.

@patmtp35, how did you get TCP modbus to reply to your read commands, please? Did you have to configure inverter IDs in the EMAManager app as per page 5 (archived)? I’ve tried without any setup, and all I get is a timeout.

1 Like

first of all i use wlan and tcp-modbus together.
wlan for monitoring and for the moment i learn how modbus work…
via my routeur i dedicate a fix-dhcp adress to the lan and wlan.
in ema manager i activate modbus , in modbus page you have to validate (upper right ) and ema manager assign an index on eatch inverter (1,2,3,…)
save and goes on with modbus doctor.

you on dynamic electricity prices these days? I’m still not decided yet, i’ll need a battery first to play with and make good use of market fluctuations.

Yes Tibber.

With battery or not?

Sounds good, merci !

How you ste High tariff usage from Grid consumption and Low tariff usage?

do you know which entity i need to put on Grid consumption? Because i have thos below

Hi everyone,

I experimented with the ECU-R TCP Modbus protocol documented here (it’s basically SunSpec).

While it seems to work (though reading is very flaky), my DS3 inverters each have two panels connected to them, and the documentation does not explain how to retrieve the individual metrics for each of the two panels, per inverter. We can read power, amperage, etc. but it seems to be an aggregate value and not what the EMA system reports per individual panel.

Naively, I tried to contact APsystems, but in the most unsurprising big-industry move, they did not even try and told me to kindly f- off, whole message reproduced below:

We don’t provide technical support for modbus.

Did anyone attempt to further reverse-engineer or discovery hidden Modbus registers to read individual panel metrics? Is Modbus really limited to reading aggregated metrics? Thanks a ton!

The addresses follow each other without leaving space in between, so I think it is unlikely that more information is available. My proxy method shows all data that is uploaded to the EMA site, but then you have no signal strength from the inverters available. What you do see is the DC voltage, power and amperage per channel. In addition, inverter temperature and frequency per inverter. I’m not sure though how compatible it would be with all ECU models and inverters and it creates a dependency because you then have be able to do DNS rewrites (using AdGuard or PiHole for example).

Thanks, that’s what I feared. The proxy method has a resolution of 5’ (as in, the RCU-R pushes every 5’) and isn’t real-time, correct? Not that I can verify how good the refresh rate for Modbus registers is, anyway :slight_smile:

Correct, data is only updated once every five minutes, also to the EMA site. A lot can happen in five minutes with partly cloudy skies. I therefore wonder whether the number of watts emitted is an average over those five minutes or the current measurement.

1 Like

Anyone having issues with the connection being unstable as of late? Past few days I’ve ran into multiple instances where the ECU-R will have the Wi-Fi/internet light lit up, but suddenly stops reporting values to home assistant, to Ema or both. I have to fiddle around with reboots of the Ecu and router and HA and than, sometimes it will start to work again. But I can’t find the combination that will guarantee it will work again. Very strange

No issues here, everything runs as it should.
ECU-R 2160xxx

i’ve just a power cut to the ecu and wait a bit , then turns on again. Sometimes it cant reconnect wifi properly and i kill it from the active list in wifi clients (omada).
power cycle is automated with a delay of 15 seconds. Seen it twice last week. Last occurance may 10th. Recovery with this is 99%

If the ECU loses the internet connection for a certain time, it will stop sending to the EMA site and the integration will no longer work. Actually, a restart of the ECU should be sufficient and it sometimes takes 10 minutes before data is uploaded again after restoring the internet connection.

Can you recall if anything was changed in the network configuration? Were firewall settings changed or WiFi APs moved? Changed cabling or added a new device?

Try if you can figure out if the ECU has connection drops on the internet.

First a correction, I said I had an ECU-R, but it is an ECU-B, sorry about that.

Nothing has changed in my configuration, not on WiFi, not on the solar side of things. I noticed a dropout a few days ago and just did what I always do, unplug and plug the unit back in. However, where before this would fix the issue, now it keeps returning. After that I kept getting “0” readings in home assistant. For example yesterday I left for work, all was fine. But an hour later it was suddenly reading 0’s again. In the Ema app, all the data was still present, but HA would give 0 inverters online, 0 for frequency, 0 for current production, etc. When online the signal strength is around 70/75%. First sign of a problem was visible on May 10th, but after a short interruption it would recover (3 times that day) but the past few days, say from the 14th, it will fail and not recover. Really weird. Look at yesterday for example.

So it appears to be more of a local problem than a EMA/internet problem…

It appears that there might have been a totally different and unrelated problem that showed itself through this integration/connection failing. A few days back my complete setup became unresponsive, rebooting fixed it for a few minutes, but then would stop again. Hooking up a monitor to the HAOS box I saw problems with reading and writing to the SSD drive. Tried making a last minute back-up (because setting up a better backup schedule and NAS destination was still on my to do list) but it was already too late and was unable to retrieve it from the system before the whole drive kicked the bucket. Got a new drive and still busy with setting things up (setting up a backup schedule should have been way higher on the list :frowning: ) But for now, no more communication problems…