APsystems Sensor for Home Assistant not visible

Last week I lost the integration with my APsystems solar panel integration and I can’t get it to work again. I have downloaded things again from bgbraga/homeassistant-apsystems: An APsystems Sensor for Home Assistant (github.com). I followed all the instructions and although I do not get any error messages I also do not see anything happening.

The entity used is dead and I can’t the entity that should is used by the integration. I’m a bit stuck here.
Am I overlooking something? Any help is appreciated.


The logs are showing this.

'Unable to prepare setup for platform apsystems_ecur.sensor: Unable to set up component.
‘12:24:39 PM – (ERROR) setup.py’
‘Error during setup of component apsystems_ecur’
‘12:24:38 PM – (ERROR) apsystems_ecur (custom integration)’

1 Like

I’am using the same repository as you are using but i can’t get it to show up in my HA energy as entitiy. It now shows information on a card and that still works. The only strange thing is that the time and date are off by 3 hours. My time is 11:30 and apsystems is showing 14:30. Still down on your HA? I’m by the way using an ECU-C not the ECU-R :wink:

i’m using a ECU-C and not the ECU-R which most users of AP Systems are using

Hi NIels,
the ECU-R that I have was connected using an ethernet cable. However, to make things work with HA you need to connect it also (!) using wifi. If you google the manual of the ECU you will find how to do this. I have set it up using both. Once the wifi connection is created you can connect it to HA. It should work. It did for me until something got messed up.

Were you able to setup your ECU connected to both ethernet and wifi?

I see two ip adresses when i scan with angry ip scanner so i think it’s a yes. Local is see this dashboard:

In the energy dashboard it doesn’t show up:
picture Energydash:

Picture entity solar:
Energy HA 2
Stil no entity to put in there to give an accurate reading

This is how the ECU-C is installed:

. On this ECU-C there are CT-clamps for monitoring the current on every phase. At my home it’s 3 phases (3x25A)

Your system is far more high tech compared to mine. The ECU-R is a simple thing. The connection is however made with a different entity Have you checked with ECU in the name?


yes i did. I think it has something to do with the diffence between the ECU-R and ECU-C. There is also poor information about how to integrate this APS in HA. My APC card is workind on my HA screen:
APSystems ECU-C info HA. And that information is pretty accuratie (3 hours behind scrapped from there portal). I’m still looking for some fix for reading out my ECU-C locally. But I’m not so good with coding myself. I rather use something that somebody else, experts coding, make to come with a good sollution. All entities showing up in the energy dashboard are readings from my smart energymeter (P1-port). No APSystems… Thanks for your help and i wish i could help you to

Have you checked for a lifetime entry? It should be provided

I still have this:

This is all correct

  • platform: apsystems_ecur
    sunset: on
    I have followed the instructions to get these numbers and I had them in the past. I guess I still need to do some soul-searching.

I have almost the same config in my configuration.yaml.
#apsystemsema.com (zonnepanelen) GitHub - bgbraga/homeassistant-apsystems: An APsystems Sensor for Home Assistant

  • platform: apsystems (yours is apsystems_ecur)
    username: username
    password: password
    systemId: systemidisalongcodefromportal
    ecuId: ecidisfromyourapp
    sunset: on
    Otherwise could it be another ip adress of you ECU-R? Can you still login in portal
    https://www.apsystemsema.com? Maybe pull the powerplug of your ECU-R and wait for a couple of minutes and then plug in again. Maybe it’s also good giving it an static ip-adress.

I changed my config to:
platform: apsystems_ecur
username: username
password: password
systemId: systemidisalongcodefromportal
ecuId: ecidisfromyourapp
sunset: on

And look what pops up when restarting my HA server:
APSystems invalid config

I think when changing your configuration.yaml ->platform apsystems_ecur in apssytems like mine it should be working again. I’m gone try this config:

Let me now if it works

In log file it looks like this with the wrong config:
Logger: homeassistant.setup
Source: setup.py:291
First occurred: 16:07:12 (1 occurrences)
Last logged: 16:07:12

Unable to prepare setup for platform apsystems_ecur.sensor: Unable to set up component.

I get this error when I’m running this. The problem is that I can’t find the file itself. It is not present in the custom_component folder apsystems_ecur.
I have downloaded the setup from github. I have done the same using hacs but the error remains.

I have even tried GitHub - bgbraga/homeassistant-apsystems: An APsystems Sensor for Home Assistant
This one does NOT return any errors but also does not return any data

  • platform: apsystems
    host: 192.168.188.xx
    scan_interval: 60

Do let me know if you have an idea where this file resides: Source: setup.py:291


Maybe it’s better to reinstall everything using hacs and than edit the config again. In the lovelace interface it’s working for me but can’t get it to integrate with the energy dashboard. In grafana dashboard its also working using influxDB for saving the data. Only by scraping the data from their portal. Locally it’s not working for me.

Is it working now? Maybe you can try this fork: GitHub - skelgaard/homeassistant-apsystems: An APsystems Sensor for Home Assistant when it still isn’t working

I did fix my problem with the ECU-C. Changed the repository in: GitHub - ksheumaker/homeassistant-apsystems_ecur: Home Assistant custom component for local querying of APSystems ECU-R Solar System. All others I deleted/removed in HACS In configuration.yaml I put down the config:
host: ipadres of ECU-C (i think the wifi IP-adress)
scan_interval: 60

And I edited the file like its done in: Yc1000 compatibility / ECU-C support · Issue #6 · ksheumaker/homeassistant-apsystems_ecur · GitHub by normanp2pl · GitHub.
step 1:
I installed ECU-R integration
step 2:
I modified lines 115 and 124 of APSystemsECUR.py to this:
if “ECU_R_PRO” in self.firmware or “ECU-C” in self.firmware (search in code and replace ECU_R_PRO when its in the same line of code with self.firmware).

Now there are entities in energy dashboard:

When I look for settings ->devices and services → tab → entities I see a lot of entities when searching for: ECU. Integration is now called: APSystems PV solar ECU-R (which is not correct for me, but I dont care for this moment ;-)). See picture bellow:

All voltages, signals, temperatures from all APSystems devices on my roof and technical room are showing up. Really great stuff.

With Grafana it’s really showing off. 18 solar panels in one screen and above of each panel, the latest, max day and current (from 14u it’s started working ;-))

Isn’t this a solution for you also?

1 Like

Niels, I will look very close at your solution. I implemented this one GitHub - bgbraga/homeassistant-apsystems: An APsystems Sensor for Home Assistant but the result it still the same. I don’t get any errors but there is still no result.
What you are showing is impressive. This is what I want to see. I will implement things as you describe and hope t see better results. I only have 8 panels but it would be nice to see all of them individually. Thanks for your answer!


I have installed things as you have shown. I have also made the adjustment. However, the line numbers are not entirely correct for me. I did change ECU_R_PRO to ECU-R 4x in the file.

Rebooted HA and got no errors. It is now also showing the sensor values without them being dimmed.
I guess tomorrow will be a big day…once data comes in and my energy panel starts to show data again.

I do hope you solved this puzzle for me. Thanks!

1 Like

Alle sensors are down now. I did read in the comments as well that’s there might be a problem overnight. It has something to do with the sleepingmode of the controller when there is no sunpower available. It doesn’t come up the next day, I just found out for myself too. We are gonna dive in to it :wink::sunglasses: