Aqara E1 USB Hub in Home Assistant?

I have a recently purchased Aqara E1 USB Hub and an Aqara Roller Shade Driver E1. Both are setup in the Aqara app as well as Apple HomeKit and Google Home and all is working well. My HomeKit automations are working well etc. But I am also running Home Assistant and have all of my other devices in there as well as Apple and Google. I thought getting the new Aqara gadgets into HA would be as simple as installing the integration and linking it to the hub but it can’t find it so it appears to be unsupported. Then I thought there may be a way to link it to my Aqara account the way Google Home does but I can’t find a way to do that either.

So I am now stuck. If I can’t get it into HA it won’t be the end of the world as it is all working outside of HA. But you can easily write more comprehensive automations in HA and I would like to do that if I can. I really don’t want to have to start from scratch again so is there any way to get the Aqara items (just the blind driver would be enough) into HA without have to start over?

Have you tried the homekit and/or homekit controller integrations?

What is the underlying technology? A lot of Aqara stuff is Zigbee. But you don’t say what it is. Google suggests it may be zigbee.

If so I suggest you buy a proper zigbee co-ordinator and use ZHA or Zigbee2mqtt.

EDIT sorry I see you did tag this post as zigbee, so hopefully my suggestion will work :slight_smile:

I do have the HomeKit integration installed but it seems more involved in getting things from HA to HomeKit, not the other way.

The HomeKit Controller seemed more the way to go but when I tried to install that I get the message “No unpaired devices could be found” and that’s about as far as it goes.

When you say a “Proper Zigbee Co-ordinator” do you mean something to replace the Aqara Hub or is this some additional piece of hardware? I thought finally moving to Zigbee for my new devices would make life easy for me but that doesn’t seem to be the case.

I think you have to unpair it first from Apple Homekit, and then pair again with Homekit controller.

1 Like

Will I then be able to pair it again with HomeKit or is it one or the other?

Something else I thought of too is the Aqara Hub should soon be getting a firmware update with Matter support so perhaps HA will see it and the devices connected to it (that aren’t getting Matter updates) that way.

AFAIK, then you need the Homekit integration to get it into Apple Homekit again.

I have Aqara devices with the Aqara E1 Hub.

The devices can be paired with either HomeKit or Homeassistant (but not both at the same time).

I used to have it paired with HomeKit (via the E1 Hub) and then linked to Homeassistant via the HomeKit Controller integration.

Since then, I have become HomeAssistant-centric, so I now have it paired with HomeAssistant (via a Sonoff 3.0 stick and Z2M) and then linked back to HomeKit using the HomeKit integration.

Note: “HomeKit Controller” and “HomeKit” are 2 different integrations.

I had a bit of time on my hands this morning so I had a go at reconfiguring things and I am happy to say it is all working as I want it. I simply removed the E1 hub from HomeKit and it was immediately detected in HA as a HomeKit hub. I configured that and then used the HomeKit controller to push it back into HK. A little bit of a cleanup after that and it’s all good. Thanks for the help!

2 Likes

Ok i think i figured this out…

1: Stick the Hub E1 in the usb port of f.ex. your Raspberry Pi.
2: Set it in to pairing mode by pressing the button. if the led flashing slowly, click on it about 10 times or untill it starts to blink fast.
3. Pair the device on your phone in the Aqara Home app and the Home Kit Controller should have popped up on your “Devices & Services”.
4. Click “Configure” and enter the pairing code that is on the back of the usb stick (12345678).

You should now be good to go.

There seems to be several modes this one can operate in. If its in the wrong mode, its absolutely impossible to get it to show up in HA. And only way to see witch mode it is in is by the led flash when in pairing mode.

Hello,
I have followed on the problem that you have had in bringing the Aqara devices to Home Assistant.
I have Aqara Hub M2, connected to 10 devices (T1 switch, door sensor, P1 sensor, smoke detector).
My HA is running in Rasberry Pi 4.
Recently I have purchased Aqara E1 hub and connected it to one of the USB ports in Rasberry Pi.
I have connected the E1 to Aqara app and Home Kit.
No devices are connected to E1 in Aqara app and Home Kit.
I have two questions

  1. The Aqara E1 hub is not detected by HA. What should I do for HA to detect the E1 hub
  2. How to detect all the Aqara devices in HA

Thanks

Recently I have bought Aqara hub e1. I was able to make it work with HA. I did on the following way

  • Plug Aqara hub e1 in any USB(Just for power it up)
  • Set it up via Aqara app
  • Connect all the sensors via Aqara app
  • Plug Aqara hub e1 on the raspberry pi USB
  • Remove HomeKit device from Aqara app and it immediately available on HA
  • I got all my sensors and it worked fine with other device on the HA

I followed the same process, I can see the Homekit Bridge in HA but cannot see the sensors linked to my E1 Hub. The sensors I am using ar the Temp/Humid and Water leak sensor.

How did you resolve it? I have E1 Hub and water leak sensor too. Want to find a way to work in HA.

I know this is an old thread but just came across it.
I just connected mine E1 hub and have my sensors working. In my opinion the E1 does not connect directly to Home Assistant. What i believe is happening is the E1 hub is connected to the smart devices and it is connected to the network (WiFi) and it creating a sort of loop / passthrough for the device to work in home assistant with HomeKit. The E1 Hub does not work natively within Home Assistant. By this I mean it does not connect via a driver etc via a USB on the hardware running Home Assistant.

Ok, I think I will jump in here and start asking my questions. LOL.
I purchased an Echo dot (3rd gen) along with Sengled Bluetooth Mesh bulbs and set these up in my apartment. Everything worked fine. I moved into a bigger home and added 3 more Alexa devices and more Sengled Bulbs. I then bought 5 Aqara Motion sensors along with the E1 Hub. Again, everything seemed to work correctly, minus the automations working correctly for lighting control. I then bought Amysen smart plugs and an Aqara Presence sensor. Still not getting things to work like I’d like.
Enter Home Assistant on an x86 Lenove ThinkCentre as a standalone system. This should fix everything; however, I feel as though I’ve walked into another rabbit hole. I have an Apple phone, but never set up HomeKit. All my devices worked via voice through Alexa. I don’t want to have to tell my rooms what to do, I might as well flip a switch. So, this is where I am at. Home Assistant is up, I have these integrations: Android TV Remote, Blink, DLNA Digital Media Server, Google Cast, Google Translate text-to -speech, Home Assistant Supervisor, HomeKit Bridge, Internet Printing Protocol (IPP), Matter (BETA), Meteorologisk Institutt (Met.no), Mabile App, Radio Browser, Roku, Shopping List, Sun, Tuya, and Vesync.
I have Blink, Invidyo, and Wyze cameras I would like to integrate into the system as well. The Blink cameras merely show an old still and do not operate correctly. I am unable to get any of my Sengled bulbs to be detected, along with my Aqara devices.
Upon reading, I found I needed a zigbee controller, and read that the E1 Hub is a zigbee controller. How do I get all this to work??? I am reading that the E1 cannot be plugged into the device as it won’t work by itself and needs a different zigbee device.
This is what I would like: all my devices in each room of the apartment to be found by HA. Then I would like to set up simple automations for presence in these rooms and finally, be able to view each of my cameras for security when I am away from the home. I do have Nabu Casa Account currently free version connected but would prefer to not pay if there is another way to set these up.
Any help would greatly be appreciated to get this up and running within the week so I can focus on other things and quit fighting with my daughter about the HA not working. LOL.

Has anyone fully figured how to get it into HA as Im really struggling tried many ways and I get it to come up in Ha but with error flows or it goes off and I get no options to configure.

I have tried in Homekit to ass the E1 Hub with no luck then tried with Homekitcontroller and then get it to bind in Aqara App on ipad comes up in Ha then get the erro flow.

Any clues on how I can get this to work as I have got blinds to try to get into HA

Forget what I have put here I have fully figure how to do it! All working in HA as well as on ipad and Samsung Tablets :slight_smile: