Aqara FP2 Presence sensor

I followed exactly the same route, though not without glitches:

  • one of sensors did not received yet update, forcing check shows that it is up to date :open_mouth: As this is recently added to my setup, I assume this is because of newer HW build and update should come soon. One strange observation for this particular one; router hsows different MAC address of sensor than Aqara app :open_mouth:
  • I have one sensor from China distribution (unlike others from European one), so need to switch regions in App to get FW update… otherwise, for HA works the same. Just additional tasks to remember…

Hmm, I don’t allow unknown MACs on my network, I usually have to add a device twice to get it on the correct SSID, once to an SSID with nothing on it so I can get the MAC, and again to where it’ll live. So if the 1.2.5 to 1.2.6 update changed it’s MAC during the update process, that would probably explain why the only one of these I had that tried to do that update, bricked itself.

UPDATE: OK so not bricked apparently, had to reset the FP2, reboot my phone, reboot my access points, clear the ARP table on the router to get it to rejoin, but it did rejoin. Very bad form, MACs are the identifier of the device, you can’t just change them on a whim. LIFX has done this too, but usually only by adding 1 to the old MAC.

Hey @skorpioskorpio, I experienced the same just now, I couldn’t understand what’s happening for a rough 30 minutes, kept reregging the device and failed at it :slight_smile:.
Not only the MAC changed from dc:ed:83:xx:xx:xx to 54:ef:44:xx:xx:xx, but the device string has changed too. Originally it announced itself as “Presence-Sensor-FP2-XXXX”, and after the fw upgrade this became empty (“”).

Yea, I had had only one update, a couple days after I posted that all the rest updated at once (I have 21 of them). What a mess, hopefully they won’t do that on the next update.

Hi guys.

Back in the days i had ~10x FP1 and they where just crap.
The issues i had:

  • ghosting (sometimes it just triggered, and nobody was in the room)
  • stuck in “presence detected” (sometimes a cold power reset helped, sometimes re-pairing). At the end a few of them i had to swap the PCB for 180 degeres or remove it to get it working again.

After all the issues (also after several fw updates) i decided to replace all of them with esphome DIY sensors with DFrobot SEN395. They work better, but sometimes, when i am sitting still for while the are clearing the presence.
So i am looking for an upgrade to these.

Now, that the FP2 is out in the wild for a while i want to know your thoughts, issues, …

Also read wome reddit, amazon, … posts, that also ghosting is an issue on these.
The last changelog of 1.2.6 also states some improvements on ghosting.

Can you please share your experience with these FP2 sensors on different Firmware Versions (maybe also the new 1.2.6).

Thank you
pOpY

I’ve read through this thread and Googled it, but maybe I missed the answer…

Is it at all possible to get the FP2 to link up to HA if they are on different subnets? When I go to add the FP2 to HA via the Setting > Integrations > Apple Homekit > it says there are no unpaired devices available to add… Probably because it on a different VLAN, but I’d like to keep it that way if possible… Can I? Or are we forced to have them on the same VLAN / subnet?

1 Like

I still have some ghosting issues, but not often and not that bad. The FP2 is still not great at detecting me when I sit still, which was suppose to be one of the great selling points of this sensor. I think performance really depends on your environment, so you might just have to buy one and test it.

2 Likes

It is possible to setup your VLAN communications to allow HomeKit discovery across VLANs, but exactly how you do it depends on your network equipment. Here’s a blog post I found that talks about doing it using UniFi equipment (the part about HomeKit is down the page a ways). If you aren’t using Unifi equipment, it might get you pointed in the right direction.

3 Likes

Thanks for this. I am using UniFi so hopefully I can get this working. I’ll have a read now, thanks for the link.

EDIT: I’ve added the firewall rules as per that link but I’m still not able to add the FP2 to HA (not detected).

I don’t want to derail this thread too much but is what I have here correct?


The bit I’m unsure about is the ‘type’ because that wasn’t shown in the linked website so I selected ‘internet local’ as a guess…

I think you need LAN Local as the type. It’s not in any of the screenshots in the article, but when you get to the HomeKit section, there is one line in the text that says the author is looking at LAN Local setting. You could be forgiven for not noticing that. :laughing:

1 Like

I’m just updating the rule on my phone and now see that option. I didn’t see that one when on PC earlier for some reason.

Trying it now…

Edit: so far it’s still not detecting the FP2.

I’m sure you have already done this but have you removed the FP2’s from home app? I also had to restart HA then mine were detected.

“Home” app? Which app are you referring to exactly? I setup the device in the Aqara app and then tried to get Home Assistant to discover it on my wifi… which it didn’t due to VLAN’s. I tried to create the appropriate network rules for it to be seen across VLAN’s but they didn’t seem to wok.

In the end I reset the wifi credentials on the FP2 and just put it on the same VLAN as HA instead of my iot VLAN.