Aqara M3 Hub

Hi all. Has anybody installed the M3 hub in HA?

I am struggling to complete this task. I can see the hub but when prompted for the Homekit code, HA dossnt accept anything I enter (there are 2 8-digit codss on stickers on the hub and niether of these work even if I type them in the xxx-xx-xxx format

Thanks in advance

Peter

Have you previously paired the M3 hub with any other Matter controller? eg Apple Home/Amazon/Google ?

Ive used the sticker on the back of the user manual and that worked. However , im not seeing the devices. I can set it and set it as a border router but still no devices.

Hi Kevin. No, it is just running standalone at tjis moment in time with the T1M light. I have it all setup in the Aqara app

All sorred. Where HA asks for the pairing code in the format of xxx-xx-xxx, i took out the hyphons and it has allowed me to add the aqara hub. Thanks for any comments which were provided

Does HA see it as (O)TBR or just MATTER hub ?

@AsztalosZs mine is being seen as both.

I have both the old Window/Door sensor (non Matter Zigbee) and the matter Window/Door P2 sensor connected. However, I can only see the zigbee device at the moment. Has anyone else got this problem?

1 Like

I’m primarily interested in this, can you see something here?


1 Like

I have the same exact issue. In HA only the Aqara Zigbee sensors show up but in Home Kit everything shows up.

@Miles81 I added it seperately as a Matter device. You need to go into the aqara app, choose the device, then expose to matter to create a temporary code.

I haven’t been able to get the TVOC sensors into Home Assistant and the sockets aren’t showing any of the sensors, just the control switch.

I just got my Aqara M3 Hub yesterday and have been trying to get it added to HA since then. Have been unable to get this done and its driving me nuts!

This is how I set things up:
I initially set up the hub in the Aqara app and added my U50 door lock to the hub. Was seamless. The hub has an ethernet connection to it and has a good connection.

I used the Aqara App to add the hub to Homekit - that worked well too. Shows as a Matter hub in Apple Home - and the U50 syncs over perfectly.

Then I tried to add the device to HA, I generated a code through Apple Home as instructed by the Matter integration in HA, but no dice.

I have tried it with the hyphens and without. Same result.

I’ve tried the code on the sticker on the back of manual - no dice. I tried the “other controllers” option and tried the temp matter code from the “expose device to matter” in the aqara app - not working.

I managed to add the device to Google Home using this method though. Then tried to generate a code in GH and add to HA - no luck that way either.

So I am thinking that something is wrong with how I have things setup in HA.

I reset the hub to factory defaults a few times too (hold button for 10 seconds and then tap it several times). I’ve even tried not pairing it to the Aqara app and use the Matter code on the back of the manual - it said it was binding - didn’t work.

When I use the Thread integration - it shows AqaraHome as the TBR and preferred network. I can’t change it to anything else. Is there a way to reset this? I’ve tried removing the integration, restarting HA multiple times - no luck.

Would love some guidance on what I am doing wrong - cos it has be something silly I am overlooking!

EDIT: One thing to add is that the hub did show up as a Homekit accessory in HA and that added perfectly well. I was excited about this - but it has only brought over 3 entities - no actual devices.

Okay - so I backup up my instance, restored a backup from before I had introduced the M3 and then added Matter once again. It didn’t want to install correctly but eventually it showed the option to add a Matter device from the Integrations menu and I managed to add the hub in one go! So must’ve been something funky with my install. I also note that I have no preferred network under the Thread integration.

Anyway - I have it integrated now!

What is actually working from the Aqara devices? The TVOC sensors are not working for me at all and the plugs arent showing energy usage.

Hey Emmett - I’m fairly new to the Aqara space after having dabbled with all the Xiaomi hubs and sensors a long time ago.

Hence I only really have the M3 Hub, the U50 door lock and two no neutral light switches. All of those seem to work perfectly well with HA.

I don’t have any other sensors and at the moment don’t believe I need them as my HVAC and Air Purifier provide me with air quality/humidity/temperature and other information. Sorry I can’t be of help with those!

Hello, so I have the hub installed and see it in home assistant because I’ve been able to connect to it via the code on the back of the device. So now it’s connected to the homekit integration, but it won’t find it in the matter integration I installed for it. Am I doing something wrong?

I have the app installed on the phone and have the hub there as well. it wants me to expose it to matter and I do get a connection code for matter but there’s just no way home assistant is seeing anything to connect to.

Okay leaving this here for future reference but after some fiddling I found out I needed to use the home assistant app and that worked great.

I had the same issue with the homekit integration working but matter not. the only way i managed to fix this was rolling back HA to a previous backup. it wasn’t the smoothest experience but it worked for me.