Ariela - Home Assistant Android Client


#463

I think the latest one, I just went on the Play store and its updated. I sent you another file, maybe I attached an older log

EDIT: I removed the data, unistalled the app, and reinstalled fresh, I can see its an updated app now. Now it does not crash in Lovelace, but its empty (only blue ribbon with DASHBOARD written), I sent the latest log now (from the app)


#464

Hello all,

Version 1.2.2.6 is out
What’s new:


#465

Awesome! I’ll update as soon as I get home and report back.


#466

Hey Ionout!

Did you fix the widgets taking loads of mobile data issue? I’ve disabled background usage and deleted all my widgets just in case as that used up the majority of my data allowance for the month!


#467

Yes, the latest version should have that fix.


#468

I’ve updated and now on my home network I have notifications! Thanks Ionut!


#469

Another widget I would like is one that interacts with the alarm_control_panel domain. Specifically, having one widget each for arming the alarm in home mode, away mode, and disarm would be amazing.
BTW, I am using a couple of picture-glance cards that you have just added support for in lovelace, but my state images are not being displayed. They (the images) are stored locally on my HA machine so I don’t know if they can be displayed in the app without them also being stored on my phone, but a feature I would recommend.


#470

Glad to hear that it works.

I will add this to my TODO list.

The images should be displayed even if they are stored on the HA machine. Can you send me the configuration of one of the cards that do not display the image?
Thanks.


#471

Here’s one of my cards:

cards:
      - type: picture-glance
        title: Den
        id: den_media
        entities:
          - switch.hulu_den
          - switch.netflix_den
          - switch.plex_den
        state_image:
          "Hulu": /local/images/hulu_logo.gif
          "Netflix": /local/images/netflix.png
          "Plex": /local/images/plex.png
          "Davinci Channel": /local/images/off.jpg
        entity: sensor.den_media

      - type: entities
        entities:
          - media_player.matthews_echo
          - media_player.echo_office
          - media_player.matthews_echo_show

#472

Hehe, it seems i do not handle the state_image but only image attribute.
Thank you for reporting it. I will add this fix to my TODO list.


#473

Hello all,
Version 1.2.2.7 is out
What’s new:

  • added Polish language support
  • added Romanian language support
  • fixed picture-entity issue
  • fixed push notifications SSL issue
  • other minor fixes

#474

4 times today I was welcomed home while I was at work - because Ariela reported me as being home.
I assume this is the same issue as where the battery was skipping to 52% I experienced a few days back.
And I’m sure it has to do with Huawei battery manager. Because today the times I was reported as home also is the same time battery status was updated. And as normally Ariela would report every % change in battery it now only reports sometimes. But that still doesn’t explain why it reports me @ home (or 52% battery). It seems maybe some status is stored in Ariela, but it’s not last known status, but rather some (random) previous state ?


#475

This is the way device tracker works in Ariela:

  • if the current location can be retrieved it sends the current location
  • if you set a home wifi(Ariela -> Settings -> Home Wi-Fi list) and your phone its connected to such network it will report to HA that you are home
  • if the location cannot be retrieved, the last location known its used.

About battery level, Ariela will just use the standard API to retrieve battery level, and i didn’t see to have false results until now, but i will still investigate this.
Anyway, please try to retrieve the logs when such issues happens, so i can investigate and fix.
Thank you.


#476

Hi,
Could you send me the file for translation?
I could translate it for dutch language.

Greetings


#477

The file that require translation has been send via PM. Thank you very much for helping me translating the app.


#478

Hello all,
Version 1.2.2.8 is out:
What’s new:

  • fixed crash when entering thermostat control
  • added markdown lovelace card support
  • fixed picture entity lovelace card bug
  • fixed picture glance lovelace card bug

Please test it and let me know how it goes.


#479

Just updated and picture glance is working great! Thanks!


#480

Glad to hear that is working as expected :smiley:
Also, this is for all users: please let me know what other features you would like to see in the Ariela.


#481

Just installed.

  • Initially would not authenticate with owner password - this is probably due to how I have authentication configured (just default settings) and the changes to authentication going on.
  • Tried ‘trusted network’ and this again would not connect.
  • Ended up with a long lived token.

2 Problems;

  • I cannot see my device in HA. Do I need to enable discovery somehow and is there any way to limit this to just the device Ariela is on?
  • The whole dashboard does not load (not on Lovelace yet).

Initial impressions are great - could do with some documentation though.


#482

If its shown in Ariela , then the device tracking was initialized successfully. In order to show that device you will have to add it to a view / group

Can you send a screenshot please?

Documentation is in progress., and i am glad to hear that you like it.