Ariela - Home Assistant Android Client


#503

Awesome work, Ionut! We really appreciate your work and responsiveness! As far as lovelace cards, I think it makes sense for you to support every built-in card for sure. I would like to play around with differenct cards and not have to worry if Ariela supports it. Also, and I don’t know if this is possible, but it would be nice to have custom cards supported as well. That may be too much to ask though, lol.


#504

Thank you very much. That’s the plan, to support every build-in lovelace card. About custom cards, that i believe i can support after all other build in cards are implemented and the custom card to have high demand.


#505

I do not think it likes my device name…

2018-11-26 22:08:01 ERROR (MainThread) [homeassistant.core] Error executing service <ServiceCall device_tracker.see (c:d49b0b4e787e4e2daf594f9e60155aa3): dev_id=moto_g(6), gps=[55.866943, -3.524786], gps_accuracy=15, battery=39, host_name=moto_g(6)>
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/core.py", line 1177, in _event_to_service_call
    await service_handler.func(service_call)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/__init__.py", line 223, in async_see_service
    await tracker.async_see(**data)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/__init__.py", line 289, in async_see
    dev_id = cv.slug(str(dev_id).lower())
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/config_validation.py", line 323, in slug
    raise vol.Invalid('invalid slug {} (try {})'.format(value, slg))
voluptuous.error.Invalid: invalid slug moto_g(6) (try moto_g6)

[edit] - Yup taking out the brackets solved it.


#506

I am glad you solved it. I will also in the meantime add a protection regarding this in Ariela.


#507

i really like where the app is going.
a few points:

  • it seems in normal view i got no sliders.
  • in lovelace view i miss my backgrounds.
  • in lovelace view i dont see my cams
  • even though i never moved my mobile i get a lot of updates from the devicetracker. i had it set to 10m, to avoid that i now set it to 50m
    i dont think its the app but the gps, but i mention it anyway, maybe there is something to change that:

    all gps coordinates i get are between the 4 points, but my house is at the X

#508

Thank you, i am glad you like the app. Regarding lovelace views, please send me your lovelace config so i can replicate it and identify the issue ( and fix ).
Regarding the device tracking, send me the debug file so i can investigate.
Thank you.


#509

you really dont want to see my whole lovelace config :wink:
but the interesting part for you:

title: Huize die Olinde
views:
  - title: CamsEnSet
    id: camsenset
    background: "radial-gradient(skyblue,black)"
    cards:
      - type: entities
        id: moestuinsettings

about the devicetracking i found how to set in debug mode.
is there an easy way to get the debug to you? because its not that big of a deal and i dont want to go trough a lot of trouble :wink:


#510

If you enabled the debug mode, just restart the app and use the contact function from Ariela. It will automatically send me the debug file.

Thank you for that part, can you share a screen-shot also?


#511

i started debug.
how long do you want it?
and how do you want me to send it?
it gives me a load of options if i chose contact.

is there an easy way to get a screenshot to you?


#512

allthough the screeshot wont help.
the background from the view is exactly the same as with the normal HA gui.
just gray.


#513

1 minute of wait is fine and to send just use your email client. About screen-shot, i was referring to a web ui screenshot of HA.


#514

oke, did send you way more then 1 minute :wink:
oh you mean how it looks at the pc?


#515

Thank you for the screenshot, i send you a PM regarding device tracker.


#516

Salut,

Este vreo modalitate de a activa log pentru aplicatie?

Dupa mesajul de conectare (web, nu token) ramane la loading Dashboard si in HA nu apare nimic in log (HA 0.82.1, doar local access, serverul nu este accesibil din afara LAN/Ariela 1.2.3). Web-ui se deschide ok din aplicatie.

Merci


#517

i love to be able to read what you write.
if you want to contact someone in another language then english, please use PM.


#518

Sorry about that.

Just asking if I can access the log for the app (others are just HA/app info).


#519

no problem.
english isnt my native language either, so i can understand why you would like to speak in another language.
but when we do that others cant read it and the forum would be unreadable :wink:


#520

Hello,
You can activate the debug option from Ariela -> Settings -> Activate debug mode. After you enable , restart the app. Reproduce the issue you have and use the contact option to send me the log. About external access, can you access your HA server using 4G or another network? If you can then use the configure external option from HA and it will just work. If you cannot access from external you will have to use a service like duckdns( or go.ro if you are using RCS - RDS) and also you will have to enable port forwarding in your router. Please let me know if you have other questions.


#521

Yeap, I’ve seen a lot of Dutch comments on the forum :smile:


#522

i know.

people love to please me to send me greetings in dutch :wink:
but only at the end of a text in english.

dont worry i would have reakted the same when someone asked it completely in dutch, or german :wink: