Ariela - Home Assistant Android Client


#584

Hello all,
Ariela will be able to change its skin soon:


#585

Hello all,
version 1.2.3.4 is out(and should be available for download in few hours).
What’s new:

  • user management support (delete, edit, add etc)
  • Android P target
  • small UI changes

Please test it and let me know how it goes.
Thank you.


#586

I’m also hit with that weird bug where the play store says there’s a new version constantly.

It’s of that all my other apps updated just fine though?


#587

It think that because i bundled the the wear application this happens. I think i will make a separate application for Android Wear, hopefully fixing the issue.


#588

Is there any way to skip the discovery? It never works for me (don’t know if it’s because I don’t use the default port) but slows me down trying to setting it up manually.


#589

There is not a way currently. I will add such function on next release.


#590

Good idea, most don’t need it and it’s knackered as it is.


#591

Today I tried to log the connection status with HA server.
What I have noticed that when using 4G and not Wi-Fi is that the server status connects and disconnects quiet a phew times. I have the Automatic Reconnect switched on.

Why would it need sometimes 6 minutes to reconnect? When it is trying to connect every 10 seconds.

With 4G:

After that I switched the Wi-Fi on to connect with the server. That seems a very stable connection
(It connected with the Wi-Fi at 08:40pm and stayed like this)
With Wi-Fi:

And than I tried both alternately and seems to work also perfect.
(Switching between 4G and Wi-Fi)


#592

Last thing I tested:

Switched both Wi-Fi and 4G on, than I would normally connect with Wi-Fi. (Which it does)
But that gives some problems. The connections seems to fall away sometimes. And tries to connect with my duckdns adress.


#593

But it surely must find the hassio server on the network? Its just not able to connect is my guess. It has never worked for me. Not sure why? The current Server Not Found message must be confusing for new users as the server is easy to find on the network. The best solution would be if it could identify the server and try http and https on the default port. And just work :slight_smile:


#594

This should be able to see when you are charging, with a slight delay:


#595

Hello all,
Regarding update issue from playstore, it seems that not only Ariela is having this issue, in fact more apps are affected by this Google Play error.

Ionut


#596

Strangely enough, I came across this sensor yesterday. I’ll investigate - my automation experience is increasing rapidly…


#597

Hello all,
Version 1.2.3.5 is out.

What’s new:


#598

The location tracking and presence detection have never worked for me, or my wife. we both have samsung phones. s7 and s9. The app seems to never ever use gps coordinates. Curious if anyone with galaxy phones ever got this functionality to work ?


#599

Are the devices appear in the known_devices.yaml?
What can you do is:

  1. delete the devices from known_devices.yaml
  2. restart Home Assistant
  3. In Ariela -> Settings -> disable / enable location tracking.
  4. Check if the devices are shown in Ariela / HA

Also, can you tell what is Ariela version you are using?
If the problem still persist after you made the steps above, please enable the debug mode, disable / enable again the device tracker in app, and use the contact option to send me the logs.

On my S8 samsung device i do not see any issue regarding device tracking.
Also, be sure on your device have high accuracy setting on the GPS location like this: http://alienmantech.com/blog/wp-content/uploads/2016/05/device-location-settings.png


#600

Anything in the HA log when it tries to connect? I had problems with illegal characters in the default device name.


#601

I am having a peculiar issue with my setup. (Hass.io running in Docker within a Ubunutu VM image)

A few days ago everything was fine. I was able to open the app (pro version) and control what I needed. Then a few things were updated, the Android app and I updated the HA instance to 0.83.3.

Now, when I fire up the Android app the configuration settings are missing so it wants to scan the network. The network scan fails so I enter the IP information manually. I get an error message saying it can’t connect to the server.

I am able to access the HA instance directly via Chrome on my phone so I know it is not a complete connectivity problem. I was also able to install the app on my son’s tablet and it found the server and connected with out fail.

I checked the home-assistant.log file and found this:

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_protocol.py", line 242, in data_received
    messages, upgraded, tail = self._request_parser.feed_data(data)
  File "aiohttp/_http_parser.pyx", line 523, in aiohttp._http_parser.HttpParser.feed_data
aiohttp.http_exceptions.BadStatusLine: invalid HTTP method

Any ideas? Are there any tokens or hashes that are made when a phone connects to the server that I might need to remove in order to reset it? I have reset the app on my phone and uninstalled/reinstalled the app and nothing seems to resolve the issue.

As an aside, I tried to connect yesterday from work via my VPN which tried to search the wireless networks at work before I realized it. My phone also had the December 2018 Android Security update applied this morning.

Thanks.


#602

Can you enable debug mode and send me the logs? If you can’t, i can send you a debug version you can try.


#603

Hello all,
Little teaser: charts