Ariela - Home Assistant Android Client


#985

Thank you, i am glad you like the app, and thank you for reddit post.

I will add this to my TODO list.


#986

Why does the connection string when launching the app for the first time require a port number? My HA lives on port 443 on my external network. It seems that if I feed it an https address without a port number it should default itself to port 443. It’s a strange thing to have to type in and took a few ‘failed attempts’ for me to realize that the port is REQUIRED.


#987

From what i know any connection if you do not specify the port number (even if http or https) it will automatically be 80 ( and this not only in Ariela). I will modify the setup UI to specify the port is required.


#988

The default port for https is 443, and http is 80. I have never had to specify port 443 for any https connection, ever.

Thank you, it would make the configuration process easier to understand.


#989

FWIW, I just had the same experience.

Why not:
http and no port given = 80
https and no port given = 443


#990

Got it, i will see what i can do about this :smiley:


#991

Hai there,

I’ve tested your application and i love it !

But in my case i have a specific setup to access my home-assistant instance from outside : I have my own SSO system in front of home-assistant.

I would love to be able to setup the application to use a specific cookie or header so the requests can reach my home assistant instance.

Would you consider this ? Or suggest a way to not expose to the entire universe my home assistant instance ? (yes i do have a VPN, but i do not want to be connected at all times)

Thanks !


#992

Hello,
I will add this in my TODO list.


#993

I love app. I have some input_booleans that hide and unhide groups. I have after I toggle a toggle I have to reload the page.


#994

Also when I use the web view it says I have an invalid cert even tho it’s not. It would be nice if there was a way to just ignore invalid certs. That would be great that way I wouldn’t have to renew it.


#995

Can you share those input booleans so i can check too? Also do you use native UI or web UI?

If its a self signed certificate then its not to be trusted :stuck_out_tongue: even firefox / chrome give you that warning. Unfortunately the just ignore invalid certificates in android webviews is not allowed by Google ( they require to show a dialog / information of some sort else they do not accept the app in the store)


#996

It’s not self signed. Native UI web ui works fine other than complaining about the cert. image


#997

Thank you for the example. I will do more check regarding that complain.


#998

Ok. Thank you. Also is there any way to hid the sun from the main page?


#999

Currently not. I will add this to my TODO list.


#1000

I just created this script:

netflix:
  alias: Netflix
  sequence:
    - service: switch.turn_on
      entity_id: switch.androidbox
    - delay: 00:00:30
    - service: mqtt.publish
      data:
        topic: homeassistant/sensor/sensor.tx9_pro_apps/startapp
        payload: com.netflix.mediaclient

But the netflix app doesn’t start on my android tv… Is the script correct?
If not how to fix? If yes, why netflix doesn’t start?

EDIT: i changed the topic to:

topic: homeassistant/sensor/tx9_pro_apps/startapp

But with no success…


#1001

Enable debug mode in Ariela please and send me the logs. Thank you


#1002

Hmmm it’s the logfile of android tv box so it’s not easy to extract and send you the logifile…
Is the syntax of the script correct?


#1003

Also I noticed if I have a group the switch for the whole group isn’t shown.


#1004

Here is a script that starts kodi on my phone:

'1547535162322':
  alias: Run Kodi
  sequence:
  - data:
      payload: org.xbmc.kodi
      topic: homeassistant/sensor/android_galaxy_s8__apps/startapp
    service: mqtt.publish

This is already on my TODO list.