Ariela - Home Assistant Android Client


#1045

I noticed the same thing. From some tests (not exaustive yet) it seems that if i configure the connection when i’m on wifi, it works only on wifi ( i can configure it in wifi at home, and have it working if connected via wifi in office). If i configure the same exact parameters when i’m on 4g, it works only if i’m on 4g(if i turno on wifi and connecto to one, Ariela can’t find the server).

I’m already using duckdns, and have the hass exposed, so i have the same address when i’m on wifi at home, at office, or on 4gr.


#1046

Another strange think is that, when using app ui, if i click on a switch, Ariela will open a windows with the switch slider. It’s a double passage that will waste time. Maybe you can have 1-click switch, and 1-keypress (longer click) open the window?

In webview it works as intended. 1-click -> turn on


#1047

Last thing, as we talked about picture-glances and controls, there still is something odd.

This is a picture of the web view

This is a picture of the UI version

As you can see, there are 2 missing controls, one is the “camera” icon, that only opnes a windows with the live camera, and the other is a normal tasmotized sonoff switch like the other that you can see in the picture-glance.

This is the lovelace config:

      - type: picture-glance
        entities:
          - camera.cam_taverna
          - sensor.terrario_temperatura
          - switch.lampada_calore_terrario
          - switch.luce_terrario

Sorry for having 3 separate posts but i think it’s better for replies.

Anyway, do you need help with italian translation? :slight_smile:


#1048

I thought i was done, but i have another strange behaviour with widgets.

I’ve put a couple of HA switches (external lights) on my Huawei Mate S screen.

If i control them via another source, like the browser in my PC, they works fine, following the state of the switch (blue off, yellow on).

But, when i try to control a switch from the widget, things goes bad.

I’ll try to explain

  • Switch/light initial status is “off”.

  • I click on it
  • The androidcaptions Says “switching Luce Portone ON”
  • From PC Browser, the light goes on.
  • The light on the widget blinks yellow for a fracton of second, the blue again. Icon caption says off

  • I click again on the widget.
  • The andorid captions Says “switching Luce Portone ON”
  • The widget turns yellow, and it’s caption says “on”
  • From PC Browser, the light stays on

  • I click again on the widget to turn off the light
  • The andorid captions Says “switching Luce Portone OFF”
  • The widget turns blue, and it’s caption says “off”
  • From PC Browser, the light turns off

BUT, sometimes the widget blinks off then on again (yellow, “on”) while the real light turns off, so i have the light off, and the widget stating it’s on.

The blink thing is desyncing the widget and it’s next click behaviour from the real Home Assistant control.
The blink happens also when turning on, sometimes.

While the widget is desynced, the Ariela UI is not, and it’s showing the real HA status.
So i have a the widget showing ON, and Ariela showing OFF.


#1049

Thank you, this update fixed Wear OS for me. :slight_smile:


#1050

Well you did only half of configuration: Ariela to work only on home wifi
What you have to do is configure external also.
Please let me know if works.

I think you click outside the switch and that’s why you have this behaviour. I will see how i can optimise this thing.

Send me the logs so i can investigate this issue. About italian translation i can send you the strings required to be translated.

Enable permanent notification in Ariela please and check if the behaviour is fixed.

Glad to hear that.


#1051

Well, maybe i’m missed something. I’ve configured Ariela with my https://>mydomain>.duckdns.org:8123 at launch, Didn’t notice there was a “external server” option mandatory to work in both wifi and not. I thought configuring with my duckdns, that works even inside home wifi, was enough.
Now it seems to work, after putting the same url in “configure external”.

No, clicking exactly on the black lamp icon. From what i remember, it wasnt doing that, last time i tried.

Ok i’ll try soon.
For the translation, you are welcome. Send me the strings when you want.

Was already enabled when i did the test today.


#1052

That’s the way Ariela is supposed to work: if connected to home wifi then it will use the server address used when first configuring (in this way if you do not configure external access it will not send your credentials over other wifi networks)

I tried in HA also and clicking the icon from a entity will open more options dialog.

I will send you via PM the file.

I will do more investigations regarding this.


#1053

Hi Ionut, could you explain me what this mean? I don’t understand


#1054

This means you will not be able to turn off your phone screen via Home Assistant.


#1055

Ohh… Thanks for the explanation!


#1056

Np, this was the reason why Ariela was removed from play store. So that’s why i removed it.


#1057

Little teaser for tomorrow update:


#1058

Hello all,

Version 1.2.6.5 is out.
What’s new:

  • tabs now support icons
  • fixed invalid redirect id while setup
  • do not show media players that are hidden
  • added italian localization
  • added VR MQTT support (can send voice commands from phone to HA)
  • clear alarm code text when arming / disarming


#1059

I still have this problem with every switch i have in my lovelace UI

When i click on a switch, no matter if it’s in a picture-glance or glance card

And the icon in the view stays off no matter the state of the real light, while the slider works fine (off-left-dark or on-right-blue as intended).


#1060

Now i understand you you are referring. I will add this fix to my TODO list.


#1061

Hello all,

Version 1.2.6.6 is out.
What’s new:

  • fixed two factor auth issue in web login
  • small thermostat UI changes
  • small tabs UI changes

#1062

Does the device_tracker.device pickup if you are driving etc? (want it to update the ui-lovelace.yaml to show where I am/What I am doing; walking, driving, cycling etc) I’m looking to replace life360 with this app, been playing with it all weekend so far and got so much more out of it than I would the multiple sensors I have running to detect presence and charging states etc.

Keep up the amazing work - about time we got a dedicated app for Android and this is the best around by far!


#1063

Glad to hear you like the app. For now the device tracker do not support such things like walking, driving etc, but i will add this to my TODO list.


#1064

Hello all,
Version 1.2.6.7 is out.
What’s new:

  • better stability for switch entities (flickering should be removed)
  • refresh switch status in advance dialog
  • add support for web links when an entity provide it (ex: update available entity)
  • show sensors values & unit of measurement in badges
  • small tabs UI changes
  • add support for effect list in lights
  • fix issue when brightness control appear for non light entities
  • add support for color temperature

Please test it and let me know how it works and as always thank you for having trust in Ariela.